Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Compound Frame-relay Switch Issues, Help Requested

Hey there Guys & Gals,

I decided to try the compound frame-relay switch configuration using two 2610's. I need to extend the FR clouds to accomendate nine routers. The reference is here: http://www.internetworkexpert.com/resource...frame-relay.htm

For some reason I cannot get it to work for the frame relay traffic ........... I can ping the tunnel0 destinations, so reachability is there for NON-Frame-relay traffic. But I cannot get the FR traffic to pass over the tunnel. I ran some debugs from R1 and its stating that the encapsulation is failing. I also set this up using a serial1/0 {Tunnel source Serial1/0} interface on each FR switch to no avail. Encapsulation is failing.

{R1 - FR1 - FR2 - R7}

Any suggestions???? ..... THANKS!!!!

Configurations:

Frame relay switch #1

********************

interface Serial1/0

description Connected to R3

no ip address

encapsulation frame-relay

clock rate 128000

no fair-queue

frame-relay intf-type dce

frame-relay route 311 interface Serial1/1 113

frame-relay route 312 interface Serial1/2 213

frame-relay route 314 interface Serial1/4 413

frame-relay route 315 interface Serial1/5 513

frame-relay route 317 interface tunnel0 713

frame-relay route 318 interface tunnel0 813

frame-relay route 319 interface tunnel0 913

no shut

!

interface Serial1/1

description Connected to R1

no ip address

encapsulation frame-relay

clock rate 128000

frame-relay intf-type dce

frame-relay route 102 interface Serial1/2 201

frame-relay route 103 interface Serial1/3 301

frame-relay route 104 interface Serial1/4 401

frame-relay route 105 interface Serial1/5 501

frame-relay route 106 interface Serial1/6 601

frame-relay route 113 interface Serial1/0 311

frame-relay route 107 interface tunnel0 701

frame-relay route 108 interface tunnel0 801

frame-relay route 109 interface tunnel0 901

no shut

!

interface Serial1/2

description Connected to R2

no ip address

encapsulation frame-relay

clock rate 128000

frame-relay intf-type dce

frame-relay route 201 interface Serial1/1 102

frame-relay route 203 interface Serial1/3 302

frame-relay route 204 interface Serial1/4 402

frame-relay route 205 interface Serial1/5 502

frame-relay route 206 interface Serial1/6 602

frame-relay route 213 interface Serial1/0 312

frame-relay route 207 interface tunnel0 702

frame-relay route 208 interface tunnel0 802

frame-relay route 209 interface tunnel0 902

no shut

!

<SNIP>

!

!

interface Async65

encap ppp

ip address 177.7.7.1 255.255.255.252

async dynamic routing

async mode dedicated

!

interface Tunnel0

tunnel source Async65

tunnel destination 177.7.7.2

!

<SNIP>

line aux 0

modem InOut

transport input all

rxspeed 128000

txspeed 128000

flowcontrol hardware

line vty 0 4

no login

!

!

end

Frame relay switch #2

********************

interface Serial1/1

description Connected to R7

no ip address

encapsulation frame-relay

clock rate 128000

no arp frame-relay

no frame-relay inverse-arp

frame-relay intf-type dce

frame-relay route 708 interface Serial1/2 807

frame-relay route 709 interface Serial1/3 907

frame-relay route 701 interface tunnel0 107

frame-relay route 702 interface tunnel0 207

frame-relay route 703 interface tunnel0 307

frame-relay route 704 interface tunnel0 407

frame-relay route 705 interface tunnel0 507

frame-relay route 706 interface tunnel0 607

frame-relay route 713 interface tunnel0 317

no shut

!

!

<SNIP>

!

interface Async65

encap ppp

ip address 177.7.7.2 255.255.255.252

async dynamic routing

async mode dedicated

!

interface Tunnel0

tunnel source Async65

tunnel destination 177.7.7.1

!

!

<SNIP>

line aux 0

modem InOut

transport input all

rxspeed 128000

tspeed 128000

flowcontrol hardware

line vty 0 4

no login

!

!

end

4 REPLIES
Bronze

Re: Compound Frame-relay Switch Issues, Help Requested

Hi

The link u provided is not showing anything relevent to this !!!!!!!!!!

The configuration u gave is missing two commands used in frame-relay switch

1."frame-relay switching" in global configuration mode

2."frame-relay intf-type nni" on both the interface between the FR switch..

Check if this is there

arun

Hall of Fame Super Silver

Re: Compound Frame-relay Switch Issues, Help Requested

darral

There are some inconsistencies in the config that you post and I suspect that they are at the heart of your problem. For example I see that switch1 is sending into the tunnel DLCIs 713, 813, 913, 701, 801, 901, 702, 802, and 902. But I do not see SW2 do anything with those DLCIs. I do see 701 and 702 on SW2 but they are on the serial side not the tunnel side. And there are similar mismatches on the DLCIs used on the tunnel by SW2.

If I am understanding what you are attempting to do you send it into the tunnel with a DLCI and the other switch must take that DLCI from the tunnel and switch it out a physical interface.

HTH

Rick

New Member

Re: Compound Frame-relay Switch Issues, Help Requested

I had to chop up the configuration to comply with forum character limitations.

here is the full configurations:

http://www.4shared.com/dir/5608717/dff87cb1/sharing.html

New Member

Re: Compound Frame-relay Switch Issues, Help Requested

Here is another location of the full configuration: THANKS!!!

http://forum.internetworkexpert.com/ubbthreads.php?ubb=showflat&Number=22049&page=0#Post22049

276
Views
0
Helpful
4
Replies
CreatePlease to create content