Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

Conditional default route - RIP

Hello,

I am tring to inject a default route in RIP v2 with a condition of only if

Int Loopback0 up

int loopback 1 down

Now i can successfully do this with any FAKE route other than 0.0.0.0 , when i use 0.0.0.0 it initally works until the the loopback1 interface is enabled and then shutdown again to meet the boolan condition.

R3 config:

track 3 list boolean and

object 1

object 2 not

interface Loopback0

ip address 3.3.3.3 255.255.255.0

interface Loopback1

ip address 33.33.33.33 255.255.255.0

shutdown

track 1 ip route 3.3.3.0 255.255.255.0 reachability

track 2 ip route 33.33.33.0 255.255.255.0 reachability

ip route 0.0.0.0 0.0.0.0 Null0 track 3

ip prefix-list Null permit 0.0.0.0/0

router rip

version 2

network 10.0.0.0

default-information originate route-map default

no auto-summary

route-map default permit 10
match ip address prefix-list Null

R3#sh track

Track 1

  IP route 3.3.3.0 255.255.255.0 reachability

  Reachability is Up (connected)

    1 change, last change 00:43:39

  Delay up 2 secs, down 2 secs

  First-hop interface is Loopback0

Track 2

  IP route 33.33.33.0 255.255.255.0 reachability

  Reachability is Down (no route)

    17 changes, last change 00:14:06

  Delay up 2 secs, down 2 secs

  First-hop interface is unknown

Track 3

  List boolean and

  Boolean AND is Up

    30 changes, last change 00:14:06

    object 1 Up

    object 2 not Down

  Tracked by:

    STATIC-IP-ROUTING 0

R1#sh ip route rip | in 0.0.0.0/0

R2#sh ip route rip | in 0.0.0.0/0

Fake route other than 0.0.0.0

R3#

ip route 100.100.100.100 255.255.255.255 Null0 track 3

ip prefix-list Null permit seq 5 100.100.100.100/32

R1#sh ip route rip | in 0.0.0.0/0

R*   0.0.0.0/0 [120/1] via 10.1.234.3, 00:00:06, FastEthernet0/0

R2#sh ip route rip | in 0.0.0.0/0

R*   0.0.0.0/0 [120/1] via 10.1.234.3, 00:00:15, FastEthernet0/0

what am I missing, or not referancing here?

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.       

Please don't forget to rate any posts that have been helpful. Thanks.
1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Conditional default route - RIP

Hi,

if I redistribute the static default pointing to null0 and track this route then it works:

R1(config-if)#do sh run | s ip route|track|route-map|ip prefix|router rip

track 1 interface Loopback0 line-protocol

track 2 interface Loopback1 line-protocol

track 3 list boolean and

object 1

object 2 not

router rip

version 2

redistribute static route-map DEFAULT-ROUTE

network 10.0.0.0

default-information originate route-map DEFAULT-ROUTE

no auto-summary

ip route 0.0.0.0 0.0.0.0 Null0 track 3

ip prefix-list test seq 5 permit 0.0.0.0/0

route-map DEFAULT-ROUTE permit 10

match ip address prefix-list test

route-map DISTR permit 10

match interface Null0

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
4 REPLIES
Purple

Conditional default route - RIP

Hi,

this is what I did and it works:

R1(config-if)#do sh run | s ip prefix|route-map|track|router rip

track 1 interface Loopback0 line-protocol

track 2 interface Loopback1 line-protocol

track 3 list boolean and

object 1

object 2 not

router rip

version 2

network 10.0.0.0

default-information originate route-map DEFAULT-ROUTE

no auto-summary

ip route 169.254.0.0 255.255.0.0 Null0 track 3

ip prefix-list test seq 5 permit 169.254.0.0/16

route-map DEFAULT-ROUTE permit 10

match ip address prefix-list test

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Conditional default route - RIP

Hello

Thanks for the reply -

I also  get the same result with any FAKE route I use, APART from when try using

ip route 0.0.0.0 0.0.0.0 Null0 track 3

ip prefix-list Null permit 0.0.0.0/0

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.
Purple

Conditional default route - RIP

Hi,

if I redistribute the static default pointing to null0 and track this route then it works:

R1(config-if)#do sh run | s ip route|track|route-map|ip prefix|router rip

track 1 interface Loopback0 line-protocol

track 2 interface Loopback1 line-protocol

track 3 list boolean and

object 1

object 2 not

router rip

version 2

redistribute static route-map DEFAULT-ROUTE

network 10.0.0.0

default-information originate route-map DEFAULT-ROUTE

no auto-summary

ip route 0.0.0.0 0.0.0.0 Null0 track 3

ip prefix-list test seq 5 permit 0.0.0.0/0

route-map DEFAULT-ROUTE permit 10

match ip address prefix-list test

route-map DISTR permit 10

match interface Null0

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Re: Conditional default route - RIP

Hello

It indeed does -..NOW looking back at my config I also tried redistribute the static route-map but my reference to the route-map was wrong!

instead of defaulti was referencing Default -hence I concluded that didn't work either.

Appreciate the assistance

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.
227
Views
0
Helpful
4
Replies
CreatePlease to create content