Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Config commands for T1 services turn-up 2811?

Greetings,

I could use some assistance figuring out the config commands for turning up a GC 384kbps T1 using a cisco 2811 router. Sorry, I'm a newb who isn't completely sure of the neccessary config commands to complete the turn-up and T1 configuration. Any help would be appreciated. An edited version of the routers relevant config is below.

This router has a T1/PRI dual port WIC and was previously setup to use an old T1 and PRI both of which have been disconnected. (configuration for the old connections is still in the config) I wil only be turning-up the data T1 for the first port in the dual port WIC and not a PRI.

! Last configuration change at 08:53:38 UTC Fri Sep 8 2006

! NVRAM config last updated at 10:40:37 UTC Mon Aug 14 2006

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

service sequence-numbers

!

hostname XXXXXXXX

!

boot-start-marker

boot-end-marker

!

logging buffered 4096 debugging

!

no aaa new-model

!

resource policy

!

clock timezone UTC -6

clock summer-time UTC recurring

network-clock-participate wic 2

network-clock-select 1 T1 0/2/0

!

-config removed for briefity-

!

controller T1 0/2/0

framing esf

linecode b8zs

pri-group timeslots 1-12,24

!

controller T1 0/2/1

framing esf

linecode b8zs

!

-config removed for briefity-

!

!

!

!

!

!

interface Loopback0

ip address 192.168.254.1 255.255.255.0

!

interface FastEthernet0/0

description $ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$$ETH-LAN$

ip address 10.0.5.1 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.0.5.1

!

interface FastEthernet0/1

description $ETH-WAN$

ip address 192.168.2.9 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0/0

ip address XXX.XX.XX.XXX 255.255.255.252

!

interface Serial0/2/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

ip route 0.0.0.0 0.0.0.0 10.0.5.15

ip route 192.168.10.0 255.255.255.0 10.0.5.2 200

The new T1 should use the same signaling and framing (B8ZS/ESF) and the network uses OSPF area 1. I'm assuming that all I would need to do is have someone plug the T1 connection into the proper T1 port on the dual T1/PRI WIC card, change the serial 0/0/0 ip to the proper internet ip, set the bandwith value on the S0/0/0 and configure ospf with

router ospf 1

network serial ip reverse mask

network internal network ip reverse mask

Am I missing anything?

Thanks.

Jon

5 REPLIES
Silver

Re: Config commands for T1 services turn-up 2811?

Hi ,

If you want to use ospf in your network then it should be connected to area 0..let assume that your ip belongs to area 0 and your network is in area 1 then config look likes..

controller T1 0/2/0

framing esf

linecode b8zs

pri-group timeslots 1-31 speed 64

interface Serial0/2/0:23

ip address x.x.x.x

encapsulation hdlc

bandwidth 2048

router opsf 1

network x.x.x.x wildcard area 0

network x.x.x.x wildcard area 1

you can use nat for translating inside ip's to public ip's and access-list for controlling no.of ip's for accessing internet.

Thanks,

satish

New Member

Re: Config commands for T1 services turn-up 2811?

Thanks for the help.

My fault, I checked other router configs and they are all in ospf area 0. I mistook the process id in the command router ospf 1 for the area.

Does the serial connection encapsulation default to hdlc? A T1 worked previously without specifying the encapsulation. This will be the same type of GC managed MPLS IP vpn connection that it had previously, it won't be able to connect directly to the internet per se, just our private network, all internet traffic is routed out one connection.

Silver

Re: Config commands for T1 services turn-up 2811?

hi ,

Default encapsulation for serial is hdlc.If you change the encapsulation then you can use "encapsulation PPP " under serial interface.

Thanks,

satish

New Member

Re: Config commands for T1 services turn-up 2811?

Gotcha.

All of our routers should be in ospf area 0.

After I change the serial IP to the new IP and configure ospf with

router ospf 1

network new public T1 ip inverse subnet mask area 0

network internal ip inverse mask area 0

then should I be all set?

Silver

Re: Config commands for T1 services turn-up 2811?

Jon:

I'm not sure if I am reading this correctly or not, but you state that this line is not an ISDN PRI. However your config shows timeslots 1-12 and 24. If this is not an ISDN line anymore then you will not need the 24th timeslot. Assuming that the 384k are laid out in the first 8 timeslots of 64k then you need to remap your DS0's for the T-1. If not then you need to get with your provisioner and verify the timeslot mappings. You will need to remove the PRI timeslot command and replace with channel group command for the controller. Also for the serial interface you need to remove all ISDN related commands. The default encap is HDLC for a serial link. Please respond with further questions we will assist you further...Phil

708
Views
0
Helpful
5
Replies
CreatePlease to create content