Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

config for bgp

As per as scenario router 2 and router 4 are the routers which are located in my comapny.

Router 2 is active router and router 4 is the standy router.Router 0 and router 5 are isp router

My requirement is that the packet which are going out ofmy  network should go from Router 2.

And packet coming from isp to my network should come via Router 4.

I have implemented As path prepend on router 2 so that packet comming from isp should come from Router 4.

What happens if i donot create ibgp neighbourship betwen router 2 qnd router 4?

Please let me know if the config is correct or any changes need to be done ?

router2#show running-config

Building configuration...

Current configuration : 604 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname router2

!

!

!

!

!

!

interface FastEthernet0/0

ip address 172.18.2.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 101.177.157.38 255.255.255.0

duplex auto

speed auto

!

interface Vlan1

no ip address

shutdown

!

router bgp 54xxx

bgp log-neighbor-changes

no synchronization

neighbor 101.177.157.37 remote-as 9999

neighbor 172.18.2.2 remote-as 54xxx next-hop-self

neighbour 101.177.157.37 route-map rsap out

network 172.18.0.0

!

ip classless

!

!

!

interface fa0/0

standy 1 priority 200

standy 1 ip 172.18.2.10

standy 1 prempt

standy 1 track fa0/1

access-list 1 permit 172.18.2.0

route-map rsap permit 10

match ip address 1

set as-path prepend 100 100

!

!

!

!

line con 0

line vty 0 4

login

!

!

!

end

---------------------------------------------------------------------------------------------------------------------------------------------------

Router4 configuration

router4#show runn

router4#show running-config

Building configuration...

Current configuration : 608 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname router4

!!

!

interface FastEthernet0/0

ip address 172.18.2.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 102.177.157.43 255.255.255.0

duplex auto

speed auto

!

interface Vlan1

no ip address

shutdown

!

router bgp 54xxx

bgp log-neighbor-changes

no synchronization

neighbor 102.177.157.41 remote-as 8888

neighbor 172.18.2.1 remote-as 54xxx

neighbor 172.18.2.1 next-hop-self

network 172.18.2.0

int fa0/0

standby 1 ip 172.18.2.10

standy 1 priority 150

standy 1 preempt

!

ip classless

!

!

!

!

!

!

!

line con 0

line vty 0 4

login

!

!

!

end

7 REPLIES

config for bgp

Hi Prashant,

Your requirement as i understand is :-

1) To influence the outbound traffic to take R2.

2) To influence the inbound to take the path via R4.

Now, to prefer an ISP for outbound you need to set a higher local preference to the neighbor. So, that downstream traffic takes R2 to R0 path.

To prefer an ISP for inbound, you have done it correctly using AS-path Prepending.

Question of iBGP being required. I would say "yes". Because if the primary path was to fail, downstream devices would not know where to forward the request. HSRP tracking might be enabled for interface, nowadays it's all ethernet so the chances to the connected interface going down is rare. You may need to think of running IP SLA along with it to get this working else.

If you were to run iBGP between R2 & R4, then you have no such issues. Assume that the path from R2 fails, you would have another path via R4. Still the packets will be forwarded to the Active router (i.e R2) & based on the BGP table it knows the next-hop is via it's iBGP peer. It simply forwards.

Hope this helps.

Regards

Vivek

New Member

config for bgp

hi,, dear...

i show ur configuration... just configure there inbound and outbound... when ur packet go out side there configure outbound means data out ack in and where u want to receive ur packet that side configure inbound means data in ack out.... and u need to configure ibgp for backup path or ur internal router communication .. hope this is needful

.

New Member

config for bgp

hi vivek,

Thanks a lot

THe think if the link on active router it is taking too much to converge.

If i create ibgp neighbour it might not take too much og time right ?

I have created local prefrence below is the direction right ? ie in or out.

router bgp 54xxx

neighbour 101.177.157.37 remote-as 9999

neighbour 101.177.157.37 route-map rsa in

ip prefix-list default seq 5 0.0.0.0/0

route-map rsa permit 10

match ip prefix-list default

set local-prefence 600

config for bgp

You are right. Using iBGP will improve your convergence. Local preference needs to be applied in "inbound direction" & you have done it correctly.

New Member

config for bgp

hi vivek

I have congigured sla for the wan link on active router .But the wan link and lan linl was up only. suddenly standy become

active router.Does sla have any disadvnatage does frequency whic i have given have any eefect? please find the logs and config

of sla

Jun 11 06:00:47.571: %HSRP-5-STATECHANGE: GigabitEthernet0/0 Grp 1 state Active -> Speak

Jun 11 06:00:50.351: %TRACKING-5-STATE: 123 ip sla 1 reachability Down->Up

Jun 11 06:00:52.907: %HSRP-5-STATECHANGE: GigabitEthernet0/0 Grp 1 state Speak -> Active

Jun 11 07:28:13.830: %TRACKING-5-STATE: 123 ip sla 1 reachability Up->Down

Jun 11 07:28:14.642: %HSRP-5-STATECHANGE: GigabitEthernet0/0 Grp 1 state Active -> Speak

Jun 11 07:28:18.830: %TRACKING-5-STATE: 123 ip sla 1 reachability Down->Up

Jun 11 07:28:20.250: %HSRP-5-STATECHANGE: GigabitEthernet0/0 Grp 1 state Speak -> Active

Jun 11 07:29:03.870: %TRACKING-5-STATE: 123 ip sla 1 reachability Up->Down

Jun 11 07:29:05.986: %HSRP-5-STATECHANGE: GigabitEthernet0/0 Grp 1 state Active -> Speak

Jun 11 07:29:08.870: %TRACKING-5-STATE: 123 ip sla 1 reachability Down->Up

Jun 11 07:29:11.458: %HSRP-5-STATECHANGE: GigabitEthernet0/0 Grp 1 state Speak -> Active

Jun 11 07:29:53.910: %TRACKING-5-STATE: 123 ip sla 1 reachability Up->Down

Jun 11 07:29:54.506: %HSRP-5-STATECHANGE: GigabitEthernet0/0 Grp 1 state Active -> Speak

ip sla 1

icmp-echo 101.177.157.37

threshold 2000

frequency 10

ip sla schedule 1 life forever start-time now

track 123 ip sla 1 reachability

standby 1 track 123

config for bgp

Your config looks ok. I have seen a similar issue with my own setup with IP SLA, it keeps dropping off without any genuine reason. I would suggest to avoid this feature (my personal opinion). Using iBGP would be a more viable solution for this scenario.

New Member

config for bgp

Thanks

From firewaall i have default route to virtual ip.

If i do ibgp it might create a problem ?

when i do show ip route there is a default route to isp with hop of neigh ip.

shall i implemet object tracking instead of ibgp?

If  i remove ipsla does it work smootly ?

353
Views
0
Helpful
7
Replies
CreatePlease to create content