Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Config on 2950 Dual Internet Connections without BGP enabled ISP

Hi, I have come across this solution to dual internet connections, c2950-i6k2l2q4-mz.121-22.EA14.bin is the IOS and the router is a 2950 Dual Wan model.

I don't know alot about this stuff I'll admit, but it is on the default configuration with IP 192.168.27.7 255.255.255.0, gateway at 192.168.27.8.  The hostname below is something I don't know exactly what it means but my guess is its the line at the command prompt with the name.

It has VLAN1 with fa0/1-24, gi0/1 - 2.

This is the script but I don't know why its not taking the commands as at ip sla monitor 1 I get invalid command error. What do the ! mean are they comments and not entered?

Which interface should this be put onto.

If anyone can help I would greatly like it to work though from the ISP router 192.168.27.1 (proity) and Engenius router 192.168.27.2 (second)  Thank you..

hostname Router
!

ip cef

!####Establish sla monitors for use in tracking objects####!

ip sla monitor 1
  type echo protocol ipIcmpEcho 12.34.45.1
  threshold 3
  frequency 5

ip sla monitor schedule 1 life forever start-time now

ip sla monitor 2
  type echo protocol ipIcmpEcho 23.34.56.1
  threshold 3
  frequency 5

ip sla monitor schedule 2 life forever start-time now

!

!####Configure Tracking objects (referencing IP SLA monitor’s above)####!

track 101 rtr 1 reachability
!
track 102 rtr 2 reachability
!
!
!
!
!####Configure Interfaces with NAT####!

interface FastEthernet0
  ip address 192.168.1.254 255.255.255.0
  ip nat inside
!
interface s0/0
  ip address 12.34.45.2 255.255.255.0
  ip nat outside
!
interface s0/1
  ip address 23.45.67.2 255.255.255.0
  ip nat outside
!
ip classless

!####Configure gateway of last resort with tracking objects####!
ip route 0.0.0.0 0.0.0.0 12.34.45.1 track 101
ip route 0.0.0.0 0.0.0.0 23.45.67.1 track 102

!####Configure NAT statements for most outbound traffic####!
ip nat inside source route-map ISP1 interface s0/0 overload
ip nat inside source route-map ISP2 interface s0/1 overload

!####Configure NAT statements for your mail server####!
!(remember to setup dns for mail on both public IP addresses)!

ip nat inside source static tcp 192.168.1.10 25 12.34.45.2 25 route-map ISP1 extendable
ip nat inside source static tcp 192.168.1.10 25 23.45.67.2 25 route-map ISP2 extendable
!
!
access-list 10 permit 192.168.1.0 0.0.0.255
!
!####Configure route maps for reference in NAT statements####!

route-map ISP2 permit 10
  match ip address 10
  match interface s0/1

!
route-map ISP1 permit 10
  match ip address 10
  match interface s0/0
!

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Config on 2950 Dual Internet Connections without BGP enabled ISP

The 2950 is a layer 2 switch. You could perhaps use it to establish the connections to the ISPs to get the traffic into your network. But they are only layer 2 devices so that can no do any routing and will not support any functions such as IP SLA. To do the routing for both ISPs you would need some layer 3 device (perhaps a router or some layer 3 switch).

HTH

Rick

4 REPLIES
Hall of Fame Super Silver

Config on 2950 Dual Internet Connections without BGP enabled ISP

I am puzzled. You talk about using 2950 Dual Wan. But the Cisco 2950 that I know about is a layer 2 Ethernet switch. You seem to show something with 2 serial interfaces. But I do not know of any 2950 with serial interfaces. Perhaps you can clarify what equipment you are using?

HTH

Rick

New Member

Config on 2950 Dual Internet Connections without BGP enabled ISP

Well, I do have a lack of knowledge, so I gather the 2950 can not be configured to have redundancy of two ISP's.

When I said about the dual WAN is am refurring to the gigabyte ports 0/1 & 0/2, which I thought were WAN ports.  My mistake sorry.

Hall of Fame Super Silver

Config on 2950 Dual Internet Connections without BGP enabled ISP

The 2950 is a layer 2 switch. You could perhaps use it to establish the connections to the ISPs to get the traffic into your network. But they are only layer 2 devices so that can no do any routing and will not support any functions such as IP SLA. To do the routing for both ISPs you would need some layer 3 device (perhaps a router or some layer 3 switch).

HTH

Rick

New Member

Config on 2950 Dual Internet Connections without BGP enabled ISP

Thanks for the pointers, its has helped.

640
Views
0
Helpful
4
Replies
CreatePlease login to create content