Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Config register problem

I have a 2621 router and I am trying to change my config register value to 0x2102 (config-register 0x2102) however whenever I change it it comes back as 0x3102. I even tried to change the jumper setting but once it boors up it takes the 0x3102 as the register value.

This is what I get after setting the jumper value, eventhough it shows the 0x2102 as current value however its not because I have to change by baud rate to 1200 once it reboots completed. I have tried 12.0 and 12.2 IOS version

{"Configuration register is 0x2102 will be 0x3102 at next reload)")

8 REPLIES
Hall of Fame Super Gold

Re: Config register problem

Muhammad

I think I had a similar problem one time. Please look in your configuration under line console 0 and see if there is a speed command configured. If there is remove it and try to set the config register again.

If that does not fix it, please capture and post the output of a terminal session that includes a show version, a config t, config-register 0x2102, and a show version.

HTH

Rick

Community Member

Re: Config register problem

You were right the speed on cosole wast set 1200 and that fixed the problem. I appreciate your help Thanks

Community Member

Re: Config register problem

I have had this problem on a Cisco 877 router and have taken the advice. The problem I was having affected the stability of the router with it sometimes hanging. However, now I have resolved this I still get the output

Configuration register is 0x2102 (will be 0x3102 at next reload). I have even tried hard setting the config -register again but it still has this output. Is it safe to reload or is this risky?

Hall of Fame Super Gold

Re: Config register problem

Jeremy

Have you done a copy running-config startup-config (or a write mem) since making the config changes?

Can you post the output of show run | begin line con

also the output of show start | begin line con

and the output of show version?

Perhaps with this information we will be better able to judge how safe it is to reload.

HTH

Rick

Community Member

Re: Config register problem

Hi Rick,

Thanks for your reply. Please see output below.

Peacocks_Store567#sho run | begin line con

line con 0

password

login

no modem enable

transport output all

line aux 0

script dialer DIALOUT

transport input all

transport output all

flowcontrol hardware

line vty 0 4

password

logging synchronous

login

transport input all

transport output all

!

scheduler max-task-time 5000

sntp server 88.151.217.68

end

Peacocks_Store567#sho start | begin line con

line con 0

password Convergence1999

login

no modem enable

transport output all

line aux 0

script dialer DIALOUT

transport input all

transport output all

flowcontrol hardware

line vty 0 4

password Convergence1999

logging synchronous

login

transport input all

transport output all

!

scheduler max-task-time 5000

sntp server 88.151.217.68

end

Peacocks_Store567#sho ver

Cisco IOS Software, C870 Software (C870-ADVSECURITYK9-M), Version 12.4(4)T8, REL

EASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Sat 11-Aug-07 03:34 by khuie

ROM: System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE

Peacocks_Store567 uptime is 18 hours, 1 minute

System returned to ROM by reload at 15:36:04 GMT Mon Nov 19 2007

System restarted at 15:42:47 GMT Mon Nov 19 2007

System image file is "flash:c870-advsecurityk9-mz.124-4.T8.bin"

Last reload reason: Reload Command

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Cisco 877 (MPC8272) processor (revision 0x300) with 118784K/12288K bytes of memo

ry.

Processor board ID FCZ114490M9

MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10

4 FastEthernet interfaces

1 ATM interface

128K bytes of non-volatile configuration memory.

24576K bytes of processor board System flash (Intel Strataflash)

Configuration register is 0x2102 (will be 0x3102 at next reload)

Hall of Fame Super Gold

Re: Config register problem

Jeremy

Thanks for posting the information that I requested. It does clearly show that there is not a speed command under the line console 0. So I am surprised that show version shows that the config register will change at reload. I have tried to reproduce the symptoms on a router I have access to and can not produce the symptom.

I am not sure what to suggest next. You might try setting the config register one more time (just in case there was a typo when you did it before). Or you might post the entire router config so we can see if there might be something else causing this. Or you might just go ahead and reload the router. I believe that the only thing that might happen would be the possibility that the console speed would change after reload and you would have to change speed in your terminal emulator software to access the console. I do not see any impact beyond that (and I am not entirely sure that this would happen).

HTH

Rick

Community Member

Re: Config register problem

Hi Rick,

Please find complete config:

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Peacocks_Store567

!

boot-start-marker

boot-end-marker

!

logging buffered 50000 debugging

enable secret

!

no aaa new-model

!

resource policy

!

clock timezone GMT 0

clock summer-time BST recurring

ip subnet-zero

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 90.x.x.1 90.5.67.159

ip dhcp excluded-address 90.x.x.169 90.5.67.254

!

ip dhcp pool Peacocks

import all

network 90.x.x.0 255.255.255.0

default-router 90.5.67.200

dns-server 89.10.2.244

lease 0 12

!

!

!

chat-script DIALOUT ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 120 CON

NECT \c

modemcap entry MY_USR_MODEM:MSC=&F0X2L1M0S0=1

!

!

!

!

track 100 interface ATM0 line-protocol

!

class-map match-all SAREBO

match access-group 1

!

!

policy-map shapetraffic

class SAREBO

bandwidth 200

class class-default

fair-queue

!

!

!

!

!

interface Loopback1

description MGMT Address

ip address 50.x.x.67 255.255.255.255

!

interface ATM0

backup delay 10 0

backup interface Dialer2

no ip address

no atm ilmi-keepalive

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address 90.x.x.200 255.255.255.0

ip policy route-map clear-df-bit

!

interface Async1

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 2

async mode dedicated

routing dynamic

!

interface Dialer2

bandwidth 64

ip address negotiated

encapsulation ppp

dialer pool 2

dialer remote-name peacocksbackup

dialer idle-timeout 180

dialer string 08456629011

dialer hold-queue 10

dialer-group 2

fair-queue

no cdp enable

ppp authentication pap chap callin

ppp chap hostname store567_pea@vpn-connect.co.uk

ppp chap password

!

interface Dialer1

bandwidth 288

ip address negotiated

encapsulation ppp

dialer pool 1

dialer idle-timeout 0

dialer persistent

no cdp enable

ppp authentication chap callin

ppp chap hostname store567_pea@vpn-connect.co.uk

ppp chap password

service-policy output shapetraffic

!

router rip

version 2

network 10.0.0.0

network 50.0.0.0

network 90.0.0.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1 track 100

ip route 0.0.0.0 0.0.0.0 Dialer2 200

!

no ip http server

no ip http secure-server

!

kron occurrence shopclosed at 17:35 recurring

policy-list shutdialer2

!

kron occurrence shopopen at 8:25 recurring

policy-list opendialer2

!

kron policy-list opendialer2

cli ifchange d2 on

!

kron policy-list shutdialer2

cli ifchange d2 off

!

access-list 1 permit 90.5.67.100

access-list 199 permit ip any any

dialer-list 2 protocol ip permit

snmp-server community convergence RO

snmp-server enable traps tty

no cdp run

route-map clear-df-bit permit 10

match ip address 199

set ip df 0

!

!

control-plane

!

!

line con 0

password

login

no modem enable

transport output all

line aux 0

script dialer DIALOUT

transport input all

transport output all

flowcontrol hardware

line vty 0 4

password

logging synchronous

login

transport input all

transport output all

!

scheduler max-task-time 5000

sntp server 88.151.217.68

end

Hall of Fame Super Gold

Re: Config register problem

Jeremy

Thank you for posting the config. I have looked at it and I do not see anything that clearly explains the symptom. The one thing I see that I wonder about it the command:

no modem enable

I do not normally see that in configs under line con 0. Perhaps it is normal on this platform, but it is a surprise to me. I wonder what would happen if you remove that command?

Otherwise I do not see anything else to do other than to reboot the router and see what happens.

HTH

Rick

545
Views
0
Helpful
8
Replies
CreatePlease to create content