Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Configure 837 router

I wanted to configure the 837 router as DHCP server using the Web interface for I do not know how to do it in a console but I just get "Loading Cisco Router Web Setup. Please wait...." page. It seems it can't load it.

Thanks

4 REPLIES

Re: Configure 837 router

Check the browser that is had the right plug-in, in the meantime here is a sample configuration on CLI:

ip dhcp excluded-address 192.168.1.1

ip dhcp pool test

network 192.168.1.0 255.255.255.0

domain-name anynet.com

default-router 192.168.1.1

dns-server 10.1.1.1 10.1.1.2

lease 3

All you have to do it copy and paste the above but of course you need to replace the ip addresses.

Community Member

Re: Configure 837 router

Thanks, I was able to paste the config you gave me and the the router is now giving IP address to my laptop but I couln't ping www.cisco.com or www.yahoo.com nor surf the net.

Community Member

Re: Configure 837 router

thanks a lot! I am newbie on the cisco router.... since I can't access the web page for 831 to configure it, I did what you told me. I can ping the http://www.cisco.com or http://www.yahoo.com on the router but I can't ping it when I am on the computer on the command prompt. I can see that it is getting the address from the cisco dhcp. Here is the configuration file on my 831 router.

The router is connected to a ADSL router with only 1 public IP. So the 10.x.x.x is a local address from the ADSL router.

The 10.0.0.2 is the default gateway configured on the ADSL router.

===============================================

Current configuration : 1346 bytes

!

version 12.3

no service pad

!

hostname ddi-dhcp

!

!

no aaa new-model

ip subnet-zero

no ip routing

20x.x.x.x

ip dhcp excluded-address 11.0.0.2 11.0.0.10

ip dhcp excluded-address 11.0.0.200 11.0.0.254

!

ip dhcp pool LAN

network 11.0.0.0 255.255.255.0

dns-server 20x.x.x.x

default-router 11.0.0.1

!

ip audit notify log

ip audit po max-events 100

no ftp-server write-enable

interface Ethernet0

ip address 11.0.0.1 255.255.255.0

ip nat inside

no ip route-cache

!

interface Ethernet1

ip address 10.0.0.5 255.255.255.0

ip nat outside

no ip route-cache

duplex auto

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

duplex auto

speed auto

!

interface FastEthernet3

no ip address

duplex auto

speed auto

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

ip default-gateway 10.0.0.2

ip nat inside source list 7 pool no overload

ip classless

ip http server

no ip http secure-server

!

access-list 7 permit 11.0.0.0 0.0.0.255

!

line con 0

no modem enable

line aux 0

line vty 0 4

!

scheduler max-task-time 5000

!

end

==============================================

Thanks for the help....

Re: Configure 837 router

I see two issues

1.)ip routing is not enabled

conf t

ip routing

2.) you need a default route

conf t

ip route 0.0.0.0 0.0.0.0 10.0.0.2

Please rate helpful posts.

117
Views
3
Helpful
4
Replies
CreatePlease to create content