Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Configure Cisco 1841 fast ethernet to WAN and LAN link

Hi guys,

I am trying to install this new Cisco 1841 as a replacement to Cisco 877, site just recently upgraded to fiber optics so we need to replace the router to Cisco 1841. There is a singtel router before the cisco router...

Do I just connect the WAN cable to the fast ethernet port? then the LAN cable to another fast ethernet port?

and set static ip?

sample:

interface Fa0/0

description WAN LINK

ip address 201.222.222.174 255.255.255.0

duplex auto

speed auto

interface Fa0/1

description LAN LINK

ip address 10.10.10.1 255.255.255.0

duplex auto

speed auto

ip router 0.0.0.0 0.0.0.0 201.222.222.174

Is this the only thing I need to do?

Really need your help.

Regards,

Jenna

6 REPLIES

Configure Cisco 1841 fast ethernet to WAN and LAN link

Frist of all default gateway can not be same as interface IP need to identify next hop. Then it actually depend upon what you are trying to do ,if users need internet access then NAT will be there. For security you might need to configure ACL .

For management you need to configure SSH/ VTY and rest of the things.

So far cabling is concern yes one port will go to WAN (SP) equipment and one port of router will go to switch where users are connected but all depends.

Untill unless you do not tell what will be the goal helping would be difficult.

Thanks

Ajay

Configure Cisco 1841 fast ethernet to WAN and LAN link

Thanks for your response Ajay.

Sorry, my mistake on the sample config, let me correct this:

interface Fa0/0

description WAN LINK

ip address 201.222.222.174 255.255.255.0

duplex auto

speed auto

interface Fa0/1

description LAN LINK

ip address 58.xx.xx.1 255.255.255.0

duplex auto

speed auto

ip router 0.0.0.0 0.0.0.0 201.222.222.173

Also, their LAN IP should be accessible over the internet as the other branch office need to access one of the terminal server (58.xx.xx.6). I tried to compare the config on the old router (cisco 877) but there is no NAT or ACL configured, maybe because there is a firewall behind the router.

Here is the config on the old router:

Building configuration...

Current configuration : 959 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$3ELz$yf9vgIgb9IFt4d/qENIUh0

!

no aaa new-model

!

!

dot11 syslog

ip cef

!

!

--More--         !

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

ip address 203.222.222.174 255.255.255.252

pvc 8/35

  encapsulation aal5snap

!

--More--         !

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address 58.xx.xx.1 255.255.255.240

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 203.222.222.173

!

no ip http server

no ip http secure-server

So I guess I only need to configure the WAN interface and LAN interface then static route?

Thanks.

VIP Super Bronze

Configure Cisco 1841 fast ethernet to WAN and LAN link

Hi,

Since you are using 10.10.10.1 255.255.255.0 address your need to NAT it. You don't need to NAT in your other location since both inside and outside IPs are public.  Other then that your config is ok.  Can you ping the SP's router from your router?

HTH

Re: Configure Cisco 1841 fast ethernet to WAN and LAN link

Hi Jenna,

Try to double check your interface's subnet mask (comparing to 877):

interface Fa0/0

description WAN LINK

ip address 201.222.222.174 255.255.255.252

interface Fa0/1

description LAN LINK

ip address 58.xx.xx.1 255.255.255.240

As suggested, perform ping tests towards the ISP router and your firewall, which I would assume is doing NAT for your 10.1.1.0/24 subnet.

Sent from Cisco Technical Support iPhone App

New Member

Hi all good guy!!I have issue

Hi all good guy!!

I have issue as Forbes. So, I want to know which more rule that can me access to internet?

For me I am already create default route but still cannot access.

 

Please help me!

New Member

If you are using private ip

If you are using private ip addresses then you need to set NATing in order to access the internet.

If possible could you please send the config of the router, so it will help us to find the problem,

 

Vishal--

5476
Views
0
Helpful
6
Replies