Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

configure cisco router 2901 as pppoe modem

hi, i used web based interface to configure ppoe on the router 2901, but it does not seems to be enabled.

 

i want to use this router to connect to my ISP and dial automatically like the normal dlink and other  routers do.

 

i want to share the internet to clients connected through switch.

Everyone's tags (2)
2 REPLIES
New Member

conf tinterface dialer 1ip

conf t

interface dialer 1
ip address negotiated
encapsulation ppp
ppp authentication pap callin
ppp pap sent-username ISPUsername password ISPPassword
ppp ipcp route default
dialer pool 10
no shutdown
ip nat outside
exit

interface gigabit 0/0
no ip address
pppoe enable
pppoe-client dial-pool-number 10
no shutdown
exit

exit

interface gigabit 0/1
ip address 192.168.0.254 255.255.255.0
no shutdown
ip nat inside
exit
ip access-list standard NAT_ADDRESSES
permit 192.168.0.0 0.0.0.255
exit

ip nat inside source list NAT_ADDRESSES interface dialer 1

Silver

hello - I have just moved

hello - I have just moved your post to the Topic forums - you had posted your question in an obscure, non-visible, promotional community.  Hopefully our community users will see your question now

1155
Views
0
Helpful
2
Replies