Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Configure FTP on Port 990

I currently have a Cisco 891 running with a FTP running on port 21. I currently have the NAT from external IP to and internal IP 192.168.12.6 for port 21. And the firewall allowing that traffic through and client software is working fine. However I need this FTP to be running on port 990 and anytime I change the NAT and the firewall, the external FTP clients connect but then drop when recieving the directory listing.

Any help would be greatly appreciated!

Sent from Cisco Technical Support iPad App

18 REPLIES
Cisco Employee

Configure FTP on Port 990

I assume that you also have FTP inspection configured on the router. The reason why the directory listing drops the FTP connection is because you are using non standard port, and the FTP inspection by default only inspect control port 21, and it will automatically allow the data connection. Since you are using non standard port, then it is not inspected by the ftp inspection engine, hence is dropped.

You can configure port map for FTP control to port 990, and inspect ftp, however it will only inspect 990, and if you have any other FTP connection on standard port 21, it will not be inspected, and data connection will be dropped.

Community Member

Re: Configure FTP on Port 990

I believe I tried that and it didn't work.... Can you give me an example?

Sent from Cisco Technical Support iPad App

Community Member

Re: Configure FTP on Port 990

I tried....

ip nat inside source static tcp 192.168.12.6 990 interface FastEthernet8 990

ip nat service list 10 ftp tcp port 990

access-list 10 permit 192.168.12.6

Sent from Cisco Technical Support iPad App

Community Member

Re: Configure FTP on Port 990

I have also tried:

ip port-map ftp port 990 list 10

ip nat inside source static tcp 192.168.12.6 990 interface FastEthernet8 990

access-list 10 permit 192.168.12.6

Sent from Cisco Technical Support iPad App

Cisco Employee

Re: Configure FTP on Port 990

do you also have inspect ftp configured?

can you please share your current configuration.

Community Member

Re: Configure FTP on Port 990

This is my current config with it running on port 21....  Over the past 24 hours I have tried all kinds of things but no sucess...  I've got to be missing something small, but what it is I'm not sure.  I believe this does have a section were ftp is being inpected via

class type inspect sdm-nat-ftp-1

  inspect

Thankyou in advance for any help!  This is driving me crazy.

__________________________________________________________________

Building configuration...

Current configuration : 11716 bytes

!

! Last configuration change at 22:14:11 PCTime Wed May 23 2012 by XXXXX

! NVRAM config last updated at 23:15:29 PCTime Wed May 23 2012 by XXXXX

!

version 15.0

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service udp-small-servers

service tcp-small-servers

service sequence-numbers

!

hostname yourname

!

boot-start-marker

boot-end-marker

!

security authentication failure rate 3 log

security passwords min-length 6

logging buffered 51200

logging console critical

enable secret 5 X

!

no aaa new-model

!

!

!

clock timezone PCTime -5

clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00

service-module wlan-ap 0 bootimage autonomous

!

crypto pki trustpoint TP-self-signed-X

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-X

revocation-check none

rsakeypair TP-self-signed-X

!

!

crypto pki certificate chain TP-self-signed-X

certificate self-signed 01

  X

       quit

ip source-route

ip gratuitous-arps

!

!

ip dhcp excluded-address 192.168.12.1 192.168.12.199

ip dhcp excluded-address 192.168.12.254

!

ip dhcp pool ccp-pool1

   import all

   network 192.168.12.0 255.255.255.0

   default-router 192.168.12.1

   dns-server 192.168.12.1

!

!

ip cef

ip domain name yourdomain.com

ip name-server 208.67.222.222

ip name-server 208.67.220.220

ip port-map user-protocol--1 port tcp 2080

no ipv6 cef

!

!

multilink bundle-name authenticated

parameter-map type protocol-info yahoo-servers

server name scs.msg.yahoo.com

server name scsa.msg.yahoo.com

server name scsb.msg.yahoo.com

server name scsc.msg.yahoo.com

server name scsd.msg.yahoo.com

server name cs16.msg.dcn.yahoo.com

server name cs19.msg.dcn.yahoo.com

server name cs42.msg.dcn.yahoo.com

server name cs53.msg.dcn.yahoo.com

server name cs54.msg.dcn.yahoo.com

server name ads1.vip.scd.yahoo.com

server name radio1.launch.vip.dal.yahoo.com

server name in1.msg.vip.re2.yahoo.com

server name data1.my.vip.sc5.yahoo.com

server name address1.pim.vip.mud.yahoo.com

server name edit.messenger.yahoo.com

server name messenger.yahoo.com

server name http.pager.yahoo.com

server name privacy.yahoo.com

server name csa.yahoo.com

server name csb.yahoo.com

server name csc.yahoo.com

parameter-map type protocol-info aol-servers

server name login.oscar.aol.com

server name toc.oscar.aol.com

server name oam-d09a.blue.aol.com

parameter-map type protocol-info msn-servers

server name messenger.hotmail.com

server name gateway.messenger.hotmail.com

server name webmessenger.msn.com

license udi pid CISCO891W-AGN-A-K9 sn FTX1530806W

!

!

username XXXXX privilege 15 secret 5 X

!

!

ip finger

ip tcp synwait-time 10

ip ssh time-out 60

ip ssh authentication-retries 2

!

class-map type inspect match-any ccp-cls-protocol-p2p

match protocol edonkey signature

match protocol gnutella signature

match protocol kazaa2 signature

match protocol fasttrack signature

match protocol bittorrent signature

class-map type inspect match-all sdm-nat-user-protocol--1-1

match access-group 102

match protocol user-protocol--1

class-map type inspect match-any ccp-skinny-inspect

match protocol skinny

class-map type inspect match-any ccp-cls-insp-traffic

match protocol cuseeme

match protocol dns

match protocol ftp

match protocol https

match protocol icmp

match protocol imap

match protocol pop3

match protocol netshow

match protocol shell

match protocol realmedia

match protocol rtsp

match protocol smtp

match protocol sql-net

match protocol streamworks

match protocol tftp

match protocol vdolive

match protocol tcp

match protocol udp

class-map type inspect match-all ccp-insp-traffic

match class-map ccp-cls-insp-traffic

class-map type inspect match-any ccp-h323nxg-inspect

match protocol h323-nxg

class-map type inspect match-any ccp-cls-icmp-access

match protocol icmp

match protocol tcp

match protocol udp

class-map type inspect match-any ccp-cls-protocol-im

match protocol ymsgr yahoo-servers

match protocol msnmsgr msn-servers

match protocol aol aol-servers

class-map type inspect match-any ccp-h225ras-inspect

match protocol h225ras

class-map type inspect match-any ccp-h323annexe-inspect

match protocol h323-annexe

class-map type inspect match-any ccp-h323-inspect

match protocol h323

class-map type inspect match-all ccp-invalid-src

match access-group 100

class-map type inspect match-all ccp-icmp-access

match class-map ccp-cls-icmp-access

class-map type inspect match-any ccp-sip-inspect

match protocol sip

class-map type inspect match-all ccp-protocol-http

match protocol http

class-map type inspect match-all sdm-nat-ftp-1

match access-group 101

match protocol ftp

!

!

policy-map type inspect ccp-permit-icmpreply

class type inspect ccp-icmp-access

  inspect

class class-default

  pass

policy-map type inspect sdm-pol-NATOutsideToInside-1

class type inspect sdm-nat-ftp-1

  inspect

class type inspect sdm-nat-user-protocol--1-1

  inspect

class class-default

  drop

policy-map type inspect ccp-inspect

class type inspect ccp-invalid-src

  drop log

class type inspect ccp-protocol-http

  inspect

class type inspect ccp-insp-traffic

  inspect

class type inspect ccp-sip-inspect

  inspect

class type inspect ccp-h323-inspect

  inspect

class type inspect ccp-h323annexe-inspect

  inspect

class type inspect ccp-h225ras-inspect

  inspect

class type inspect ccp-h323nxg-inspect

  inspect

class type inspect ccp-skinny-inspect

  inspect

class class-default

  drop

policy-map type inspect ccp-permit

class class-default

  drop

!

zone security out-zone

zone security in-zone

zone-pair security ccp-zp-out-self source out-zone destination self

service-policy type inspect ccp-permit

zone-pair security ccp-zp-in-out source in-zone destination out-zone

service-policy type inspect ccp-inspect

zone-pair security ccp-zp-self-out source self destination out-zone

service-policy type inspect ccp-permit-icmpreply

zone-pair security sdm-zp-NATOutsideToInside-1 source out-zone destination in-zone

service-policy type inspect sdm-pol-NATOutsideToInside-1

!

!

!

!

!

!

!

interface FastEthernet0

!

!

interface FastEthernet1

!

!

interface FastEthernet2

!

!

interface FastEthernet3

!

!

interface FastEthernet4

!

!

interface FastEthernet5

!

!

interface FastEthernet6

!

!

interface FastEthernet7

!

!

interface FastEthernet8

description $ES_WAN$$ETH-WAN$$FW_OUTSIDE$

ip address X.X.X.X 255.255.255.240

ip mask-reply

ip directed-broadcast

ip flow ingress

ip nat outside

ip virtual-reassembly

zone-member security out-zone

duplex auto

speed auto

!

!

interface GigabitEthernet0

no ip address

ip mask-reply

ip directed-broadcast

ip flow ingress

shutdown

duplex auto

speed auto

!

!

interface wlan-ap0

description Service module interface to manage the embedded AP

ip unnumbered Vlan1

ip mask-reply

ip directed-broadcast

ip flow ingress

arp timeout 0

!

!

interface Wlan-GigabitEthernet0

description Internal switch interface connecting to the embedded AP

!

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-FE 1$$ES_LAN$$FW_INSIDE$

ip address 192.168.12.1 255.255.255.0

ip mask-reply

ip directed-broadcast

ip flow ingress

ip nat inside

ip virtual-reassembly

zone-member security in-zone

ip tcp adjust-mss 1452

!

!

interface Async1

no ip address

ip mask-reply

ip directed-broadcast

encapsulation slip

!

!

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

ip dns server

ip nat inside source list 1 interface FastEthernet8 overload

ip nat inside source static tcp 192.168.12.50 2080 interface FastEthernet8 2080

ip nat inside source static tcp 192.168.12.6 21 interface FastEthernet8 21

ip route 0.0.0.0 0.0.0.0 X.X.X.X

!

logging trap debugging

access-list 1 remark INSIDE_IF=Vlan1

access-list 1 remark CCP_ACL Category=2

access-list 1 permit 192.168.12.0 0.0.0.255

access-list 100 remark CCP_ACL Category=128

access-list 100 permit ip host 255.255.255.255 any

access-list 100 permit ip 127.0.0.0 0.255.255.255 any

access-list 100 permit ip 192.168.1.0 0.0.0.255 any

access-list 100 permit ip 209.60.166.192 0.0.0.15 any

access-list 101 remark CCP_ACL Category=0

access-list 101 permit ip any host 192.168.12.6

access-list 102 remark CCP_ACL Category=0

access-list 102 permit ip any host 192.168.12.50

no cdp run

!

!

!

!

!

!

control-plane

!

!

banner exec ^CCCC

% Password expiration warning.

-


Cisco Configuration Professional (Cisco CP) is installed on this device

and it provides the default username "cisco" for  one-time use. If you have

already used the username "cisco" to login to the router and your IOS image

supports the "one-time" user option, then this username has already expired.

You will not be able to login to the router with this username after you exit

this session.

It is strongly suggested that you create a new username with a privilege level

of 15 using the following command.

username  with the username and password you want to

use.

-


^C

banner login ^CCCCAuthorized access only!

Disconnect IMMEDIATELY if you are not an authorized user!^C

!

line con 0

login local

transport output telnet

line 1

modem InOut

stopbits 1

speed 115200

flowcontrol hardware

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin udptn ssh

line aux 0

login local

transport output telnet

line vty 0 4

privilege level 15

login local

transport input telnet ssh

line vty 5 15

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

scheduler allocate 4000 1000

scheduler interval 500

end

Bronze

Re: Configure FTP on Port 990

You're trying to use FTP over SSL (aka FTPs) which is not supported by the ASA: 

https://supportforums.cisco.com/thread/2010303

Community Member

Re: Configure FTP on Port 990

I just need port 990 to act just like port 21....

Sent from Cisco Technical Support iPhone App

Cisco Employee

Re: Configure FTP on Port 990

access-list 101 should be configured with destination of FastEthernet8 interface instead of the private IP as it is inspected before NAT.

Community Member

Re: Configure FTP on Port 990

Jennifer,

Sorry but I'm confused on your response.... Isn't list 101 giving permission for the ip 192.168.12.6 to get the information from the NAT, just as list 102 is for the NAT on port 2080 for 192.16.12.50 (which is for a different service and server)? 101 should be referencing the outside-in traffic, if put in as FastEthenet 8 wouldn't that be telling it to that it has permission to send traffic to it's self.

I know that the way it is right now works for port 21. It's just getting this to work on port 990 instead of port 21 is we're I'm having the issue.

Sent from Cisco Technical Support iPad App

Cisco Employee

Re: Configure FTP on Port 990

Both your NAT statements does not have access-list 101 or 102 applied to it:

ip nat inside source static tcp 192.168.12.50 2080 interface FastEthernet8 2080

ip nat inside source static tcp 192.168.12.6 21 interface FastEthernet8 21

Access-list 101 and 102 is actually applied to the Zone Based FW configuration within the class-map:

class-map type inspect match-all sdm-nat-ftp-1

match access-group 101

match protocol ftp

And because you are actually configuring static PAT on FastEthernet8 interface as per your NAT statement above, then the ACL should be matching FA8 ip address.

Community Member

Re: Configure FTP on Port 990

I'll give it a shot... Still confused...

After making that change, do I then need to apply the:

ip port-map ftp port 990 list 10

ip nat inside source static tcp 192.168.12.6 990 interface FastEthernet8 990

access-list 10 permit 192.168.12.6

Sent from Cisco Technical Support iPad App

Cisco Employee

Re: Configure FTP on Port 990

yes pls, and also:

access-list 10 permit

Community Member

Re: Configure FTP on Port 990

Thanks.... I'll have to try it when I get back. I'll let you know what the results are.

Sent from Cisco Technical Support iPad App

1339
Views
0
Helpful
18
Replies
CreatePlease to create content