Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configure PPPOA and PPPOE on Cisco 2600 Without WIC card

Hello !!

I have some specified scenario in one company. Their ISP is using only PPPOA instead of PPPOE, so since company uses the Cisco PIX 501 than we are not able to configure PIX to use PPPOA Encapsulation, because PIX does not support it.

Than we need to put one router in this scenario and we have one 2600 series without WIC card but it have only E0. As SHDSL modem we use SpeedTouch with 4 DSL ports which is bridged. So behind this we need one Router first instead of the PIX, so this router needs to be configured with PPPOA (I asked the config for PPPOE just in case, great to know both of encapsulation types) and than this 2600 router will than receive a static wan ip address from radius server, and than we have one SUBNET .252 which this isp have routed to this primary static ip which is assigned on 2600 trough PPPOA.

Than one of the ip addresses from routed subnet we will set on the PIX, and anothes will be configured on one SUB interface on the 2600, so the PIX can than use this ip address as its gateway.

So in short words I need full sample config for both encapsulations PPPOA and PPPOE on 2600 WITHOUT WIC card, because we have a SHDSL bridge.

Now I am not talking about PPPoE or PPPoA TERMINATION on the 2600 but CLIENT config PPPoA and PPPoE on Cisco 2600 without WIC card.

I hope someone can answer me as soon as possible.

Thank You

Best regards

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: Configure PPPOA and PPPOE on Cisco 2600 Without WIC card

Hi,

You cannot do PPPoA over ethernet because it is not bridgeable. Config PPPoE on LAN is simple:

interface Ethernetx/y

no ip address

pppoe enable

pppoe-client dial-pool-number 1

!

interface Dialer1

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

ppp ipcp route default

ppp ipcp dns request

ppp pap sent-username password

Use ppp chap host and password in case you are using chap.

You can see documentation with also configured vpdn, this is no more necessary with recent code.

Hope this helps, please rate post if it does!

6 REPLIES
Hall of Fame Super Gold

Re: Configure PPPOA and PPPOE on Cisco 2600 Without WIC card

Hi,

You cannot do PPPoA over ethernet because it is not bridgeable. Config PPPoE on LAN is simple:

interface Ethernetx/y

no ip address

pppoe enable

pppoe-client dial-pool-number 1

!

interface Dialer1

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

ppp ipcp route default

ppp ipcp dns request

ppp pap sent-username password

Use ppp chap host and password in case you are using chap.

You can see documentation with also configured vpdn, this is no more necessary with recent code.

Hope this helps, please rate post if it does!

New Member

Re: Configure PPPOA and PPPOE on Cisco 2600 Without WIC card

Hello !!

Thank You for helping !!!

So in the config above I also need to specify the default route as in example below:

ip route 0.0.0.0 0.0.0.0 Dialer1

is this right ?

and there is one more command I don`t understand : dialer pool 1

do we allways need to use 1 or ?

And the "interface Ethernetx/y " can this be one or another SUB-Interface ?? or this needs to be E0 only ?

Thank You again !!

Best regards

Hall of Fame Super Gold

Re: Configure PPPOA and PPPOE on Cisco 2600 Without WIC card

Hi,

once you use 'ppp ipcp route default' you don't need 'ip route 0.0.0.0 ...'.

Please use 1 for dialer-pool. The number simply has to match in the pppoe-client and dialer configuration.

Please do not use sub-interfaces for this configuration. Configure on the interface that is connected to the SHSDL modem/bridge.

Note there are interface cards available from cisco that would allow you to eliminate the SHDSL modem/bridge, hence applying QoS and monitoring the real performances of the circuit.

Thanks for the nice rating and good luck!

New Member

Re: Configure PPPOA and PPPOE on Cisco 2600 Without WIC card

Hi again !!

Thank You very much for great explanations !!

Now I understand it.

You`re welcome for rating, pople like You deserv it !

PS: Since You are CCIE, I hope I can ask You one more question, but it have nothing to do with this scenario. Shell I post new thread-post and let You know the link only ? is it great ?? I had this problem for a long time, therfore I need someone who can give me an answer.

Best regards

Hall of Fame Super Gold

Re: Configure PPPOA and PPPOE on Cisco 2600 Without WIC card

Hi James,

thank you for the nice rating and appreciation.

Please feel free to post new questions here.

I think it's better to open a new thread for each different problem.

Good luck!

New Member

Re: Configure PPPOA and PPPOE on Cisco 2600 Without WIC card

Hi again !!!

Thank You for very quick response, vel below is the link about my question.

I`ll not forget to rate it !

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=WAN%2C%20Routing%20and%20Switching&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cbe4374

Thank You

Best regards

938
Views
5
Helpful
6
Replies