Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configure ripv2 ospf and BGP

hi, my name is martin, im from argentina, im doing a job for my

university, conecting 2 networks, one works with RIPv2 ant the other

with OSPF, th 2 are linked by a BGP link..

im using boson netsim to simulate this... i got the two netwoks

configred correctly, but i cant get BGP up...

here is the net diagram

http://img517.imageshack.us/img517/1193/topologiame5.jpg

and the router 4 config

[CODE]

!

Version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router4

!

!

!

ip subnet-zero

!

!

!

!

!

!

!

!

!

!

interface Serial0

ip address 10.114.2.1 255.255.255.252

no ip directed-broadcast

!

interface Serial1

ip address 10.114.1.2 255.255.255.252

no ip directed-broadcast

clock rate 50000

!

interface Serial2

ip address 10.115.9.1 255.255.255.252

no ip directed-broadcast

!

router rip

version 2

network 10.114.0.0

!

router bgp 1

network 10.114.1.0 mask 255.255.255.252

network 10.114.2.0 mask 255.255.255.252

network 10.114.3.0 mask 255.255.255.252

network 10.114.4.0 mask 255.255.255.252

neighbor 10.115.9.2 remote-as 2

!

interface FastEthernet0/0

no ip address

no ip directed-broadcast

shutdown

!

interface FastEthernet0/1

no ip address

no ip directed-broadcast

shutdown

!

!

ip classless

no ip http server

!

!

!

line con 0

transport input none

line aux 0

line vty 0 4

login

password martin

!

no scheduler allocate

end

[/CODE]

router 5 config

[CODE]

!

Version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router5

!

!

!

ip subnet-zero

!

!

!

!

!

!

!

!

!

!

interface Serial0

ip address 10.111.8.1 255.255.255.252

no ip directed-broadcast

!

interface Serial1

ip address 10.111.7.2 255.255.255.252

no ip directed-broadcast

clock rate 50000

!

interface Serial2

ip address 10.115.9.2 255.255.255.252

no ip directed-broadcast

clock rate 50000

!

interface FastEthernet0/0

no ip address

no ip directed-broadcast

shutdown

!

interface FastEthernet0/1

no ip address

no ip directed-broadcast

shutdown

!

router ospf 1

network 10.111.8.0 0.0.0.255 area 0

network 10.111.7.0 0.0.0.255 area 0

!

router bgp 2

network 10.111.8.0 mask 255.255.255.252

network 10.111.7.0 mask 255.255.255.252

network 10.111.6.0 mask 255.255.255.252

network 10.111.5.0 mask 255.255.255.252

neighbor 10.115.9.1 remote-as 1

!

ip classless

no ip http server

!

!

!

line con 0

transport input none

line aux 0

line vty 0 4

login

password xxx

!

no scheduler allocate

end

[/CODE]

can someone point my how to solve this??

thanx..

4 REPLIES
Hall of Fame Super Silver

Re: Configure ripv2 ospf and BGP

Martin

It is difficult to tell from this whether you have run into some issue with the simulator or whether it is something else.

So first, can you be a bit more specific about what you mean when you say cant get BGP up? When you do show ip bgp what does it say about the neighbor? While I wonder about the usefulness of having 4 network statements for networks with /30 masks that should not impact getting BGP up. In the configuration as posted I would expect BGP to form the neighbor relationship.

Also can you tell whether the serial link that connects them is up? If you perform show cdp neighbor, does it show the routers as neighbors at layer 2?

HTH

Rick

New Member

Re: Configure ripv2 ospf and BGP

hi, if i run sh cdp neighbor i can see the 3 neighbors, and all the links are UP..

the problem i ges is the config of the bgp..

sh ip bgp shows only 2 networks.

on router 4 the 10.114.1.0 and the 10.114.2.0

and on router 5 10.111.8.0 and 10.111.7.0

...

any idea?

Hall of Fame Super Silver

Re: Configure ripv2 ospf and BGP

Martin

Can you post the output of show cdp neighbor detail from router 4 (and/or router 5)? Also the output of show ip bgp neighbor would be helpful.

The BGP configuration that you post is fairly simple and straightforward. Assuming correct connectivity between router 4 and router 5 I do not see anything that would keep it from forming the neighbor relationship.

I believe that there are 2 routes listed because those are the locally connected routes. I assume that the other networks that are represented by network statements are remote networks that you expect to learn via RIP or OSPF? I would interpret from what you have said that either they are not being leaerned, or they are being learned but do not have /30 masks. Posting the output of show ip route would clarify this.

HTH

Rick

New Member

Re: Configure ripv2 ospf and BGP

yes those routes are directly conected to the routers. the other networks configured in bgp 1 and bgp 2 are the nets i whant to pass to the the other AS.

have you seen the diagram image http://img517.imageshack.us/img517/1193/topologiame5.jpg

al rip area routers now each other, i want them to know also the routers in ospf area, and to do this i use bgp

... here are the info i got from the routes.

http://img514.imageshack.us/img514/6733/router4oo8.png <-- router 4

http://img225.imageshack.us/img225/1362/router5oo5.png <-- router 5

628
Views
0
Helpful
4
Replies
CreatePlease to create content