Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Configure serial port for additional Public IP's w/diff subnet

How do you configure your serial port for additional public IP's on a different subnet. Can you create a serial 0.1 I am sure this has been done I cannt figure it out.

Jeff

6 REPLIES
Hall of Fame Super Silver

Re: Configure serial port for additional Public IP's w/diff subn

Jeff

If you would explain a bit more about what you need and what your environment is we might be able to give better advice. For some media such as Frame Relay it may be possible to create subinterfaces such as serial0.1 and assign addresses to the subinterfaces. The other general solution is to use secondary addressing. It might look something like this:

interface serial 0

ip address 10.10.10.1 255.255.255.0

ip address 10.20.20.1 255.255.255.0 secondary

This allows both subnets to be active on the same interface at the same time. Would this provide what you need?

HTH

Rick

New Member

Re: Configure serial port for additional Public IP's w/diff subn

I think you got it. When I tryed it I received an error message that /28 for address 66.16.102.240 is Bad. I was suppose to receive an additional 16 addresses. That would make the subnet 28. Is it because my original subnet is 29 for the primary?

My original ip is 66.x.x.185/28

ip address 66.173.x.x.255.255.248

Any ideas?

Jeff

New Member

Re: Configure serial port for additional Public IP's w/diff subn

Rick,

You have been very helpfull but....

Following is my config. I can ping 66.16.102.241 but none of the other ip's work. I would think that I dont need a route statement in because of the gateway of last resort "ip route 0.0.0.0 0.x.x.x 66.x.167.57" Any ideas???

TechSupport#show run

Building configuration...

Current configuration : 710 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname TechSupport

!

enable secret 5

enable password

!

ip subnet-zero

!

!

!

!

interface FastEthernet0

ip address 66.16.x.x.255.255.240 secondary

ip address 66.173.x.x.255.255.248

speed auto

full-duplex

--More-- !

interface Serial0

ip address 66.173.x.x.255.255.252

encapsulation ppp

no fair-queue

service-module t1 clock source internal

!

ip classless

ip route 0.0.0.0 0.x.x.x.173.167.57

no ip http server

!

!

snmp-server community public RW

!

line con 0

line aux 0

line vty 0 4

password

login

!

no scheduler allocate

end

Thanks for your help Jeff

Re: Configure serial port for additional Public IP's w/diff subn

Jeff,

You don't need a static route for that subnet as that's a directly connected network.

Do you have the PCs on the 66.16.102.240/28 subnet configured with the default gateway of 66.16.102.241? Ensure the PCs are configured with the correct subnet mask.

Pls. rate all helpful posts.

Sundar

Re: Configure serial port for additional Public IP's w/diff subn

Hello Jeff,

in addition to Rick's post, make sure that the hosts in the 66.16.102.242-254 IP address range have 66.16.102.241 configured as their default gateway. From where are you pinging anyway ?

Regards,

GNT

Hall of Fame Super Silver

Re: Configure serial port for additional Public IP's w/diff subn

Jeff

I am not sure that I am clear on what you are doing. It appears that you have at least three blocks of IP address space from your provider (subnet 66.173.167.56/30, 66.173.255.184/29, and 66.16.102.240/28). If that is right then I think the router config is about right. The default route that you configured should send everythig out to the provider. And traffic should get to you assuming that the provider is routing all three subnets to you.

The PCs in subnet 66.16.102.240 should use 66.16.102.241 as their default gateway while the PCs in 66.173.255.184 should use 66.173.255.185 as their deafult gateway.

If the above is true then there should be connectivity. If the above is not true then point out to me what is not. If there are still connectivity problems then help me understand better what does not work.

HTH

Rick

156
Views
5
Helpful
6
Replies