Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Configure two routers in bridge mode

Hi, i need to configure two Cisco routers in bridge mode as they interconnect two LANs that are in the same subnet. The two routers are connected by a fiber optic link. Can you please indicate me how to set the routers in bridge mode.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Configure two routers in bridge mode

Hello Alvin,

if the routers are ISR routers 2811 or above you could think to use L2tpv3

However, if the link is direct and you don't need to use it as a L3 routed link you can also bridge

int fas0/0

no ip address

bridge-group 1

desc internal lan

int fas0/1

desc link to fiber

no ip address

bridge-group 1

bridge-group1 protocol ieee

brdige-group1 route ip

int bvi1

desc l3 interface of the bridge group

ip address x.x.x.1 255.255.255.0

no shut

you need to do the same on the second router

int fas0/0

no ip address

bridge-group 1

desc internal lan

int fas0/1

desc link to fiber

no ip address

bridge-group 1

bridge-group1 protocol ieee

brdige-group1 route ip

int bvi1

desc l3 interface of the bridge group

ip address x.x.x.2 255.255.255.0

no shut

just the ip address associated to the BVI1 of R2 needs to be different

if R1 reach all other networks via R2

R1 needs a default route

ip route 0.0.0.0 0.0.0.0 x.x.x.2 10

Hope to help

Giuseppe

23 REPLIES
Hall of Fame Super Silver

Re: Configure two routers in bridge mode

Hello Alvin,

if the routers are ISR routers 2811 or above you could think to use L2tpv3

However, if the link is direct and you don't need to use it as a L3 routed link you can also bridge

int fas0/0

no ip address

bridge-group 1

desc internal lan

int fas0/1

desc link to fiber

no ip address

bridge-group 1

bridge-group1 protocol ieee

brdige-group1 route ip

int bvi1

desc l3 interface of the bridge group

ip address x.x.x.1 255.255.255.0

no shut

you need to do the same on the second router

int fas0/0

no ip address

bridge-group 1

desc internal lan

int fas0/1

desc link to fiber

no ip address

bridge-group 1

bridge-group1 protocol ieee

brdige-group1 route ip

int bvi1

desc l3 interface of the bridge group

ip address x.x.x.2 255.255.255.0

no shut

just the ip address associated to the BVI1 of R2 needs to be different

if R1 reach all other networks via R2

R1 needs a default route

ip route 0.0.0.0 0.0.0.0 x.x.x.2 10

Hope to help

Giuseppe

New Member

Re: Configure two routers in bridge mode

Dear Giuseppe,

I have configured the routers and the bridge mode configuration is working fine. I can ping both routers.

But there is a problem occurring.

When I connect the second router (Router B)to its LAN, there is no more connection. I cannot reach it anymore. There seems to be a STP loop.

Find below the configuration of both routers:

RouterA#

bridge irb

!

!

!

interface GigabitEthernet0/0

description 'Connection To LAN'

no ip address

duplex auto

speed auto

bridge-group 1

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

shutdown

clock rate 2000000

!

interface GigabitEthernet0/1/0

description 'Fiber Optics Link'

no ip address

negotiation auto

bridge-group 1

!

interface BRI0/2/0

no ip address

encapsulation hdlc

shutdown

!

interface BVI1

ip address 172.18.12.12 255.255.252.0

arp timeout 300

!

ip forward-protocol nd

!

!

ip http server

ip http authentication local

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

Router A#sh spanning-tree summary

Root bridge for: Bridge group 1.

PortFast BPDU Guard is disabled

UplinkFast is disabled

BackboneFast is disabled

Name Blocking Listening Learning Forwarding STP Active

-------------------- -------- --------- -------- ---------- ----------

Bridge group 1 0 0 0 2 2

-------------------- -------- --------- -------- ---------- ----------

1 Bridge Group 0 0 0 2 2

RouterB#

bridge irb

!

!

!

interface GigabitEthernet0/0

description 'Connection To LAN'

no ip address

duplex auto

speed auto

bridge-group 1

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

shutdown

clock rate 2000000

!

interface GigabitEthernet0/1/0

description 'Fiber Optics Connection'

no ip address

negotiation auto

bridge-group 1

!

interface BRI0/2/0

no ip address

encapsulation hdlc

shutdown

!

interface BVI1

ip address 172.18.14.2 255.255.252.0

arp timeout 300

!

no ip forward-protocol nd

!

!

ip http server

ip http authentication local

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

Router B#sh spanning-tree summary

Root bridge for: Bridge group 1.

PortFast BPDU Guard is disabled

UplinkFast is disabled

BackboneFast is disabled

Name Blocking Listening Learning Forwarding STP Active

-------------------- -------- --------- -------- ---------- ----------

Bridge group 1 0 0 0 2 2

-------------------- -------- --------- -------- ---------- ----------

1 Bridge Group 0 0 0 2 2

Thanks for your help.

Best regards,

Alvin

Hall of Fame Super Silver

Re: Configure two routers in bridge mode

Hello Alvin,

a loop cannot occur unless you close the two lan interfaces together but STP should take care of this

if you use a fiber connection you may need a media-type command.

do

sh int gi0/1/0

media-type ?

and see the options

check the status of the fiber based links with

sh int gi0/1/0

both devices say they are root bridge for bridge-group 1

Root bridge for: Bridge group 1.

so they are not communicating

Hope to help

Giuseppe

New Member

Re: Configure two routers in bridge mode

Dear Giuseppe,

Find below the interfaces from both routers:

Router A#sh interfaces

GigabitEthernet0/0 is up, line protocol is up

GigabitEthernet0/1/0 is up, line protocol is up

Hardware is PM-3387, address is 0017.5aa6.d606 (bia 0017.5aa6.d606)

Description: 'Fiber Optics Link'

MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, link type is autonegotiation, media type is LX

output flow-control is XON, input flow-control is XON

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:04, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 1 packets/sec

24870 packets input, 2138807 bytes, 0 no buffer

Received 73 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

0 input packets with dribble condition detected

209475 packets output, 18426653 bytes, 0 underruns

0 output errors, 0 collisions, 4 interface resets

0 unknown protocol drops

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 pause output

0 output buffer failures, 0 output buffers swapped out

BVI1 is up, line protocol is up

RouterB#sh interfaces

GigabitEthernet0/0 is up, line protocol is up

GigabitEthernet0/1/0 is up, line protocol is up

Hardware is PM-3387, address is 0015.622e.f3b6 (bia 0015.622e.f3b6)

Description: 'Fiber Optics Connection'

MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, link type is autonegotiation, media type is LX

output flow-control is XON, input flow-control is XON

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 2000 bits/sec, 4 packets/sec

5 minute output rate 2000 bits/sec, 3 packets/sec

351035 packets input, 29378840 bytes, 0 no buffer

Received 143617 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

0 input packets with dribble condition detected

35369 packets output, 2863100 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

28 unknown protocol drops

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 pause output

0 output buffer failures, 0 output buffers swapped out

BVI1 is up, line protocol is up

I am able to ping any device in the LAN of Router A from Router B.

The opposite is not possible.

Please advise.

Alvin

New Member

Re: Configure two routers in bridge mode

Thanks Giuseppe,

I will configure the routers and revert back to you.

Thanks for your help.

Blue

Re: Configure two routers in bridge mode

Alvin:

Not to distract you from your work, but I am wondering why you find yourself in a situation where you have 2 ethernet interfaces on your router that are cnnected to the same LAN.

Can you also attach a simple diagram to show whats going on?

Thanks

Victor

New Member

Re: Configure two routers in bridge mode

Dear Victor,

Please find attached the network topology.

As you will see, both LAN A and B are found in the 172.18.12.0/22 subnet.

So, that is why the routers are configured in Bridge mode.

But I am having problems when connecting the LAN interface of Router B. As soon as I connect it to the switch, I am not able to ping it anymore from router A.

Best regards,

Alvin

Blue

Re: Configure two routers in bridge mode

Alvin:

Thanks.

Have you taken notice of Giuseppe's suggestion? The routers dont seem to be exchanging BPDUs because each is claiming itself as the root bridge.

Victor

Hall of Fame Super Silver

Re: Configure two routers in bridge mode

Hello Alvin, Victor

collecting facts:

there is a fiber based link working at OSI layer 1 but STP messages are not exchanged.

Alvin:

what type of interface is g0/1/0 is part of some form of etherswitch module ?

in that case the configuration could need to be changed to something like

conf t

vlan 5

name inter-router-vlan

int vlan 5

no ip address

bridge-group 1

int gi0/1/0

switchport

switchport mode access

switchport access vlan 5

if the port is part of an etherswitch the bridge-group command has to be given under the SVI (int vlan 5)

Hope to help

Giuseppe

New Member

Re: Configure two routers in bridge mode

Dear Guiseppe,

In fact interface g0/1/0 is a Gigabit Ethernet HWIC card (HWIC-1GE-SFP) with a GLC-LH-SM module. For each router it is the same.

Regards,

Alvin

New Member

Re: Configure two routers in bridge mode

Dear Victor,

So in this typical configuration, should I enable the STP. And which STP should I use?

Which router needs to be the root bridge?

Regards,

Alvin

Hall of Fame Super Silver

Re: Configure two routers in bridge mode

Hello Alvin,

with your configuration STP is already running in the version IEEE:

the command

bridge 1 protocol ieee

Hope to help

Giuseppe

New Member

Re: Configure two routers in bridge mode

ok, Guiseppe.

I will continue with the testing.

Regards,

Alvin

New Member

Re: Configure two routers in bridge mode

Hello Guiseppe,

Hope you are doing fine.

The bridge configuration is working fine but I am encountering another issue that is preventing me from using the routers.

The issue is with Router B's LAN. When I am connecting Router B to the existing switch, I am not able to reach router A and its associated LAN anymore. Timeout occurs when I ping Router A from router B.

When I disconnect Router B from the existing switch, I can then access Router A and its associated LAN.

This seems to be a problem with the existing switch. Can you please explain what can be causing this problem and whether I need to do some modifications in the router configuration.

I did some tests using a standalone switch where I connected Router B and a laptop. Both where accessible from Router A. The problem did not occur.

Regards,

Alvin

Hall of Fame Super Silver

Re: Configure two routers in bridge mode

Hello Alvin,

this kind of configuration is thought to make routers to bridge between them.

you need to keep this scenario:

RA ----- RB

if you put a switch in the middle several facts can happen.

By the way if you had two switches with fiber optic link you can connect them together without using bridging on routers.

I guess (I hope) that you have only one switch in site B. (no switch on site A)

You need to connect the switch downstream RB interface in bridging mode.

Verify how the switch port is configured depending on some settings it can react negatively when it receives an IEE STP BPDU on its port.

Or the port can be configured to be a trunk port.

feel free to post the configuration of the switch and the way you connect RB and the switch (what ports you use)

Hope to help

Giuseppe

New Member

Re: Configure two routers in bridge mode

Dear Guiseppe,

I am still having problems with the deployment of the routers. Please refer to attached topology.

From router A, I am able to ping router B and the server. Similarly from router B, I am able to ping router A and the devices in LAN A.

But as soon as I connect the uplink (red line) from the HP switch 2626 to the D-Link switch, I cannot ping router B and the server from router A anymore. From router B also, I am also unable to ping router A and the devices in LAN A.

As soon as I disconnect the uplink, I am able to ping both sides again.

Below is the configuration of the HP switch:

Running configuration:

; J4900B Configuration Editor; Created on release #H.08.83

hostname "ProCurve Switch 2626"

mirror-port 19

snmp-server community "public" Unrestricted

vlan 1

name "DEFAULT_VLAN"

untagged 1-26

ip address 172.18.14.1 255.255.252.0

exit

interface 21

monitor

exit

So, is there some modification that I need to do to the routers configurations.

Please also refer to the second message that I will send.

Thanks for your help.

Alvin

New Member

Re: Configure two routers in bridge mode

Dear Guiseppe,

Actually there are two Cisco 878 SHDSL routers (Router C and D) being used to provide the link between LAN A and LAN B. Refer to the attached topology. The fiber optic routers are meant to replace those two routers.

What is strange is that these two routers are also configured in bridge mode and they are working fine.

Find attached the configuration of the two routers C and D.

With routers C and D, the devices in both LANs A and B are accessible.

Referring to the configuration of these two routers, is there some modifications that needs to be done to the fiber optic routers?

Best regards,

Alvin

Hall of Fame Super Silver

Re: Configure two routers in bridge mode

Hello Alvin,

when you connect the fiber uplink between the D-link unmanaged switch and the HP switch the SHDSL is still connected ?

I see something I think it could be wrong in routerD config:

no spanning-tree vlan 1

I would fix this I'm not sure on the effects of this command.

May you schedule a maintanance window and can you try to connect the fiber uplink after having shutted the SHDSL link ?

I also recommend to verify that STP is running correctly on all devices.

Being a multi-vendor scenario you need to verify that all devices are able to understand and talk 802.1D (protocol ieee in IRB config).

The guidelines are:

all devices have to be running 802.1D

all devices have to agree on root bridge-id.

if two different devices are claiming to be the root bridge something wrong is happening.

I suspect that a loop forms when you connect the fiber cable :

there is the SHDSL link and the fiber cable.

I'm starting to think that you should think to redesign the network for using different subnets so that you can use IP routing.

Also I would move the D-link unmanaged switch after the hp switch and if possible I would connect directly the router to the hp switch.

Hope to help

Giuseppe

New Member

Re: Configure two routers in bridge mode

Hello Giuseppe,

The SHDSL link is working fine with the present configuration of routers C and D. Servers and PCs are accessible on both sides.

The uplink between the HP switch and the D-Link switch is actually a UTP cable. It is when plugging this UTP cable in the D-Link switch that there is no more connection between the two fiber optic routers. And yes when connecting this uplink the connection between the SHDSL routers is still up.

Also, the use of different subnets will not be possible according to the client. We will have to stick with this single subnet.

Also, I may not have mentioned it before but this very strange issue occurred last week. I disconnected the SHDSL routers (C and D) from LANs A and B and I then connected the fiber optic routers (A and B). The link went up and I was able to access the servers at each end. I even connected the UTP uplink from the HP switch and it worked. The client was able to work for like 12 hours and then suddenly the link went down. I had to revert back to the SHDSL routers. Since then, each time I connect the UTP uplink even after having removed the SHDSL routers there is no communication between the two fiber optic routers. Could this be indicating that there is some kind of loop?

Also will the use of the following command help:

bridge-group 1 spanning disabled

Please find attached spanning tree for routers A,B (Fiber) and C,D (SHDSL).

Regards,

Alvin

New Member

Re: Configure two routers in bridge mode

Dear Giuseppe,

I have done some testing after disconnecting the two SHDSL routers from the network at both locations A and B.

So far the bridge mode configuration of the fiber optic routers A and B are working out fine. But the loss of connection occurred again when I connected the UTP uplink from existing HP switch found in LAN B to the unmanaged D-Link switch on which router B is connected. When this UTP uplink is connected, I am not able to ping router A from router B. Similarly from router A, I can no longer ping router B.

Removing this UTP uplink connecting the HP switch to the D-Link switch restores the connection between routers A and B.

Find below the configuration of the HP switch:

ProCurve Switch 2626# sh run

Running configuration:

; J4900B Configuration Editor; Created on release #H.08.83

hostname "ProCurve Switch 2626"

mirror-port 19

snmp-server community "public" Unrestricted

vlan 1

name "DEFAULT_VLAN"

untagged 1-26

ip address 172.18.14.1 255.255.252.0

exit

interface 21

monitor

exit

ProCurve Switch 2626#

Based on the above configuration, is there some modifications that needs to be done to the routers A and B configurations or to the HP switch configuration so that there is no connection interruption when the UTP uplink is connected?

Best regards,

Alvin

Hall of Fame Super Silver

Re: Configure two routers in bridge mode

Hello Alvin,

the problem here is to have an unmanaged and unmanageable device on the path: it is the D-link switch that is not able to work well with the other devices.

You should find a way to avoid to have it in the data path.

In my opinion that kind of device is acceptable only at home.

When we speak of a network for a business even a small business first basic requirement is to have manageable devices (and I don't say it has to be of a specific brand/vendor) so that you can know how they are configured and how they perceive the other devices.

Hope to help

Giuseppe

New Member

Re: Configure two routers in bridge mode

Dear Guiseppe,

The bridge mode configuration was working fine but in the end I had to shift to routing because the routers were having a conflict with a Cisco switch already present in the network. This was because of the spanning tree protocol being used in the bridge mode configuration.

Thanks for all your help.

Regards,

Alvin

Re: Configure two routers in bridge mode

What is the sense to use two routers for doing this?

1287
Views
0
Helpful
23
Replies
CreatePlease to create content