Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Configure WIC-1ADSL

Hello people!

I'm Sao Paulo - Brazil and here my ISP Telefonica work with RFC 2864. I need configure my interface WIC-1ADSL with following IPs.

It is easy part.

Fixed IP = 189.19.35.xxx

Gateway = 189.19.35.yyy

Mask = 255.255.255.0

Here it's my question. How to configure its on WIC-1ADSL? It's possible or I need another interface which work with encapsulation?

WAN = 172.20.7.170

Gateway = 172.20.7.169

Mask = 255.255.255.252

On my modem SpeedTouch I have a same configuration.

1 > software version
2 > env list
3 > env set var SESSIONTIMEOUT value 0
4 > ppp flush
5 > pptp flush
6 > eth flush
7 > eth bridge flush
8 > atm flush
9 > atm phonebook flush
10 > script flush
11 > ip ipdelete addr=10.0.0.138
12 > dns server config state disabled
13 > saveall
14 > env set var=CONF_SERVICE value=IP_FIXO_Metro_IPoE
15 > atm phonebook add name=pvc addr=8*35
16 > atm ifadd intf=atm
17 > atm ifconfig intf=atm dest=pvc ulp=mac
18 > atm ifattach intf=atm
19 > eth ifadd intf=ethoa
20 > eth ifconfig intf=ethoa dest=atm
21 > eth ifattach intf=ethoa
22 > ip ifadd intf=ipoe dest=ethoa
23 > ip ifconfig intf=ipoe status=up
24 > ip ifattach intf=ipoe
25 > ip ipadd intf=ipoe addr=172.20.9.170/255.255.255.252 addroute=enabled
26 > ip rtadd dst=0.0.0.0/0 gateway=172.20.9.169

27 > ip ipadd intf=LocalNetwork addr=$$$.$$$.$$$.$$$/255.255.255.0 addroute=enabled
28 > dhcp server flush
29 > dhcp server pool add name=ipfixo

My traceroute.

traceroute 189.19.35.xxx
traceroute to 189.19.35.xxx (189.19.35.xxx), 30 hops max, 60 byte packets
1 * * *
2 201-0-93-137.dsl.telesp.net.br (201.0.93.137) 28.573 ms 30.709 ms 31.883 ms
3 201-0-5-149.dsl.telesp.net.br (201.0.5.149) 34.056 ms 201-0-5-153.dsl.telesp.net.br (201.0.5.153) 35.718 ms 201-0-5-149.dsl.telesp.net.br (201.0.5.149) 37.388 ms
4 201-63-253-73.customer.tdatabrasil.net.br (201.63.253.73) 39.558 ms 41.215 ms 42.895 ms
5 200-100-1-246.dsl.telesp.net.br (200.100.1.246) 44.755 ms 200-100-1-250.dsl.telesp.net.br (200.100.1.250) 45.875 ms 200-100-1-242.dsl.telesp.net.br (200.100.1.242) 48.079 ms
6 * * *
7 172.20.7.170 (172.20.7.170) 107.368 ms 102.621 ms 98.416 ms
8 * * *
9 * * *
10 * * *
11 * * *
12 * * *
13 * * *

Thank you for help.

Best regards.

6 REPLIES
Hall of Fame Super Silver

Re: Configure WIC-1ADSL

Hello Antonio,

my guess is that your provider may be using RFC 1483 bridged where

IP/ethernet/AAL5 is carried over the ADSL line.

That it is different from an RFC 1483 routed where you have:

IP/AAL5 over ADSL line

refer to this document and look at the configuration part customer side = CPE

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a0080093e5f.shtml

Hope to help

Giuseppe

Re: Configure WIC-1ADSL

Hello Giuseppe,

I'll try that.

Thank you very much.

New Member

Re: Configure WIC-1ADSL

Let me know if you need a sample bridging config -  I have multiple sites set up for it.

Re: Configure WIC-1ADSL

Hello!

If you can. I'll be very happy.

I'm fighting with this inteface.

Thank you very much.

Cisco Employee

Re: Configure WIC-1ADSL

Hi,

Sample config for your quick reference:


PPPoEoA Sample Configuration:
---------------------------------

vpdn enable
no vpdn logging
!
vpdn-group 1
request-dialin
  protocol pppoe
!
interface Ethernet0
ip address 192.168.100.1 255.255.255.0
ip tcp adjust-mss 1452
ip nat inside
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 8/35
  pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap callin
ppp chap hostname <>
ppp chap password 0 <>
ppp pap sent-username <> password 0 <>
!
ip nat inside source list 101 interface Dialer1 overload

ip route 0.0.0.0.0.0.0.0 Dialer1
access-list 101 permit ip 192.168.100.0.0.0.0.255 any

Re: Configure WIC-1ADSL

Hello Manish,

Thank you very much.

This sample helped a lot.

Thank's again.

702
Views
0
Helpful
6
Replies