Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

configureing PPPOE on cisco 1841 router

hi friends,

i am having broadband connection from my ISP .. it is RJ45 connection i need to configure this connection in 1841 router..

but the ISP given me username and password to get internet by dailing..

how i will configure using ethernt interface in cisco 1841 router.

5 REPLIES
Hall of Fame Super Silver

Re: configureing PPPOE on cisco 1841 router

Hello Cyril,

see this example

https://www.cisco.com/en/US/products/hw/routers/ps380/products_configuration_example09186a0080094475.shtml

you don't need the vpdn part if your IOS is recent.

username and password has to be added to dialer interface configuration with commands like

int dialer 1

ppp authentication chap pap

you can configure username and password using

username xxx password yyy

in global config mode

Hope to help

Giuseppe

New Member

Re: configureing PPPOE on cisco 1841 router

hi

i am using 1841 router and my interface cable is RJ45 cable not ADSL cable RJ11.

so i need to connect any one of the fast ethernet port in 1841 then how i can use dialer interface..

it is possible

Hall of Fame Super Silver

Re: configureing PPPOE on cisco 1841 router

Hello Cyril,

it is possible sorry for my misunderstanding

interface FastEthernet0/0

no ip address

speed auto

full-duplex

pppoe enable

pppoe-client dial-pool-number 1

this links to dialer interface

interface Dialer0

ip address negotiated

ip access-group 105 in

ip mtu 1454

ip nat outside

encapsulation ppp

ip tcp adjust-mss 1414

no ip mroute-cache

dialer pool 1

dialer idle-timeout 0

dialer-group 1

ppp authentication pap callin

ppp chap hostname johnroche

ppp chap password pppoeisgreat

ppp chap refuse

!

ip route 0.0.0.0 0.0.0.0 Dialer0

on internal interface

int f0/1

ip address 192.168.11.250 255.255.255.0

ip nat inside

speed 100

full-duplex

!

ip nat inside source list 101 interface Dialer0 overload

access-list 101 permit ip 192.168.11.0 0.0.0.255 any

Hope to help

Giuseppe

New Member

if i have a vlan  in that wan

if i have a vlan  in that wan connection how can configure pppoe 

can you give guideline for me

New Member

Re: if i have a vlan  in that wan

Hi,

 

It's not a case since this is router's port not a switch port.

 

Regards,

 

13970
Views
3
Helpful
5
Replies