Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Configuring 1841 with PTP T1

Greetings:

Let me first explain to you our current setup.

We have two locations that have a PTP T1 connecting the two.

Location A has DSL internet, Location B does not.

I want to be able to access DSL from Location B.

I figure that this is possible with the T1 Line. By having the DSL Plugged into the Cisco 1841 router at Location A then having the second 1841 at Location B, I figure we should be able to get out on the internet via that method.

We have a CSU/DSU T1 card in the two modular routers.

Would this setup work, and is there anyother equipment that would be needed for this to work?

You might be asking why not just go with a full T1 with internet service, but thers about a $1500/month difference between that and the PTP T1 method I've described.

Thanks for your help.

  • WAN Routing and Switching
1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: Configuring 1841 with PTP T1

Howdy,

You don't have a default route on the 1841 at location A, for starters... There are some other things, but let's just start with this.

Add a route as follows:

ip route 0.0.0.0 0.0.0.0 192.168.1.1 (if that's the address of the DSL modem)

You are pinging from the 1841 router, are you ?

Paresh

35 REPLIES
Purple

Re: Configuring 1841 with PTP T1

Hi,

What you are proposing is certainly possible and in fact, quite a commonly used scenario.

You do not need any other equipment apart from what you have. To get this working, you need to configure Network Address Translation (NAT) on the 1841 at location A. The use of NAT will allow you to translate any private IP addressing you are using into globally unique addresses.

Here is a list of things you should do:

- Firstly, I presume you already have IP addressing configured at both your locations. If not, assign IP addresses at the two locations out of the RFC1918 private ranges: 10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16

- configure your PCs (hosts) at each site with a gateway address that points to the router's LAN IP address

- set up the T1 controller at both your locations, make sure the line comes up and assign IP addresses at both ends

- once you have done that, configure your router at location B with a static default route that points to the IP address of the serial interface at router A

- on router A, configure your LAN interface and the serial interface as inside NAT interfaces

- on router A, configure the DSL ATM interface as an outside NAT interface

- configure a NAT overload translation on router A that will translate source addresses within the range used at location B to the public address associated with your DSL interface (ensure you use the overload keyword so that port translation will also take place).

That should just about do it....

If you need help with the actual configuration, just let us know...

Hope that helps - pls rate posts that help.

Regards,

Paresh

Purple

Re: Configuring 1841 with PTP T1

Hi,

I should add that you will also need a static route for the network at route A for location B's network...

Paresh

New Member

Re: Configuring 1841 with PTP T1

Thank you for your help in this matter.

Just to make sure I have this clear, Router A should be in a different IP range than Router B?

For example

Router A would have a IP of 10.10.5.1 and Router B would have 10.10.10.1.

If you have a configuration that you think would be useful for this, I would appreciate it, if I could see it.

Thank you

Purple

Re: Configuring 1841 with PTP T1

That is correct.

In a routed world, all distinct link-layer segments have to be distinct subnets.

Your example is correct provided you use a mask such as 255.255.255.0 ...

Here's a sample config for you (you will need to change things such as the T1 parameters and addressing to suit you):

Router A

========

controller t1 0/0/0

framing esf

linecode ami

channel-group 1 timeslots 1-24

!

interface fastethernet0/0

ip address 10.10.5.1 255.255.255.0

ip nat inside

!

interface atm0/1/0

no ip address

!

interface atm0/1/0.32

ip address 203.1.1.1 255.255.255.252

ip nat outside

pvc 1/32

encapsulation aal5snap

vbr-nrt 256 256 1

!

interface serial0/0/0:1

ip address 10.20.1.1 255.255.255.0

ip nat inside

encapsulation ppp

!

ip route 10.10.10.0 255.255.255.0 serial0/0/0:1

!

ip nat inside source list 1 interface atm0/1/0.32 overload

!

access-list 1 permit 10.0.0.0 0.255.255.255

!

PC Configuration:

IP Address: 10.10.5.x

Mask: 255.255.255.0

Gateway: 10.10.5.1

Router B

========

controller t1 0/0/0

framing esf

linecode ami

channel-group 1 timeslots 1-24

!

interface fastethernet0/0

ip address 10.10.10.1 255.255.255.0

!

interface serial0/0/0:1

ip address 10.20.1.2 255.255.255.0

encapsulation ppp

!

ip route 0.0.0.0 0.0.0.0 serial0/0/0:1

!

PC Configuration:

IP Address: 10.10.10.x

Mask: 255.255.255.0

Gateway: 10.10.10.1

Hope that helps - pls rate the post if it does.

Paresh

Hope that helps.

Paresh.

New Member

Re: Configuring 1841 with PTP T1

Thank you for your help.

I'm gonna start configuration tommorrow on it.

Never really done a whole lot with the WAN enviroment.

If I have anymore questions I'll let you know.

Thanks again.

New Member

Re: Configuring 1841 with PTP T1

Ok, heres what I got so far.

I can ping both routers now over the T1, however I can't ping the actual router IP.

For example I'll be at location B and I can ping 10.20.1.1 but when I try to pin 10.10.5.1 its a no go, and vice versa, I can be at location A and ping Router B, but can't ping 10.10.10.1

Also we changed one thing, instead of having the DSL modem plug straight into the router its going into a router first....its your average soho router, plug n play type of thing.

So I was thinking I might need to config the internet part of it a bit differently.

I gave the router that sits between the 1841 and the DSL modem a IP of 10.10.0.1, and the DSL modem itself has a IP Of 192.168.1.1.

I may be wrong but will I need to add a static route at location A of 10.10.0.0 / 255.255.255.0 ?

so that router B trying to get out will hit router A then the router between router A and the DSL modem, then it gets out through the DSL modem.

Thanks in advance.

Purple

Re: Configuring 1841 with PTP T1

Hi mate...

Would you be able to post the configs you've got so far.. makes it a bit easier to troubleshoot..

Thanks,

Paresh

New Member

Re: Configuring 1841 with PTP T1

yeah...I'll have to post it tommorrow though...I'm not in the office anymore now.

I would like to mention that I am using SDM instead of CLI configuration.

I'll get those configs up for you tommorrow though.

Thanks

Purple

Re: Configuring 1841 with PTP T1

No probs.. what you are doing is certainly achievable.

Also, try and see if you can get the CLI configs since they are a bit more useful when troubleshooting.

Paresh

281
Views
10
Helpful
35
Replies
This widget could not be displayed.