Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Configuring 2 or more subnets on the same Frame Relay T1

my question is on how to configure 2 or more subnets on a single Frame Relay T1 interface using the same DLCI (dlci 851 in this case)?

In other words, I need to configure two subnets: 10.5.15.1/240 and 10.5.15.17/240 on a T1 that terminates at my Cat 6509. I have a single dlci (dlci 851) that I need to map or associate these subnets to locally.

  • WAN Routing and Switching
8 REPLIES
Hall of Fame Super Bronze

Re: Configuring 2 or more subnets on the same Frame Relay T1

You create subinterfaces.

interface s0/0

encapsulation frame-relay

frame-relay lmi-type [ansi | cisco]

interface s0/0.1

ip address 10.5.15.1 255.255.255.240

frame-relay interface-dlci [remote dlci]

interface s0/0.17

ip address 10.5.15.17 255.255.255.240

frame-relay interface-dlci [remote dlci]

Please rate helpful posts.

Thanks

Hall of Fame Super Silver

Re: Configuring 2 or more subnets on the same Frame Relay T1

Edison

In the original post Anthony was very clear that he had a single DLCI. Your suggested solution of configuring subinterfaces requires 2 DLCIs.

I am not clear why Anthony needs two subnets on a single DLCI which is inherently a point to point connection. But if he does need two subnets then I believe that the appropriate solution is to configure secondary address on the frame relay interface. It could be done on the primary physical interface or could be done on a subinterface. Without knowing more about the environment and the requirements I would probably suggest configuring a single subinterface with secondary addressing. The configuration would look something like this:

interface s0/0.851

ip address 10.5.15.1 255.255.255.240

ip address 10.5.15.17 255.255.255.240 secondary

frame-relay interface-dlci 851

HTH

Rick

Hall of Fame Super Bronze

Re: Configuring 2 or more subnets on the same Frame Relay T1

Rick, you are right. My apologies for posting an incorrect suggestion.

Hall of Fame Super Silver

Re: Configuring 2 or more subnets on the same Frame Relay T1

Edison

Your instincts were right. Your solution is a common and very good solution - just for a slightly different question.

HTH

Rick

Re: Configuring 2 or more subnets on the same Frame Relay T1

I'd add one more thing - the sub-interface has to be point-to-point, so any traffic matching subnet but not matching local interface address will be send out. If the sub-interface is point-to-multipoint, or if this configured on main interface then static mapping for remote secondary address will be necessary since InARP apparently works only on primary address.

New Member

Re: Configuring 2 or more subnets on the same Frame Relay T1

Thanks for the reponse. However, configuring subinterfaces was not the issue. I've done that many times before. What was unique this time is that I needed to apply the same dlci to both subintfs. IOS complains when you try to do this because it knows the dlci is already configured on the first subintf. What I realized I had to do was apply the dlci to the primary interface only. This seemed to have worked.

interface Serial1/1/3:0

no ip address

encapsulation frame-relay

shutdown

no fair-queue

frame-relay interface-dlci 851

frame-relay lmi-type ansi!

interface Serial1/1/3:0.2 point-to-point

bandwidth 1544

ip address 10.5.15.1 255.255.255.240!

interface Serial1/1/3:0.3 point-to-point

bandwidth 1544

ip address 10.5.15.17 255.255.255.240

New Member

Re: Configuring 2 or more subnets on the same Frame Relay T1

I think you don't need to use subinterface.

like this:

interface s0/0

ip address 10.5.15.1 255.255.255.240

ip address 10.5.15.17 255.255.255.240 secondary

frame-relay interface-dlci 851

New Member

Re: Configuring 2 or more subnets on the same Frame Relay T1

This makes sense and is much easier.

Thanks for the info! I'll try it.

170
Views
0
Helpful
8
Replies
This widget could not be displayed.