Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuring 2 T1's for voice

We have 2 sites connected with 2 Point to Point T1's and are looking for a good design to include voice. We originally had a multilink solution but Qos for voice was not working at all, so I tried to use static statements to point voice over one circuit and data over the other. Any design or functionality thoughts?

Running EIGRP with Cisco 2800 routers

Site A

interface Serial0/0/0

description Data T1

ip address 10.1.x.5 255.255.255.0

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

no cdp enable

service-policy output VOICE-POLICY

!

interface Serial0/2/0

description Voice T1

ip address 10.1.x.6 255.255.255.0

encapsulation ppp

no ip mroute-cache

load-interval 30

no cdp enable

service-policy output VOICE-POLICY

Site B

interface Serial0/0/0

description Data T1

ip address 10.1.x.8 255.255.255.0

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

service-policy output VOICE-POLICY

!

interface Serial0/2/0

description Voice T1

ip address 10.1.x.7 255.255.255.0

encapsulation ppp

no ip mroute-cache

load-interval 30

no cdp enable

service-policy output VOICE-POLICY

ip route 0.0.0.0 0.0.0.0 Serial0/0/0 (data)

ip route 172.x.30.0 255.255.255.0 Serial0/2/0 (Voice)

ip route 172.x.70.0 255.255.255.0 Serial0/2/0 (Voice)

ip route 172.x.80.0 255.255.255.0 Serial0/2/0 (Voice)

3 REPLIES
VIP Purple

Re: Configuring 2 T1's for voice

Hello,

how did you configure your service policy ? Have a look at this configuration example, which can be used for Cisco VoIP traffic:

class-map match-all VoIP_Traffic

match access-group name VOICE_ACL

!

policy-map VOICE-POLICY

class VoIP_TRAFFIC

set dscp 5

class class-default

set dscp 1

!

access-list extended VOICE_ACL

permit tcp any any eq 1720

permit udp any any range 16384 32767

Apply this to all your serial interfaces with the command ´service-policy input VOICE_POLICY.

In addition, turn on CEF, and configure two equal cost default routes, which will ensure per-destination load-balancing over both T1s. So, putting this all together, your configuration should look like this:

Site A

ip cef

!

interface Serial0/0/0

description Data T1

ip address 10.1.x.5 255.255.255.0

encapsulation ppp

no ip mroute-cache

no cdp enable

service-policy input VOICE-POLICY

!

interface Serial0/2/0

description Voice T1

ip address 10.1.x.6 255.255.255.0

encapsulation ppp

no ip mroute-cache

load-interval 30

no cdp enable

service-policy output VOICE-POLICY

!

class-map match-all VoIP_Traffic

match access-group name VOICE_ACL

!

policy-map VOICE-POLICY

class VoIP_TRAFFIC

set dscp 5

class class-default

set dscp 1

!

access-list extended VOICE_ACL

permit tcp any any eq 1720

permit udp any any range 16384 32767

!

ip route 0.0.0.0 0.0.0.0 Serial0/0/0

ip route 0.0.0.0 0.0.0.0 Serial0/2/0

Site B

ip cef

!

interface Serial0/0/0

description Data T1

ip address 10.1.x.8 255.255.255.0

encapsulation ppp

no ip mroute-cache

service-policy output VOICE-POLICY

!

interface Serial0/2/0

description Voice T1

ip address 10.1.x.7 255.255.255.0

encapsulation ppp

no ip mroute-cache

load-interval 30

no cdp enable

service-policy output VOICE-POLICY

!

class-map match-all VoIP_Traffic

match access-group name VOICE_ACL

!

policy-map VOICE-POLICY

class VoIP_TRAFFIC

set dscp 5

class class-default

set dscp 1

!

access-list extended VOICE_ACL

permit tcp any any eq 1720

permit udp any any range 16384 32767

!

ip route 0.0.0.0 0.0.0.0 Serial0/0/0

ip route 0.0.0.0 0.0.0.0 Serial0/2/0

Can you try this config and see if that results in your voice traffic being prioritized ?

Regards,

GP

New Member

Re: Configuring 2 T1's for voice

I have CEF turned on in both routers. Will there be any voice quality issues if the voice packets go across two different T1's? What are the implications of doing it this way (if any)?

My Qos Config:

class-map match-all voice-signaling

match access-group 103

class-map match-all voice-traffic

match access-group 102

!

!

policy-map VOICE-POLICY

class voice-traffic

priority 500

class voice-signaling

bandwidth 24

!

!

access-list 102 permit udp any any range 16384 32767

access-list 103 permit tcp any eq 1720 any

access-list 103 permit tcp any any eq 1720

"service-policy output VOICE-POLICY" is applied to both Serial Interfaces

Are their any recommendations for the priority or bandwidth levels under the policy-maps?

VIP Purple

Re: Configuring 2 T1's for voice

Hello,

by default, CEF does per-destination load balancing, so you should be ok with your voice traffic.

Actually, the configuration example I have given prioritizes all voice (and voice signalling) traffic. If you want to assign a certain amount of bandwidth for your voice traffic, you would need to know how many conversations you average over the line. Each conversation uses approximately 8kbps. In case of doubt, assign more bandwidth than possibly needed, if the bandwidth is eventually not used by the voice traffic, it will be available to the other traffic anyway...

HTH,

GP

204
Views
0
Helpful
3
Replies
CreatePlease login to create content