Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Configuring a 2800 router for two ISP's

How do I configure a 2800 series router for dual WAN connections. I just added another fast ethernet card to the router, and will be connecting two ISP's to the same router. Will need to load balance and set static routes. Anyone know of a knowledgebase article or website that will help me with that?

3 REPLIES

Re: Configuring a 2800 router for two ISP's

what is your topology? assuming you have switch-->2800-->ISP

This could be one way :

interface serial0/0

Description ISP1

ip address 20.20.20.1 255.255.255.252

ip nat outside

interface serial0/1

Description ISP2

ip address 30.30.30.1 255.255.255.252

ip nat outside

interface fE0/0

ip add 192.168.1.1 255.255.255.0

ip nat inside

interface fe0/1

ip add 192.168.2.1 255.255.255.0

ip nat inside

ip nat pool ISP1 20.20.20.1 20.20.20.1 netmask 255.255.255.252

ip nat pool ISP2 30.30.30.1 30.30.30.1 netmask 255.255.255.252

ip nat inside source route-map ISP1 pool ISP1 overload

ip nat inside source route-map ISP2 pool ISP2 overload

ip access-list 101 permit 192.168.1.0 0.0.0.255

ip access-list 102 permit 192.168.2.0 0.0.0.255

route-map ISP1

match ip address 101

match interface S0/0

route-map ISP2

match ip address 102

match interface S0/1

ip route 0.0.0.0 0.0.0.0 20.20.20.2

ip route 0.0.0.0 0.0.0.0 30.30.30.2

there are some other examples here

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a00808d2b72.shtml

some threads here

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=WAN%2C%20Routing%20and%20Switching&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1de00f9f

You may also need these resources

NAT support page

http://www.cisco.com/en/US/tech/tk648/tk361/tk438/tsd_technology_support_sub-protocol_home.html

if not firewalls between 2800 router and ISP I would recommend go over these acls

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_white_paper09186a00801a1a55.shtml

HTH

Jorge

New Member

Re: Configuring a 2800 router for two ISP's

Excellent! This info is a big help. Currently, the 2800 router goes straight into a stack of 3 catalyst 2950's. The reason for this dual WAN is there are several users utilizing an imaging database out of Houston that requires a ton of dedicated badwidth. I'd like to static all traffic to that Houston database thru one ISP, and then push all the other traffic (basic internet, email, etc)thru the other ISP. The Cisco rep that sold me the card made mention that 2 VLAN's would have to be created to accomplish this. Wasn't sure what she meant and wanted to see some sample config's.

Re: Configuring a 2800 router for two ISP's

You could also do it with one FE interface only by 802.1q trunking FE0 interface to switch and pass two subnets into switch. On switch trunk the port connecting to FE these way you can assign switch ports to be in vlan 2 or 3 for hosts that will go to ISP1

and ISP2 respectivately.

e.g

interface FastEthernet0/0

description MyOnlyOne FE INterface

no ip address

no ip proxy-arp

duplex full

speed 100

interface FastEthernet0/0.2

Description VLAN2

encapsulation dot1Q 2 ( for vlan 2 on switch )

ip address 192.168.1.1 255.255.255.0

ip nat inside

interface FastEthernet0/0.3

Description VLAN3

encapsulation dot1Q 3 ( for vlan 3 on switch )

ip address 192.168.2.1 255.255.255.0

ip nat inside

HTH

Jorge

670
Views
10
Helpful
3
Replies
CreatePlease to create content