Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Configuring a Leased Line on Router 1841

Hi Guys,

Can you please assit me with step by step commands to configure a leased line over two sites using router 1841 and Data link provided by COLT network

Would really appreciate a detailed reply, I have got the network ip addresses.

Many Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Configuring a Leased Line on Router 1841

Hi Saurabh,

According to the information from you, you are using a LES circuit. So in your case, the LES should behave just  like a normal (crossover) Ethernet cable interconnecting your two routers together.  On your 1841, no special configuration is necessary besides a  completely ordinary Ethernet configuration and basic routing.

Let's  assume that for the interconnection between your two routers, you have  allocated an IP subnet 192.168.1.0/30. Furthermore, let's assume that  your network behind the router A is 10.0.1.0/24 and the network behind  the router B is 10.0.2.0/24. Routers A and B will be using their Fa0/0  interface to connect to the LES circuit, and each of them will have its  local network connected to the Fa0/1 interface. The configuration then  would be as follows:

Router A:

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.252

no shutdown

!

interface FastEthernet0/1

ip address 10.0.1.1 255.255.255.0

no shutdown

!

ip route 10.0.2.0 255.255.255.0 192.168.1.2

The router B will have similar configuration:

interface FastEthernet0/0

ip address 192.168.1.2 255.255.255.252

no shutdown

!

interface FastEthernet0/1

ip address 10.0.2.1 255.255.255.0

no shutdown

!

ip route 10.0.1.0 255.255.255.0 192.168.1.1

This configuration is the simplest configuration with two routers  having one local network and another one interconnecting them both. For  the additional firewall, I cannot give you an example at this point  because creating a firewall requires creating a comprehensive set of  requirements on what shall and what shall not be permitted.

This  configuration can be verified simply by interconnecting both routers  with a crossover cable between their Fa0/0 interfaces and having a  station connected to the Fa0/1 on each interface, configured  appropriately with IP addressing. One station shall be able to ping the other.

Best regards,

Peter

5 REPLIES
Cisco Employee

Re: Configuring a Leased Line on Router 1841

Saurabh,

We need additional technical information:

  1. What is the interface used to connect to this leased line? Is it a serial interface, or Ethernet, or some other technology?
  2. If it is a serial interface, is the encapsulation used on this leased line arbitrary (i.e you can choose it), or does the leased line use any particular encapsulation - HDLC, PPP, Frame Relay?
  3. Did your provider tell you any connection-specific information to be included in the configuration?
  4. What exact interface will the modem (if any) be connected to?
  5. What is the exact type of this modem or access device?

Best regards,

Peter

Re: Configuring a Leased Line on Router 1841

Hi Peter,

Thanks for your reply,

I have sent you the required information as a private message to your a/c.

Many Thanks for your help.

Rgds

S

Cisco Employee

Re: Configuring a Leased Line on Router 1841

Hi Saurabh,

According to the information from you, you are using a LES circuit. So in your case, the LES should behave just  like a normal (crossover) Ethernet cable interconnecting your two routers together.  On your 1841, no special configuration is necessary besides a  completely ordinary Ethernet configuration and basic routing.

Let's  assume that for the interconnection between your two routers, you have  allocated an IP subnet 192.168.1.0/30. Furthermore, let's assume that  your network behind the router A is 10.0.1.0/24 and the network behind  the router B is 10.0.2.0/24. Routers A and B will be using their Fa0/0  interface to connect to the LES circuit, and each of them will have its  local network connected to the Fa0/1 interface. The configuration then  would be as follows:

Router A:

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.252

no shutdown

!

interface FastEthernet0/1

ip address 10.0.1.1 255.255.255.0

no shutdown

!

ip route 10.0.2.0 255.255.255.0 192.168.1.2

The router B will have similar configuration:

interface FastEthernet0/0

ip address 192.168.1.2 255.255.255.252

no shutdown

!

interface FastEthernet0/1

ip address 10.0.2.1 255.255.255.0

no shutdown

!

ip route 10.0.1.0 255.255.255.0 192.168.1.1

This configuration is the simplest configuration with two routers  having one local network and another one interconnecting them both. For  the additional firewall, I cannot give you an example at this point  because creating a firewall requires creating a comprehensive set of  requirements on what shall and what shall not be permitted.

This  configuration can be verified simply by interconnecting both routers  with a crossover cable between their Fa0/0 interfaces and having a  station connected to the Fa0/1 on each interface, configured  appropriately with IP addressing. One station shall be able to ping the other.

Best regards,

Peter

Re: Configuring a Leased Line on Router 1841

Thanks Peter. I will be connecting one more router at each end via LAN link and will make them available on the network.

It will lock something like this

Internal router 1 ~~~Router A------------Leased Line-------------------- RouterB ~~~ Internal router 2

Would like connectivity b/w Internal router 1 and Internal router 2

Can you provide details of it based on the information you assumed before?

Cisco Employee

Re: Configuring a Leased Line on Router 1841

Hi Saurabh,

The configuration will be very similar to what I have indicated, just more networks will be used, as each connection between two adjacent routers is an IP network of its own.

Before I give you the example configuration, let me ask a few more questions:

  1. I assume there is a network behind the internal routers IR1 and IR2. Is it so? Are there some more networks?
  2. Is there a need to have two routers at each location daisy-chained as you are planning to have right now? Is it not possible to make the entire connection using a single router at each location?
  3. Are you familiar with any routing protocol? The number of networks in your real topology seems to be higher than originally anticipated, and perhaps some routing protocol could be used to disseminate the routing information.
  4. What are the types of the internal routers IR1 and IR2? Do they support any routing protocol?

Best regards,

Peter

5116
Views
0
Helpful
5
Replies
CreatePlease login to create content