Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Configuring an E1 backup link

We are in the process of setting up a remote site. We are using BT to provide a point to point leased line and an ISDN30 PRI at both sites. Only 15 of the E1 channels will be enabled. We are using cisco 2800 routers with a single port serial wic card and a single port ISDN PRI network module in each. The PRI link is to be used as a backup in case of serial link failure I would appreciate detailed advice and guidance on the following:-

1) how to configure /enable the E1 controller (given that it is provided by BT and we are only using ½ of the channels)

2) How to set up the interfaces so that the router will automatically fail over to the PRI link

Thanks

8 REPLIES

Re: Configuring an E1 backup link

Hi Reeces,

You can use backup interface command on e1 link to configure isdn as backup.

This link will guide you with the config for backup links

http://www.networkingunlimited.com/white004.html

HTH

Ankur

VIP Purple

Re: Configuring an E1 backup link

Hello,

first of all, the configuration of your E1 controller would look like this:

controller E1 1

framing crc4

linecode hdb3

clock source line secondary

pri-group timeslots 1-15

The parameters might be slightly different than the ones used here, depending on your provider.

Next, the D-channel interface configuration would look like this:

interface Serial1:0:15

no ip address

encapsulation ppp

dialer pool-member 1

dialer pool-member 1 min-link 14

isdn switch-type primary-net5

no cdp enable

ppp authentication chap

ppp multilink

Then, you would create a dialer interface for the connection to the other side:

interface Dialer1

ip address 192.168.1.1 255.255.255.252

encapsulation ppp

dialer pool 1

dialer remote-name Remote1

dialer string 123456

dialer-group 1

ppp authentication chap

ppp multilink

Regarding the backup method, it depends on if and what routing protocols you are using. The easiest way to configure the backup would be to include the statement 'backup interface dialer 1' on your main serial interface, that is, the serial interface of the leased line. Other options, such as dialer watch, or snapshot routing, are available as well, depending on, as said before, the routing protocols you are using.

Hope I did not forget anything. Of course, make sure you are either using local username and password for the CHAP (if you use CHAP) or have that configured in e.g. an ACS.

Let me know if you run into trouble...

Regards,

GP

New Member

Re: Configuring an E1 backup link

Hi, Many thanks for the information - most helpful. A couple of questions though -

1) I presume I need to set up an access list for the dialer1 interface to define 'interesting' traffic for it to actually be brought up as a backup

2) I will be using static routes rather than any routing protocol - My serial link and Dialer will be on seperate networks so I guess I need to set two static routes for every destination - one for the serial link and one for the Dialer?

3) Any special config required for this or is it simply a matter of setting two static routes up?

Re: Configuring an E1 backup link

Hi Reces,

Yes you have to configure access list and call that access list in dialer list to define your interesting traffic.

It will be something liek this

interface dialer 1

dialer-group 1

!

dialer list 1 protocol permit ip 101

!

access-list 101 deny x.x.x.x

access-list 101 permit ip any any

This way you can configure your interesting traffic and can configure your access list as per your wish and requirement.

HTH

Ankur

VIP Purple

Re: Configuring an E1 backup link

Hello,

when you use the ´backup interface dialer 1´ command under your serial interface, you do not need to specify an access list for your interesting traffic, the dialer interface will be up/up (spoofing), which means it will not route any traffic unless the main interface goes down. So the statement ´dialer-list 1 protocol ip permit´ would be sufficient.

As for the static routes, yes, just configure two default routes with different administrative distances:

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 0.0.0.0 0.0.0.0 Dialer1 200

HTH,

GP

New Member

Re: Configuring an E1 backup link

and I presume that a dialer string needs only to be specified on one side of this simple point-to-point example as you wouldn`t want both routers to try and dial each other if there is a failure?

New Member

Re: Configuring an E1 backup link

And finally,

Things are almost working but when failing over to the ISDN E1, only one channel is brought up. I enclose what I believe to be the appropriate bits of config as I think it is likely a config error as I want to bring all available chnnels up.

controller E1 1/0

pri-group timeslots 1-16

interface Serial1/0:15

no ip address

encapsulation ppp

dialer pool-member 1 min-link 14

isdn switch-type primary-net5

no cdp enable

ppp authentication chap

ppp multilink

!

interface Dialer1

ip address 10.20.0.2 255.255.255.0

encapsulation ppp

dialer pool 1

dialer remote-name XXXXXXXX

dialer string XXXXXXXXXXX

dialer-group 1

no cdp enable

ppp authentication chap

ppp multilink

access-list 101 remark Intersting Traffic Definition for Backup Link

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

VIP Purple

Re: Configuring an E1 backup link

Hello,

try and add ´ppp multilink links minimum 14´ to your dialer 1 interface configuration.

Regards,

GP

288
Views
4
Helpful
8
Replies
CreatePlease to create content