Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuring controllers in Cisco 2620

Hi,

I am somewhat new to cisco IOS. We have full T1 line terminated at cisco 2620 (IOS 12.3)with the integrated CSU/DSU. It has two interfaces FastEthernet 0/0 (LAN) and Serial 0/0 (T1). At least that's what the router shows when I execute the command 'show int'.

I've been seeing a lot of frame drops in the serial0/0 interface and CRC error. Here is what my router shows (1wd4 stat):

Input queue: 0/75/0 (size/max/drops); Total output drops: 404021

Queueing strategy: weighted fair

Output queue: 0/1000/64/404021 (size/max total/threshold/drops)

Conversations 0/130/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 98000 bits/sec, 88 packets/sec

5 minute output rate 606000 bits/sec, 698 packets/sec

493258 packets input, 80216893 bytes, 0 no buffer

Received 505 broadcasts, 0 runts, 0 giants, 0 throttles

2034 input errors, 540 CRC, 0 frame, 0 overrun, 0 ignored, 0 abor

3463399 packets output, 419484254 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

My ISP asked me to check the frame type and clock source. They said it should be ESF for frame and line for clock source. Looking through IOS 12.3 documentation, I see one of the controllers (either E1 or T1) has these settings. But if I execute the 'show controller e1' or 'show controller t1', I see nothing or even errors. The router goes back to command prompt as if nothing is configured for E1 or T1.

So my question is where would I go to set these configs?

Thanks

4 REPLIES
Purple

Re: Configuring controllers in Cisco 2620

Hi,

'show controller t1 0/0' should show you these settings ....

Paresh

New Member

Re: Configuring controllers in Cisco 2620

This is what I get if I type 'show controller t1 0/0'

router#show controller t1 0/0

^

% Invalid input detected at '^' marker.

router#

But if I enter 'show controller serial 0/0', this is what I get:

router#show controller se 0/0

Interface Serial0/0

Hardware is PowerQUICC MPC860 with Integrated FT1 CSU/DSU mo

TX and RX clocks detected.

idb at 0x80C0E718, driver data structure at 0x80C14674

SCC Registers:

General [GSMR]=0x2:0x00000030, Protocol-specific [PSMR]=0x8

Events [SCCE]=0x0000, Mask [SCCM]=0x001F, Status [SCCS]=0x06

Transmit on Demand [TODR]=0x0, Data Sync [DSR]=0x7E7E

Interrupt Registers:

Config [CICR]=0x00367F80, Pending [CIPR]=0x00008000

Mask [CIMR]=0x40204000, In-srv [CISR]=0x00000000

Command register [CR]=0x600

Port A [PADIR]=0x0000, [PAPAR]=0xFFFF

[PAODR]=0x0000, [PADAT]=0xE7FD

Port B [PBDIR]=0x0180F, [PBPAR]=0x0E00E

[PBODR]=0x0000E, [PBDAT]=0x3077D

Port C [PCDIR]=0x00C, [PCPAR]=0x000

[PCSO]=0x020, [PCDAT]=0xFC0, [PCINT]=0x00F

Receive Ring

rmd(68012830): status 9000 length 76 address 1B6DD44

rmd(68012838): status 9000 length 9E address 1B6F744

rmd(68012840): status 9000 length 86 address 1B71E44

rmd(68012848): status 9000 length 12A address 1B6A94

rmd(68012850): status 9000 length 55 address 1B695C4

router#show controller t1

router#

Thanks for the help

Purple

Re: Configuring controllers in Cisco 2620

Ok, I see your problem. Try the following command: show service-module serial 0/0

Paresh.

PS. Pls do remember to rate posts

New Member

Re: Configuring controllers in Cisco 2620

This is what I got. Now I can see clock source and framing type.

router#show service-module serial 0/0

Module type is T1/fractional

Hardware revision is 0.96, Software revision is 0.2,

Image checksum is 0xED22BEC5, Protocol revision is 0.1

Receiver has no alarms.

Framing is ESF, Line Code is B8ZS, Current clock source is line,

Fraction has 24 timeslots (64 Kbits/sec each), Net bandwidth is 1536 Kbits/sec.

Last module self-test (done at startup): Passed

Last clearing of alarm counters 1d22h

loss of signal : 0,

loss of frame : 0,

AIS alarm : 0,

Remote alarm : 0,

Module access errors : 0,

Total Data (last 96 15 minute intervals):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Data in current interval (129 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Thanks.

So why didn't 'show controller t1 0/0' didn't work. Thanks

262
Views
0
Helpful
4
Replies
CreatePlease to create content