Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuring FTP on local IP Address

Hi Netpros,

I wanted to configure FTP server on private Ip Address Range as 192.xx.xx.xx/24. I do have one public IP.

So i wanted to forward the FTP request for port number 21 on that perticular Private Ip Address which is already configured with FTP Server and working fine locally.

Ii have Cisco 2621 with IOS 12.1

can any budy has the solution or provide me any link to resolve this issue.

Thanks,

Dhaval Tandel

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Configuring FTP on local IP Address

and dhaval you can use same thing for port 80 for website

rate this post if it helps

regards

Devang

18 REPLIES
Hall of Fame Super Bronze

Re: Configuring FTP on local IP Address

interface f0/0

description internal network

ip address 192.168.1.1 255.255.0

ip nat inside

interface fa0/1

description outside network

ip address 69.255.255.255 255.255.255.252

ip nat outside

ip nat inside source static tcp [local ip] 21 interface fa0/1 21

New Member

Re: Configuring FTP on local IP Address

Hi

Thanks for taking interest..

I did try by above config but its not working i also do same for port number 80 but no any luck.....is there any thing else to do with this configuration...?

Thanks

Dhaval Tandel

Hall of Fame Super Bronze

Re: Configuring FTP on local IP Address

Can you post your config ?

New Member

Re: Configuring FTP on local IP Address

Current configuration : 1997 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname IndiaVoiceRouter

!

logging buffered 16000 debugging

enable secret xxx

!

!

ip subnet-zero

ip host voicerouter 192.168.1.100

ip name-server 202.xx.xx.xx

ip name-server 202.xx.xx.xx

ip dhcp database tftp://192.168.1.13/dhcp-lease

ip dhcp excluded-address 192.168.1.100

!

ip dhcp pool 192.168.1.0/24

network 192.168.1.0 255.255.255.0

default-router 192.168.1.100

dns-server 202.xx.xx.xx 202.xx.xx.xx

lease 333

!

!

!

interface FastEthernet0/0

ip address 61.xx.xx.xx 255.255.255.0

no ip redirects

ip nat outside

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.1.100 255.255.255.0

ip nat inside

duplex auto

speed auto

!

ip default-gateway 61.xx.xx.xx

ip nat pool dhara 61.xx.xx.xx 61.xx.xx.xx netmask 255.255.255.0

ip nat inside source list 3 pool dhara overload

ip nat inside source static tcp 192.168.1.11 80 interface FastEthernet0/0 80

ip nat inside source static tcp 192.168.1.11 21 interface FastEthernet0/0 21

ip classless

ip route 0.0.0.0 0.0.0.0 61.xx.xx.xx

no ip http server

!

logging 192.168.1.13

access-list 3 permit 192.168.1.0 0.0.0.255

access-list 121 permit tcp any any range ftp-data ftp

access-list 121 permit tcp any any eq www

!

line con 0

line aux 0

line vty 0 4

password xxx

login

!

end

IndiaVoiceRouter#

New Member

Re: Configuring FTP on local IP Address

HI

Additionally both the ACL-121 has been removed now....

Thanks

Dhaval Tandel

New Member

Re: Configuring FTP on local IP Address

Any Luck...?

Hall of Fame Super Bronze

Re: Configuring FTP on local IP Address

Can you turn a debug ip nat and see if the address is getting translated ?

Also, since you have a pool of public IPs, why don't you take a public IP from the pool and do a static assignment instead of using the Fa0/0 interface ?

New Member

Re: Configuring FTP on local IP Address

HI

Thnaks fo rtakin interest...

I did replace with public ip instade of fa0/0.

my debug is on bu i cant see any messages on terminal...

am not getting this...

Thanks

Dhaval Tandel

Hall of Fame Super Bronze

Re: Configuring FTP on local IP Address

You won't see the messages on terminal unless you typed 'term mon'. You should be able to see the message in the log by typing 'show log'.

The command is

#debug ip nat detailed

Re: Configuring FTP on local IP Address

dhaval add only extendable keyword

ip nat inside source static tcp localIP 21 globalIP address 21 extendable

and let me know it works or not

please rate this post if it helps

regards

Devang

Bronze

Re: Configuring FTP on local IP Address

Hi dhaval,

use this command

ip nat service list ftp tcp command.

Note:The access list address in the above command must match the inside local IP address for the FTP server .

!

access-list 10 permit 192.168.1.11

!

!

ip nat service list 10 ftp tcp port 21

ip nat inside source static 192.168.1.11 interface FastEthernet0/0

!

Tell me if it worked

Thanks

Raj

New Member

Re: Configuring FTP on local IP Address

HI, RAJ

Thasks but no any luck yet...

i think you saw my last post for statics can you recognise why that...?

Thanks,

Dhaval Tandel

Hall of Fame Super Bronze

Re: Configuring FTP on local IP Address

Dhaval,

Can we see the #debug ip nat detailed

output ?

Re: Configuring FTP on local IP Address

and dhaval you can use same thing for port 80 for website

rate this post if it helps

regards

Devang

New Member

Re: Configuring FTP on local IP Address

Hi

i got resolve my issue and thaks for takin interest...

Thanks

Dhaval Tandel

New Member

Re: Configuring FTP on local IP Address

Hi

I now my 21 port is workin but i cant use port number 80 using same command....

is there any additional thing required...

Thanks

Dhaval Tandel

Hall of Fame Super Bronze

Re: Configuring FTP on local IP Address

Port 80 active on 192.168.1.11 ?

Can you access port 80 to this device internally ?

Can you post the config with the new changes ?

Re: Configuring FTP on local IP Address

dhaval again make sure your static natting must be perfect with port 80 and tcp and dont forgot to use extendable...

because i have configured same thing for my home also...

rate this post if it helps

regards

Devang

264
Views
5
Helpful
18
Replies