Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

configuring NAT in 2811 router

I need some ideas in configuring NAT on my new 2811 router

I am planning to use my 2811 router for routing, firewall and also to do NAT to my LAN.

I have installed an HWIC T1 DSU/DSU card as serial interface and the router comes with two fast ethernet ports

My ISP is giving me an csu/dsu handoff and have given me the ip address I have to assign on my serial interface.I have purchased 50 public IPs from the ISP also.

I am planning to terminate the Fa0/0 interface on the existing LAN switches which have private IP assigned.

My question is what addresing should I give to my Fa0/0 interface, is it going to be the public IP address I have purchased from the ISP or the private IP address of the LAN. and how will I perform NATing on the interface

2 REPLIES

Re: configuring NAT in 2811 router

Hi Saravana,

since you say you have purchased 50 public IP address from ur ISP, you need not do any NAT on the router, 1 of the public IP address should configured in fastethernet 0/0 & rest eg. for ur web,ftp,mail servers etc..., as also make 1 as a IGS(Internet Gateway Server) which will have 2 NIC 1 will point towards Internet Router & other pointing towards LAN having Private IP Address. by doing this you need not do NAT on the router rather you need to do NAT on the IGS can be a LINUX/Windows OS. if you still say that you wanted to do NAT on the router, below are the configuration

interface Serial0

description "To Internet"

ip address 202.2.2.1 255.255.255.252

ip nat outside

!

interface FastEthernet0

description " To LAN"

ip address 192.168.1.1 255.255.255.0

ip nat inside

!

ip nat translation timeout 3600

ip nat pool test 203.1.1.2 203.1.1.30 netmask 255.255.255.240

ip nat inside source list 1 pool test overload

these are the NAT command on the router, if you still say that you wanted to hav a public server like ftp,mail,web inside ur office & also LAN to be connected, juz add a secondary IP as public.

hope this helps.

rate this post if cleared.

New Member

Re: configuring NAT in 2811 router

Thanks Anandan, It made it very clear.

396
Views
4
Helpful
2
Replies
CreatePlease to create content