Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Configuring NAT Overload for 5 different sunets

Im currently in the middle of configuring a network using NAT(Overload) with 5 Subnets needing to be translated. The Nat/DHCP router has 3 network interface cards, each with a router attached to it. DHCP works perfectly, However translation at the Network gateway is not taking place. Below is the show run for the DHCP/NAT router. Thanks in advance guys.

hostname Router

!

!

!

!

ip dhcp excluded-address 192.168.10.0 192.168.10.3

ip dhcp excluded-address 192.168.50.0 192.168.10.3

!

ip dhcp pool Vlan10

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1

ip dhcp pool Vlan50

network 192.168.50.0 255.255.255.0

default-router 192.168.50.1

!

no ip cef

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface GigabitEthernet7/0

ip address 193.168.10.1 255.255.255.0

ip nat outside

duplex auto

speed auto

!

interface GigabitEthernet8/0

ip address 192.168.30.2 255.255.255.0

ip nat inside

duplex auto

speed auto

!

interface GigabitEthernet9/0

ip address 192.168.40.2 255.255.255.0

ip nat inside

duplex auto

speed auto

!

router rip

version 2

network 192.168.30.0

network 192.168.40.0

network 193.168.10.0

!

ip nat inside source list 20 interface GigabitEthernet7/0 overload

ip classless

!

ip flow-export version 9

!

!

access-list 20 permit 192.168.10.0 0.0.0.255

access-list 20 permit 192.168.20.0 0.0.0.255

access-list 20 permit 192.168.50.0 0.0.0.255

access-list 20 permit 192.168.60.0 0.0.0.255

access-list 20 permit 192.168.70.0 0.0.0.255

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

2 REPLIES
Community Member

Not that it is probably

Not that it is probably related, but your exclude statement has a typo:

        ip dhcp excluded-address 192.168.50.0 192.168.10.3

If you can, try clearing the nat table with:  clear ip nat translation *

If it is still an issue, can you paste the output of "sh ip nat translations" and "sh ip nat statistics"

I also don't see a default gateway in the config.

VIP Purple

Hello,

Hello,

the access list (20) includes the address space of the NAT outside interface. Change it as below. I would also include network 192.168.10.0 in RIP:

hostname Router
!
ip dhcp excluded-address 192.168.10.0 192.168.10.3
ip dhcp excluded-address 192.168.50.0 192.168.10.3
!
ip dhcp pool Vlan10
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
ip dhcp pool Vlan50
network 192.168.50.0 255.255.255.0
default-router 192.168.50.1
!
no ip cef
no ipv6 cef
!
interface GigabitEthernet7/0
ip address 193.168.10.1 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface GigabitEthernet8/0
ip address 192.168.30.2 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface GigabitEthernet9/0
ip address 192.168.40.2 255.255.255.0
ip nat inside
duplex auto
speed auto
!
router rip
version 2
network 192.168.10.0
network 192.168.30.0
network 192.168.40.0
network 193.168.10.0
!
ip nat inside source list 20 interface GigabitEthernet7/0 overload
!
ip classless
!
ip flow-export version 9
!
access-list 20 permit 192.168.20.0 0.0.0.255
access-list 20 permit 192.168.50.0 0.0.0.255
access-list 20 permit 192.168.60.0 0.0.0.255
access-list 20 permit 192.168.70.0 0.0.0.255
!
line con 0
!
line aux 0
!
line vty 0 4
login

16
Views
0
Helpful
2
Replies
CreatePlease to create content