Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Configuring new serial int

Hello,

I have posted on here a few times before and you guys have been very helpful. So here goes!

I have an existing Cisco 2621XM. It is connected to an external DSU via an ehternet crossover cable. I am about to get another T1 into the building from the same ISP but on a new DSU. I plan to buy 2 WIC-1T interfaces and use them to connect to both the DSUs. The DSUs are Adtran 608. They have v.35 interfaces. So, I relise this is asking a lot but could anyone help me with the best way to configure my router to use this config? I am a complete newb when it comes to Cisco and though I can use the command line and change settings, I have no idea about the best way to do this.

Please let me know if you need any more info.

I appreciate any help you can give me.

Paul

35 REPLIES
Purple

Re: Configuring new serial int

Hi Paul,

A WIC-1T gives you a serial interface. You can use a config like the following at each end:

interface serial0/0

ip address x.x.x.x y.y.y.y

encapsulation ppp

If this is a point-to-point link, the above should get you going.

Hope that helps - pls rate the post if it does.

Paresh

Re: Configuring new serial int

Thanks for your reply Paresh. I don't have access to the Adtran to configure it so I guess I will need to ask the ISP for config details. The Serial int will be going to a v.35 on the adtran. I was told by the tech that the encpsulation would be hdlc. Does that sound right?

Purple

Re: Configuring new serial int

You don't really need access to the Adtran as long as you know details of the service.

HDLC is fine - just remove the 'encapsulation ppp' command from the config I provided earlier.

Pls do remember to rate posts that help.

Paresh

Re: Configuring new serial int

Once again, Thank you for your help. I have a few more questions. I asked previously in this forum about load balancing and you replied telling me bout CEF and showed me a config that was something like this:

ip cef

!

ip route 0.0.0.0 0.0.0.0 serial0:1

ip route 0.0.0.0 0.0.0.0 serial1:1

There is alredy a route in the router that is like this:

ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xx (where xx is the ip address of the default gateway of the ISP)

There is also this:

ip nat inside source static 10.0.0.2 xx.xx.xx.xx

(where the 10.x.x.x address is the outside nic on the ISA server the router is connected to and xx is the outside interface of the router, connected to the adtran)

Is this going to be affected by the new configuration? If so, ow should I reconfigure the router?

Again, any help would be apprciated. I realise the router is probably not configured very well and I am happy to make changes for the better, but it works right now and I am loath to break it!

Thank you.

Paul

Purple

Re: Configuring new serial int

Hi Paul,

Here's what you need to do:

- add another default route with next-hop equal to the ISP's address on the second link:

ip route 0.0.0.0 0.0.0.0 yy.yy.yy.yy

- the inside source static command is fine and can stay

- if you have an 'ip nat inside source list' command, you will need to replace it with something like the following:

ip nat inside source route-map ISP1-map interface serial0:1

ip nat inside source route-map ISP2-map interface serial1:1

!

route-map ISP11-map permit 10

match interface serial0:1

!

route-map ISP12-map permit 10

match interface serial1:1

You might wanna post your full config in order so that it helps us to see if we have everything covered, though...

Hope that helps - pls rate the post if it does.

Paresh

Re: Configuring new serial int

Hi again Paresh,

I have attatched my full config as suggested. Any suggestions regarding improvments will be greatfully received.

Thank you.

Paul

Purple

Re: Configuring new serial int

Just another query before I comment on the config ... Both your DSU facing interfaces will end up being serial interfaces, right ?

Paresh

Re: Configuring new serial int

Yes Paresh, they will both be WIC-1Ts.

Thanks,

Paul

Purple

Re: Configuring new serial int

In that case, Paul, the changes I mentioned earlier should be all you need in order to get this working over the two link.

Feel free to post back with the complete config once you have done it up if you want us to give it a look.

Paresh

Re: Configuring new serial int

Hi again Paresh,

Ok, I am just a bit confused about one point. With the lines

ip nat inside source route-map ISP1-map interface serial0:1

ip nat inside source route-map ISP2-map interface serial1:1

Is the number after the : indicating the int number or is it in addition to the int number. My serial int is numbered serial0/0. So, once that is gone and the two new serial ints are installed would the line look like this?

ip nat inside source route-map ISP1-map interface serial0/0:1

ip nat inside source route-map ISP2-map interface serial0/1:1

Do I also still need the following:

ip cef

!

ip route 0.0.0.0 0.0.0.0 serial0/0:1

ip route 0.0.0.0 0.0.0.0 serial0/1:1

and with what I just said above, would they look like that?

Last of all (for now!)

Would I be able to configure something like this using wht I have installed right now? Obviously, it would not completely work because the serial int I have is not connected to anything. But would it not act like the link was there but not availible?(I have it cable loop backed)

If so, would it look like this?

ip cef

!

ip route 0.0.0.0 0.0.0.0 Fastethernet0/1:1

ip route 0.0.0.0 0.0.0.0 serial0/0:1

And then

ip nat inside source route-map ISP1-map interface Fastethernet0/1:1

ip nat inside source route-map ISP2-map interface serial0/0:1

!

route-map ISP11-map permit 10

match interface Fastethernet0/1:1

!

route-map ISP12-map permit 10

match interface serial0/0:1

Would that work? Even just to help me see how it comes together or am I way off base?

Thank you again.

Paul

Purple

Re: Configuring new serial int

Hmm.. I see I've got you a bit confused. What I posted was an example and as such, used some sample interface types.

So addressing your questions:

- the number after the colon is the channel-group number; that is something you use with E1/T1 channelised interfaces. In your case, you are using serial interfaces so you will not need that at all. So pls remove the colon and the following number from your config !

Your config lines will look like:

ip nat inside source route-map ISP1-map interface serial0/0

ip nat inside source route-map ISP2-map interface serial0/1

You still need the following:

ip cef

!

ip route 0.0.0.0 0.0.0.0 serial0/0

ip route 0.0.0.0 0.0.0.0 serial0/1

In answer to your last question, it's best not to configure the above if the link is not up. In fact, things get a lot hairier with Ethernet interfaces cause they don't necessarily go down when the link goes down. So I would not recommend using this with your current setup. Install the 2 T1s first and then tweak your config to get the redundancy working.

Hope that helps - pls rate the post if it does.

Paresh

Re: Configuring new serial int

Ok, last question for now, I promise!

I understand that I will have 4 routes configured.

The two for the serial interfaces and two for the ISP hops:

ip route 0.0.0.0 0.0.0.0 serial0/0

ip route 0.0.0.0 0.0.0.0 serial0/1

ip route 0.0.0.0 0.0.0.0 yy.yy.yy.yy

ip route 0.0.0.0 0.0.0.0 yy.yy.yy.yy

with the yy being whatever the next hop is for the ISP? Do I have that right?

I am learning a great deal, thanks once more.

Paul

Purple

Re: Configuring new serial int

No probs at all, Paul.

You only need to have two routes configured.. either the first two or the last two of the 4 that you posted - it does not really matter which but I would suggest that you use the ones pointing to the serial interface - that gives you some protection in case your change your IPs at some point:

ip route 0.0.0.0 0.0.0.0 serial0/0

ip route 0.0.0.0 0.0.0.0 serial0/1

Paresh

Re: Configuring new serial int

Once again, thank you for your help. Do I understand corrctly, that I could immplement that right now?

Instead of the route

ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xx

I could have it point to the FE0/1 int? If this is the case, is there anything else I would need to do?

Paul

Purple

Re: Configuring new serial int

Hi Paul,

With Ethernet interfaces, it is best to use a route such as the following:

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 xx.xx.xx.xx

This is because it's a multiaccess interface and you are better off pointing to a next-hop address on that interface. If you don't, your router will send out unnecessary ARPs for every single address ...

Hope that helps - pls rate the post if it does.

Paresh

Re: Configuring new serial int

Hi Paresh,

When I use the route ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 xx.xx.xx.xx

I loose connection to the T1. I am assuming of course that xx is the next hop. IE the default gateway I have set up in my

ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xx

It works if the other route is stll in there but if I remove it, it stops working...

Any ideas?

Thanks

Paul

Re: Configuring new serial int

Ok, I experimented a little. When I enter the command

no ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xx

To see if it will work with just the

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 xx.xx.xx.xx

It removes both the route. Neither are in the sh ip route where as, before I entered the no ip route comand mentioned above they were both visable....it also removed the

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 xx.xx.xx.xx

line from the config.....

It seems I am doing something wrong!

Purple

Re: Configuring new serial int

Hi Paul,

Can I calrify what exactly you want to achieve at the moment...

1. You have an internet link via Fast0/1 and another via a T1

2. You want to load-balance over the two links

Is the above correct or do you want to use the links in a primary/backup fashion ?

Paresh

Re: Configuring new serial int

Hi Paresh,

I think I am confusing the issue. It would be better to wait until my second T1 is installed! I will immplement the suggestions you have lredy given me nd then post on my progress. Thans for your help so far

Paul

Purple

Re: Configuring new serial int

Hey Paul,

That's what I was kinda getting at...

Post back when you get the second T1.

Regards,

Paresh

Re: Configuring new serial int

Hi Paresh,

It seems I have a problem! I was informed lte yesteday that our existing Adtran DSU from our ISP will not be able to use v.35. The only way this Adtran can deliver service is over the ethernet port. This is, as I have said, the way we have it now. The new Adtran will be able to use v.35. So, with this in mind, how best can I configre this?

To recap:

1st T1 will go into FE0/1

2nd T1 will go into WIC-1T

I would still like to load balance and have some redundancy. I am no certin how this i going to affect that.

Thank you.

Paul

Purple

Re: Configuring new serial int

Hi Paul,

This just means that you will need to do a lot more configuration. As I mentioned below, the problem with Ethernet interfaces is that they won't go down even if your link to the ISP goes down. Therefore, you have to use the reliable static routing feature in order to ensure that the route through the interface is brought down when the link goes down.

I've got a sample config that illustrates how to do this (you will need to modify this to apply it to you router):

Replace with an IP that you can ping through your main link - preferably the ISP side of the WAN link address.

interface Ethernet 0/0

description Primary Link

ip address 10.1.1.1 255.0.0.0

!

interface Serial0

description Backup Link

ip address 192.168.1.1 255.0.0.0

!

rtr 1

type echo protocol ipIcmpEcho

timeout 1000

frequency 3

threshold 2

!

rtr schedule 1 life forever start-time now

!

track 100 rtr 1 reachability

!

access list 101 permit icmp any host echo

!

route map LOCAL_POLICY permit 10

set ip next-hop 10.1.1.254

set interface null0

!

ip local policy route-map LOCAL_POLICY

!

ip route 0.0.0.0 0.0.0.0 10.1.1.254 track 100

ip route 0.0.0.0 0.0.0.0 192.168.1.254 254

Have a got at coming up with a config and then post it and I'll have a look...

Pls do rate the post if it helps...

Paresh

Re: Configuring new serial int

Ok Paresh, I will give it a try. COuld you possibly run through your config here and give me some notes on what it all means. I get the general gist of it but some of it my as wll be a foreign tounge!

Thank you so much for all your help so far.

Paul

Purple

Re: Configuring new serial int

Ok, let me try...

The difference here is that you are associating a tracking object with your static route. The static route will remain in the routing table as long as the state of the tracked object stas up. In the config I provided, the tracked object is tracking the status of a RTR object. RTR (which is now called IP SLA) is a mechanism used to initiate QoS-type actions from the router. In this case, I use it to initiate a ping from the router to an address on the internet. The local policy ensures that it is sent out of the ethernet interface. As long as we can ping this address, the RTR object returns a succesful status to the tracked object and the static route stays up. If we can't ping that address, the tracked object and the static route goes down. This provides dynamic tracking of the state of your link.

Hope that explains it somewhat...

Pls do remember to rate the posts.

Paresh

Re: Configuring new serial int

Hello Paresh.

Ok, so far so good. I understand, I think, what you have said so far. Will this configuration be able to take advantage of both links in a load-balance scenario? Or is it limited to primary/backup? I would really like to have both links available....

Paul

Re: Configuring new serial int

Hello again,

I was trying out the rtr commands on my existing setup. I figured I could at least see what it does and how it shows up. Well, I got to the part

track 100 rtr 1 reachability

And my router returned an error. I was in config t and the error was:

router(config)#track 100 rtr 1 reachability

^

% Invalid input detected at '^' marker.

Was I in the correct config mode?

Sorry to be such a pain. I am really trying to get to grips with all this!

Thank you.

Paul

Purple

Re: Configuring new serial int

Hey Paul,

What IOS version are you ruuning ? Some of the commands are IOS-dependent...

Paresh

Re: Configuring new serial int

Hi Paresh,

I am running Version 12.2(8)T5. I guess I need to upgrade it huh?

Thanks,

Paul

Purple

Re: Configuring new serial int

Yes, you do. I believe you need something like 12.3(8)T for the reliable static route feature.

Hope that helps - pls rate the post if it does.

Paresh

259
Views
20
Helpful
35
Replies