Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

lap
New Member

Configuring PPPoE with FVRF on a C881

Hi,

I have a big doubt on how I can configure PPPoE on a C881 with FVRF. I explain a bit deeper. Our customer is migrating from a IPsec HUB and SPOKE network to a DMVPN network. There is a SPOKE location in France which should get a new C881 to join the DMVPN network. My problem is that the ISP in France is using PPPoE and I have VRF configured on the Internet facing interface.

If I tried the following the ip address negociated in not taken in account:


interface FastEthernet 4
description ***Connection to WAN***$ETH-WAN$
no ip address
pppoe enable
pppoe-client dial-pool-number 1
no shutdown


interface Dialer0
description ***Connection to WAN***$ETH-WAN$

bandwidth 670
ip access-group OUTSIDE_IN in
ip vrf forwarding FVRF

ip mtu 1492
encapsulation ppp
dialer pool 1
ppp authentication chap pap callin
ppp pap sent-username X password 0 X

So if I try to add ip address negociated to interface dialer 1 the command is not taken in account!

Does anyone knows how I can solve this problem? Maybe with virtal-interface? Does the PPPoE config looks ok?

Regards,

Laurent

1 REPLY
lap
New Member

Re: Configuring PPPoE with FVRF on a C881

So I found out how to solve this issue.

You have to do the following:

default interface dialer 0 //if dialer 0 was alredy configured

interface dialer 0

ip vrf forwarding X

ip address negociated

shutdown

Then you should add the rest of the PPPoE config to the dialer interface:

interface Dialer0
encapsulation ppp
dialer pool 1
ppp chap hostname fti/fdguhk3
ppp chap password 0 gkccp9ca
ppp ipcp route default

Regards,

Laurent

1050
Views
0
Helpful
1
Replies