cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
716
Views
0
Helpful
1
Replies

Confiure QOS on ATM PVC's

jhalterman805
Level 1
Level 1

I am trying to conifgure QOS on my ATM PVC's and wanted to see if what I have put together is going to work as I am no QOS expert.

A little run down....we have a Avaya phone system and have point to point DS-3's between 3 sites using ATM interfaces on 7206vxr routers.

This is what I plan on applying to the ATM3/0.32 and .33 subinterface PVC's

class-map match-any voice
match access-group 100
match ip rtp 163834 16383
!
!
policy-map voip
class voice
  priority percent 65
class class-default
  fair-queue

!
access-list 100 permit ip any any precedence critical
access-list 100 permit ip any any dscp ef
access-list 100 permit udp any any range 16384 32767
access-list 100 permit ip any any precedence flash
access-list 100 permit ip any any dscp cs3
access-list 100 permit tcp any any eq 1720
access-list 100 permit tcp any any range 11000 11999
access-list 100 permit udp any any eq 2427
access-list 100 permit tcp any any range 2000 2002
access-list 100 permit udp any any range 49152 53246

This is how the ATM interfaces are configured:

interface ATM3/0
description Primary link to SJC
no ip address
ip flow ingress
atm clock INTERNAL
atm scrambling cell-payload
no atm ilmi-keepalive
!
interface ATM3/0.32 point-to-point
description Data PVC to SJC
bandwidth 42000
ip address 10.0.0.5 255.255.255.252
no ip redirects
ip flow ingress
no ip mroute-cache
no snmp trap link-status
pvc 1/32
  oam-pvc manage
  oam retry 3 10 1
  encapsulation aal5snap
!
!
interface ATM3/0.33 point-to-point
bandwidth 3000
ip address 10.0.0.9 255.255.255.252
ip flow ingress
no snmp trap link-status
pvc 1/33
  vbr-rt 3000 2000 32
  oam-pvc manage
  oam retry 3 10 1
  encapsulation aal5snap

This is how I plan on appling the service policy:

interface ATM3/0.32
pvc 1/32
  service-policy output voip

interface ATM3/0.33
pvc 1/33
  service-policy output voip

Any help would be greatly appreciated!

Thanks

James

1 Accepted Solution

Accepted Solutions

rstanisl
Cisco Employee
Cisco Employee

HI James,

Your config looks good, but you might need to tweak it a bit.

You will need to specify traffic shaping value for both the pvcs.

I see you only have appled it on one pvc1/33

pvc 1/32 you do not have vbr-nrt value you will need to add that so the the pvc will know how much bandwidth you have for the pvc when you apply the service policy to the interface.

Once you add this you will be able to apply the service policy to each subinterface and that shoudl work.

show policy-map int atm 3/0.32  will show you if packets are correctly getting matched.

hope this helps.

Raymond

View solution in original post

1 Reply 1

rstanisl
Cisco Employee
Cisco Employee

HI James,

Your config looks good, but you might need to tweak it a bit.

You will need to specify traffic shaping value for both the pvcs.

I see you only have appled it on one pvc1/33

pvc 1/32 you do not have vbr-nrt value you will need to add that so the the pvc will know how much bandwidth you have for the pvc when you apply the service policy to the interface.

Once you add this you will be able to apply the service policy to each subinterface and that shoudl work.

show policy-map int atm 3/0.32  will show you if packets are correctly getting matched.

hope this helps.

Raymond

Review Cisco Networking products for a $25 gift card