Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Confusing DHCP issue

I'm having a very curious (to me at least) issue with my c1841 configuration. I originally had it behind a Verizon Fios Actiontec router during configuration and managed to get everything set how I wanted it in a double NAT configuration so I could seemlessly swap out the routers. The Functional Config below is the configuration I was using at the time and it worked (still works) flawlessly. I then removed the Actiontec router from the configuration and hooked-up the c1841 in its place. Still everything worked just peachy. Problem is, I went to switch the 10.0.0.0 network DHCP to 192.168.1.0 and things got screwy. For some reason I cannot get a DHCP address from the router anymore over LAN, over my wireless AP I can still get dhcp and everything works flawlessly. If I manually assign an address to my client I can access the internet perfectly find (using it right now to write this S.O.S.) I simply cannot figure out the difference between these two setups. I've done a line comparison and the only thing I can find different is that the default-router on conf A does not have the subnet mask, but I cannot imagine that would cause any problem since that's part of the DHCP process that never happens. Is there something obvious or not so obvious that I'm missing?

Here's my topology - { FIOS DHCP WAN } - { Cisco 1841 router } - { Cisco 3524 Catalyst Switch } - { Lan Clients }

The catalyst has been 'write erase'd and left for default unconfigured status, not sure if that makes any difference considering it works for the 10.0.0.1 configuration

Functional Config - http://pastebin.com/NWAeDLMP

Same (Just different subnet) Non-Functional Config - http://pastebin.com/mqXZt2D9

Everyone's tags (3)
1 REPLY
New Member

Confusing DHCP issue

Okay, I figured it out. I went throught he configs again and did a one line at a time mirror and fixed the problem. It appears that that 255.255.255.0 in the default-router is not a netmask but actually a second default-router. It seems that this causes all sorts of problems with the dhcp process. I'm still not sure why my linux box was able to pick up DHCP over wireless. I'm assuming that maybe it only uses a single default-gateway and therefore the 255.255.255.0 doesn't come into play. All I know is it's been a long 16 hours and I'm finally rid of this ActionTec router.

430
Views
0
Helpful
1
Replies
CreatePlease to create content