Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Congestion Management

I am hoping to get some advice as to what method of congestion management I should use.

We are a heavy Terminal Server environment. We have 14 or so remote sites connected via 256K frame relay circuits to our host which is a full T1.

We want to give terminal server connections total priority and have everything else take the back seat in terms of bandwidth utilization.

I thought Frame Relay IP RTP Priority would work, but it appears to only apply to UDP traffic.

Priority queueing is looking like the next best option.

Dang, so many options to achive the same thing is making it hard to pick one.

Any thoughts?

Thank you,

Denny

  • WAN Routing and Switching
1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: Congestion Management

Hi Denny,

You can do this in that case:

!

int serial1/0.16

ip address....

frame-relay traffic-shaping

frame-relay interface-dlci 16

class Shaper1

frame-relay interface-dlci 17

class Shaper2

!

map-class frame-relay Shaper1

frame-relay cir xx

frame-relay mincir xx

service-policy output LLQPolicy1

!

map-class frame-relay Shaper2

frame-relay cir xx

frame-relay mincir xx

service-policy output LLQPolicy2

As you can see, you can apply a different map-class to each PVC, which will determine the service that particular PVC gets. So you can configure different shaping rates per PVC.

Hope that helps - pls rate the post if it does.

Regards,

Paresh

4 REPLIES
Purple

Re: Congestion Management

Hi Danny,

Use low latency queueing (LLQ):

class-map TermServerTraffic

match access-group 101

!

policy-map LLQPolicy

class TermServerTraffic

priority 128

class class-default

fair-queue

!

int serial1/0.16

ip address....

frame-relay class Shaper1

!

map-class frame-relay Shaper1

frame-relay cir xx

frame-relay mincir xx

service-policy output LLQPolicy

!

access-list 101 permit tcp/udp .....

Apply such a policy at both ends. This policy will give priority to term server traffic up to 128k (you can of course change this figure to suit you)...

Hope that helps - pls rate posts that help.

Regards,

Paresh

New Member

Re: Congestion Management

Hello,

Thank you for responding. In your example it appears you apply the map-class to a Sub-Interface. In our case, all of our DLCI's are defined under the Serial0/0 interface.

Would this example force all remotes to share 128K or would each PVC get 128K?

Thank you,

Denny

Purple

Re: Congestion Management

Hi Denny,

You can do this in that case:

!

int serial1/0.16

ip address....

frame-relay traffic-shaping

frame-relay interface-dlci 16

class Shaper1

frame-relay interface-dlci 17

class Shaper2

!

map-class frame-relay Shaper1

frame-relay cir xx

frame-relay mincir xx

service-policy output LLQPolicy1

!

map-class frame-relay Shaper2

frame-relay cir xx

frame-relay mincir xx

service-policy output LLQPolicy2

As you can see, you can apply a different map-class to each PVC, which will determine the service that particular PVC gets. So you can configure different shaping rates per PVC.

Hope that helps - pls rate the post if it does.

Regards,

Paresh

New Member

Re: Congestion Management

That is perfect.

Thank you,

Denny

105
Views
0
Helpful
4
Replies