Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Connect Pbx and Data Network Through 2811

Hi,

I'm new in Cisco. I have 2811 router with VWIC-1MFT-E1 and I want to connect 2 different network to it (data & voice).

eg.

Data&Voice----->2811---->E1----->2811---->Data&Voice

my question is :

At first I'm connect the VWIC-1MFT-E1 to Pbx. The system is working fine. But when I'm connect the 10/100 Fast Ethernet ports to Data network, the Pbx start going intermittent. Can you help me how to solve this ? Is my config is wrong ?

tq

13 REPLIES
Hall of Fame Super Gold

Re: Connect Pbx and Data Network Through 2811

Have you set clock source internal for the PBX E1 ?

New Member

Re: Connect Pbx and Data Network Through 2811

According to my Pbx vendor, there's nothing wrong with clock. Because the pbx is working fine. For ref. pls find the attached config.

Hall of Fame Super Gold

Re: Connect Pbx and Data Network Through 2811

Please send text only attachments to make it easier.

New Member

Re: Connect Pbx and Data Network Through 2811

the config :

Current configuration : 3544 bytes

!

version 12.4

service timestamps debug datetim

service timestamps log datetime msec

no service password-encryption

!

hostname ROUTER_BKE-TP

!

boot-start-marker

boot-end-marker

!

enable password pr0p3l

!

no aaa new-model

network-clock-participate wic 2

!

!

ip cef

!

!

no ip domain lookup

isdn switch-type primary-qsig

!

voice-card 0

no dspfarm

!

!

voice call carrier capacity active

!

voice service voip

signaling forward rawmsg

sip

!

!

voice class codec 1

codec preference 2 g711ulaw

!

!

!

!

archive

log config

hidekeys

!

!

controller E1 0/2/0

pri-group timeslot

!

!

!

interface Loopback0

ip address 10.192.1.28 255.255.255.255

!

interface FastEthernet0/0

description Connect to PBX

ip address 172.16.4.2 255.255.255.0

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1

description Connect to CAT3750E BKE

ip address 10.192.33.9 255.255.255.252

duplex auto

speed auto

!

interface Serial0/1/0

description Connect To TM Leased Line

bandwidth 2048

ip address 10.192.33.6 255.255.255.252

ip tcp header-compression i

auto qos voip

service-policy output AutoQoS-Policy-UnTrust

ip rtp header-compression iphc-format

ip rsvp bandwidth 1024 1024

!

!

router eigrp 101

network 10.0.0.0

network 192.0.0.0

network 200.1.2.0

no auto-summary

!

ip forward-protocol nd

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

dial-peer voice 1 voip

description ROUTER_BKE-TP to ROUTER_BRT-RCC

destination-pattern ....

signaling forward rawmsg

session protocol sipv2

session target ipv4:10.192.1.29

req-qos guaranteed-delay

codec g711ulaw

!

dial-peer voice 2015 pots

description ROUTER_BKE-TP to PBX_BKE-TP

destination-pattern ....

direct-inward-dial

port 0/2/0:15

forward-digits all

!

gateway

timer receive-rtp 1200

!

sip-ua

reason-header override

!

!

!

line con 0

password cisco

login

line aux 0

line vty 0 4

password cisco

login

!

exception data-corruption buffer truncate

scheduler allocate 20000 1000

!

end

Hall of Fame Super Gold

Re: Connect Pbx and Data Network Through 2811

Under controller E1 0/2/0 configure:

clock source internal

New Member

Re: Connect Pbx and Data Network Through 2811

I've done the config but still can't. Do I need to config both router ? And is my previous config is correct ?

Hall of Fame Super Gold

Re: Connect Pbx and Data Network Through 2811

Send a corrected network diagram because the one aboe doesn't really make sense.

New Member

Re: Connect Pbx and Data Network Through 2811

PBX---2811---E1 Leased Line---2811---PBX

*both 2811 router connected to CAT3750E for Data Network

ROUTER_BKE-TP#sh ver

Cisco IOS Software, 2800 Software (C2800NM-ENTSERVICESK9-M), Version 12.4(19b),

RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by Cisco Systems, Inc.

Compiled Fri 13-Jun-08 04:12 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

ROUTER_BKE-TP uptime is 11 weeks, 1 day, 2 hours, 16 minutes

System returned to ROM by power-on

System image file is "flash:c2800nm-entservicesk9-mz.124-19b.bin"

Cisco 2811 (revision 53.51) with 249856K/12288K bytes of memory.

Processor board ID FHK1242F1JU

2 FastEthernet interfaces

13 Serial interfaces

1 Serial(sync/async) interface

1 Channelized E1/PRI port

4 Voice FXO interfaces

DRAM configuration is 64 bits wide with parity enabled.

239K bytes of non-volatile configuration memory.

62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

sh run :

!

!

controller E1 0/2/0

pri-group timeslot

clock source internal

!

!

interface Loopback0

ip address 10.192.1.28 255.255.255.255

!

!

interface FastEthernet0/1

description Connect to CAT3750E BKE

ip address 10.192.33.9 255.255.255.252

duplex auto

speed auto

!

interface Serial0/1/0

description Connect To TM Leased Line

bandwidth 2048

ip address 10.192.33.6 255.255.255.252

ip tcp header-compression i

auto qos voip

service-policy output AutoQoS-Policy-UnTrust

ip rtp header-compression iphc-format

ip rsvp bandwidth 1024 1024

!

interface Serial0/2/0:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-qsig

isdn overlap-receiving

isdn incoming-voice voice

isdn send-alerting

isdn bchan-number-order ascending

isdn sending-complete

isdn outgoing display-ie

no cdp enable

!

router eigrp 101

network 10.0.0.0

network 192.0.0.0

network 200.1.2.0

no auto-summary

!

ip forward-protocol nd

!

!

ip http server

no ip http secure-server

!

!

!

!

dial-peer voice 1 voip

description ROUTER_BKE-TP to ROUTER_BRT-RCC

destination-pattern ....

signaling forward rawmsg

session protocol sipv2

session target ipv4:10.192.1.29

req-qos guaranteed-delay

codec g711ulaw

!

dial-peer voice 2015 pots

description ROUTER_BKE-TP to PBX_BKE-TP

destination-pattern ....

direct-inward-dial

port 0/2/0:15

forward-digits all

!

gateway

timer receive-rtp 1200

!

sip-ua

reason-header override

!

!

Hall of Fame Super Gold

Re: Connect Pbx and Data Network Through 2811

You cannot have the same destination-pattern .... for both pots and voip DP. Configure them correctly accordingly to the numbers in use.

You also need to configure incoming called-number for both DPs.

New Member

Re: Connect Pbx and Data Network Through 2811

Configured already but still can't. My config :

dial-peer voice 2 voip

description ROUTER_BKE-TP to ROUTER_BRT-RCC

destination-pattern 16..

dial-peer voice 2015 pots

description ROUTER_BKE-TP to PBX_BKE-TP

destination-pattern 10..

Sorry, but is it because of the pri-group timeslots below ? It should be 32 ts right ?

controller E1 0/2/0

clock source internal

pri-group timeslots 1-12,16

tq

New Member

Re: Connect Pbx and Data Network Through 2811

According to the pbx vendor the destination pattern should be :

destination pattern ....

as the pbx will forward the number to router.

Hall of Fame Super Gold

Re: Connect Pbx and Data Network Through 2811

Let the PBX vendor care about the PBX only,

You need a proper configuation of the routers or nothing will work. I recommend you hire a reputable partner for that.

New Member

Re: Connect Pbx and Data Network Through 2811

But when I try to enter the

command "pri-group timeslots 1-31" under the E1 controller I

get this error:

% Not enough DSP resources available to configure pri-group on controller E1 0/0/0

% The remaining dsp resources are enough for 0 time slots.

% For current codec complexity, 2 extra dsp(s) are required to create this voice port.

Is it true that's why my network is intermittent.

254
Views
0
Helpful
13
Replies
CreatePlease to create content