Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

connected pc unable to get to the internet

Hi All,

I am having issues getting to the internet from the PC. It's currently connected to the cisco 877w via FE0.

The PC is able to grab the correct IP address. Even when I input the dns [8.8.8.8], I am still not able to access the internet.

Attached is the config -

================================

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

!

dot11 syslog

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.254

!

ip dhcp pool HOME-DHCP

   import all

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.254

   dns-server 8.8.8.8

!

!

no ip bootp server

ip name-server 8.8.8.8

ip name-server 165.21.100.88

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

description $ES_WAN$$FW_OUTSIDE$

ip flow ingress

pvc 0/100

  encapsulation aal5snap

  protocol ppp dialer

  dialer pool-member 1

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Dot11Radio0

no ip address

shutdown

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$

ip address 192.168.1.254 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

!

interface Dialer0

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username xxx@xxx password 7 130D44185206173829

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

!

scheduler max-task-time 5000

end

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions

connected pc unable to get to the internet

Can you ping 8.8.8.8 from your router? If so, all you'll need is to configure nat on the router:

access-list 100 permit ip 192.168.1.0 0.0.0.255 any

ip nat inside source list 100 interf dialer0 overload

int vlan 1

ip nat inside

int dial0

ip nat outside

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
5 REPLIES

connected pc unable to get to the internet

Can you ping 8.8.8.8 from your router? If so, all you'll need is to configure nat on the router:

access-list 100 permit ip 192.168.1.0 0.0.0.255 any

ip nat inside source list 100 interf dialer0 overload

int vlan 1

ip nat inside

int dial0

ip nat outside

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

connected pc unable to get to the internet

Thanks so much for the help! All is working fine now. So it's all about the ACLs that is causing the issue. cheers.

One more question - can someone please teach me how to configure the wireless module of this 877w?

connected pc unable to get to the internet

Can you souce a ping from your vlan1 interface to 8.8.8.8?

For Example: ping 8.8.8.8 source 192.168.1.254

Also can you post the results of a traceroute to 8.8.8.8 from this PC?

And my last question, is your Internet Service currently up?

New Member

connected pc unable to get to the internet

@John - thanks but I got it all sorted out.

cheers

If you can assist with the wireless, it would be very much appreciated!

connected pc unable to get to the internet

Can you start a new post about your wireless issue?

Thanks!
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
149
Views
0
Helpful
5
Replies
CreatePlease login to create content