Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Connecting 2100 Cable Modem, 3550, and E2000

I current have a Cisco 2100 Cable modem (192.168.100.1) connected to a Cisco Linksys E2000 (192.168.0.1) that is connected to a Cisco 3550 (192.168.0.10). I would like to relocate the E2000 to another room.  This would require me to connect the 2100 and the E2000 through the 3550. I have had to set a MAC address clone on the E2000 of the PC that is also connected to the 3550.

The question I have is how do I get this all to interconnect so that the E2000 is used by the 2100 for validation to the internet provider (Time/Warner).  I am also using the E2000 for DHCP.

Here is a copy of the running config:

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname A-1

!

!

clock timezone CST -6

clock summer-time CDT recurring

ip subnet-zero

ip routing

!

vtp mode transparent

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

!

interface GigabitEthernet0/1

description Office Hub

switchport mode dynamic desirable

spanning-tree portfast

!

interface GigabitEthernet0/2

description Wireless Router

switchport mode dynamic desirable

spanning-tree portfast

!

interface GigabitEthernet0/3

description Office PC

switchport mode dynamic desirable

spanning-tree portfast

!

interface GigabitEthernet0/4

description Rec Room Xbox

switchport mode dynamic desirable

spanning-tree portfast

!

interface GigabitEthernet0/5

switchport mode dynamic desirable

spanning-tree portfast

!

interface GigabitEthernet0/6

description Wii - Family Room

switchport mode dynamic desirable

spanning-tree portfast

!

interface GigabitEthernet0/7

switchport mode dynamic desirable

spanning-tree portfast

!

interface GigabitEthernet0/8

switchport mode dynamic desirable

spanning-tree portfast

!

interface GigabitEthernet0/9

switchport mode dynamic desirable

spanning-tree portfast

!

interface GigabitEthernet0/10

switchport mode dynamic desirable

spanning-tree portfast

!

interface GigabitEthernet0/11

switchport mode dynamic desirable

spanning-tree portfast

!

interface GigabitEthernet0/12

switchport mode dynamic desirable

spanning-tree portfast

!

interface Vlan1

ip address 192.168.0.10 255.255.255.0

!

ip default-gateway 192.168.0.1

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.0.1

ip http server

!

!

line con 0

login local

line vty 0 3

login local

line vty 4

login

line vty 5 15

login

!

!

!

1 REPLY
Cisco Employee

Connecting 2100 Cable Modem, 3550, and E2000

Hi Mark

Hi Mark

As Far as I know, generally the Cable provider is not interested in your MAC, what they limit is the number

of CPE (your PC)

If in the past your PC was connected and assuming you have a limit of one CPE, you probably had to clone

the mac of your PC, however if the CM is reloaded you should be able to use a new one (mac address)

The Mac @ is learned through DHCP process or through the arp process, if you make sure the E200 is the only

one doing this towards the CMTS, the CMTS should only be aware of one MAC (after your cable modem is reloaded)

I suppose you are using the 3550 for your internal network, as you said you need to connect through the 3550

I suppose you have some physical limitation (cable ...)

I guess your best option is to keep the L2 between the linksys and CMTS, through the 2100

topology :

CMTS-----cable / l2 environment-----CM(2100)---vlan10---3550---vlan10---internet=Linksys---PC

                                                                                 |                                                  |

                                                                                |___vlan20___________________|

If there is a requirement to connect other devices on the 3550, make sure they do not have access as L2 device in the

vlan10 as :

1- it could potentially be learned by the CMTS , hence the linksys would have no more opportunity to become the CPE

2- Maybe better to use your devices on the back of the FW of the E2000

I would propose to put all those devices in a vlan20 which would be connecting one of the port Rj45

of the Linksys so all you internal devices are on the back of the Linksys, and not of those interfere in the

L2 environment of the cable provider

Alain

3532
Views
0
Helpful
1
Replies