Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Connecting 2600 to home network

I've got a 2600 that I am wanting to connect to my cable modem. However I don't have the knowledge to get it running. My ISP uses a dynamic IP and I am unable to get it to connect.

ROUTER#show run

Building configuration...

Current configuration : 685 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname ROUTER

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$O5Kp$atJxl2wqOU1tbefL2Yu530

enable password lt1t56

!

no aaa new-model

ip subnet-zero

no ip routing

no ip cef

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet1/0

ip address 10.0.0.1 255.0.0.0

ip nat inside

no ip route-cache

speed auto

half-duplex

!

no ip http server

ip classless

!

!

snmp-server community public RO

!

line con 0

line aux 0

line vty 0 4

password panthers1

login

!

!

end

ROUTER#

Any ideas?

~Nathan

7 REPLIES
Gold

Connecting 2600 to home network

Hi Nathan,

would you care to explain your goal in more detail? you want to connect your 2600 to internet, then you have stations connected to you 2600 and what u want to do next? a little more detail would be nice.

plz Rate if it helped,

Soroush.

Hope it Helps!

Soroush.
New Member

Connecting 2600 to home network

I started a home business and am upgrading to 50megs down, I have a 2600,pix515e, and a 2900, and plan to use them. Currently I would like to connect  my 2600 to the internet.

Gold

Connecting 2600 to home network

I assume everything is fine with ISP connection and its modem, turn on your modem. connect your router interface fa0/0 to your modem ethernet port 1.

since you already have dhcp client enabled on your fa0/0 it should receive an address from the modem, and you should be able to successfully issue ping www.cisco.com

result?

plz Rate if it helped,

Soroush.

Hope it Helps!

Soroush.
New Member

Connecting 2600 to home network

my network would go like this atm:

PC--->2600---->modem----->ISP

Once I can verify that I have a connection from my 2600 I will add the PIX515E and work from there.

~Nathan

New Member

Re: Connecting 2600 to home network

hi i have just set up my home lab to virgin modem/superhub.and your setup is  similar to mine from my 2621 to modem to isp.from your show run u have no nat set up,u got the inside outside but no access-list,i just set mine to translate to the interface and the ip changed but it all still wkd and also check ur pcs have dns set up,(thanks to the guys on here who helped me with that)hope this helps

chris

New Member

Re: Connecting 2600 to home network

here my show run from my 2621

!

version 12.4

no service timestamps debug uptime

no service timestamps log uptime

service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

enable secret 5 ****************

!

no aaa new-model

!

resource policy

!

ip cef

!

!

!

!

!

!

!

!

interface Loopback0

no ip address

shutdown

!

interface FastEthernet0/0

description LINK TO SW1

ip address 192.168.1.1 255.255.255.0

ip nat inside

speed 100

full-duplex

!

interface Serial0/0

no ip address

shutdown

no dce-terminal-timing-enable

!

interface FastEthernet0/1

description outside

ip address dhcp

ip nat outside

duplex auto

speed auto

no cdp enable

!

interface Serial0/1

no ip address

shutdown

no dce-terminal-timing-enable

!

interface Serial0/2

no ip address

shutdown

no dce-terminal-timing-enable

!

router eigrp 10

redistribute static

network ***********

network ***********

no auto-summary

!

!

ip http server

ip nat inside source list NAT_ADDRESSES interface FastEthernet0/1 overload

!

ip access-list standard NAT_ADDRESSES

permit inside network wilcard mask

!

!

control-plane

!

banner motd ^CC

************************************************

AUTHORISED ACCESS ONLY!!!!!!!!!!!!!!!!!!!!!!!!!!

************************************************^C

alias exec c copy run start

alias exec siib show ip int brief

!

line con 0

exec-timeout 0 0

password 7 *********

logging synchronous

login

line aux 0

line vty 0 4

access-class 1 in

exec-timeout 0 0

password 7 ***********

logging synchronous

login

!

!

end

where inside network and wilcard mask would be your 10.0.0.0 and 0.255.255.255 your mask and u may not need the overload untill u add more devices to ur network

hope this helps

chris

Purple

Connecting 2600 to home network

Hi,

you should also put a static default route pointing towards your modem and reenable CEF and ip routing:

-for the static route: ip route 0.0.0.0 0.0.0.0 x.x.x.x     where x.x.x.x is the modem IP address

-ip routing

-ip cef

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
546
Views
0
Helpful
7
Replies
CreatePlease to create content