Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Connecting to Cisco routers together

I'm trying to connect to routers together. Here is my configs. Please help..

interface GigabitEthernet0/0

ip address 192.168.192.57 255.255.255.0

duplex auto

speed auto

media-type rj45

no mop enabled

!

interface GigabitEthernet0/1

ip address 192.168.104.1 255.255.255.0

duplex auto

speed auto

media-type rj45

no mop enabled

!

interface FastEthernet1/0

ip address 192.168.96.1 255.255.252.0

duplex full

speed 100

no mop enabled

!

interface FastEthernet1/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet2/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet2/1

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.168.192.24

ip route 192.168.104.0 255.255.255.0 192.168.104.2

no ip http server

no ip http secure-server

!

!

!

ip access-list standard delete

interface FastEthernet0/0

ip address 192.168.103.3 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex full

speed 100

no mop enabled

!

interface FastEthernet0/1

ip address 192.168.104.2 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex full

speed 100

no mop enabled

!

router rip

version 2

network 192.168.104.0

!

ip forward-protocol nd

ip route 192.168.104.0 255.255.255.0 192.168.104.1

ip route 192.168.148.0 255.255.252.0 192.168.103.10

ip route 192.168.192.0 255.255.255.0 192.168.103.10

23 REPLIES
Cisco Employee

Re: Connecting to Cisco routers together

Mark,

You must provide more details. You have just pasted excerpts of two configuration files (not even properly separating them) and you have given us absolutely no clue as to what is the problem you are trying to solve, what have you already tried, what are the relevant command outputs and so on. We can't even try to help you further if you do not provide more specific information.

Best regards,

Peter

Gold

Re: Connecting to Cisco routers together

gig0/1 of the top config to fas0/1 of the bottom config? is that the connection between the two that isn't working?

i'm guessing the TWO 'ip nat inside' statements on the bottom config aren't helping.

Community Member

Re: Connecting to Cisco routers together

Sorry about that. This is my first time posting something like this.

I have a swtich that is configured with a ip of 192.168.103.7 and I have plug a network cable into the switch and the other end into GE0/1 with a ip address of 192.168.104.1. interface GigabitEthernet0/0

ip address 192.168.192.57 255.255.255.0

interface FastEthernet1/0

ip address 192.168.96.1 255.255.252.0. The 103 switch is our QMOE switch. At the other end I have another router that I configured with a address of 192.168.104.2. From router to router I can ping the 104 network. My test workstation is on the 192.168.192.0 network and I can't ping the 104 network. Sorry so long

Community Member

Re: Connecting to Cisco routers together

Hi Peter, Sorry about that. This is my first time posting something like this.

I have a swtich that is configured with a ip of 192.168.103.7 and I have plug a network cable into the switch and the other end into GE0/1 with a ip address of 192.168.104.1. interface GigabitEthernet0/0

ip address 192.168.192.57 255.255.255.0

interface FastEthernet1/0

ip address 192.168.96.1 255.255.252.0. The 103 switch is our QMOE switch. At the other end I have another router that I configured with a address of 192.168.104.2. From router to router I can ping the 104 network. My test workstation is on the 192.168.192.0 network and I can't ping the 104 network. Sorry so long

Community Member

Re: Connecting to Cisco routers together

Hi Pete, Do you need anyother information from me?

Cisco Employee

Re: Connecting to Cisco routers together

Mark,

I see a number of problems in the configuration of both your routers. I will call them in the order of their configs as "R1" (first router) and "R2" (second router).

1.) The R1 does not seem to run any routing protocol and it is missing the route to the 192.168.103.0/24 network which is located at R2. The route to the network 192.168.103.0/24 shall be added on R1 statically or a routing protocol shall be used. If you decide to configure it statically, use this command on R1:

ip route 192.168.103.0 255.255.255.0 192.168.104.2

2.) The R2 contains a static route back to the network 192.168.192.0/24 but it seems to point towards an incorrect next hop. Correctly, the static route on R2 towards 192.168.192.0/24 should be configured as follows:

ip route 192.168.192.0 255.255.255.0 192.168.104.1

3.) The configuration of both R1 and R2 contains a static route to the network 192.168.104.0/24. This configuration shall be removed from both routers. The network 192.168.104.0/24 is a directly connected network and configuring it statically does not make any sense.

4.) The R2 runs the RIPv2 routing protocol. However, it seems to be largely useless because the R1 does not run RIPv2 and also, the network 192.168.103.0/24 is missing from the RIPv2 configuration on R2. Correctly, the configuration of RIPv2 on R2 should be as follows:

router rip

version 2

no auto-summary

network 192.168.104.0

network 192.168.103.0

! other networks that we want R1 to know about

The R1 should be configured at least as follows:

router rip

version 2

no auto-summary

network 192.168.104.0

If you decide to run RIPv2 on both routers, remove the static routes from both routers as they will take precedence over RIPv2-discovered routes.

I suggest correcting these errors before moving on.

Best regards,

Peter

Community Member

Re: Connecting to Cisco routers together

Hi Peter, Thanks I will give this a try and let you know. Thanks

Community Member

Re: Connecting to Cisco routers together

Hi Pete, I did step 3 and 4 and on 4 I removed the router rip stuff on R2. I put in the ip route 192.168.103.0 255.255.255.0 192.168.104.2 on R1 and didn't put the ip route 192.168.192.0 255.255.255.0 192.168.104.1 on R2 and I still could n't ping the 104 network from the 103 network. Please help

Cisco Employee

Re: Connecting to Cisco routers together

Mark,

Can you do the show ip route on both routers and post the output here?

Also, a complete configuration in the present version would be helpful. You may post it here as attachments.

Best regards,

Peter

Community Member

Re: Connecting to Cisco routers together

Here are both configs on both routers. Thanks

Cisco Employee

Re: Connecting to Cisco routers together

Mark,

First, remove the ip nat inside commands from the interfaces Fa0/0 and Fa0/1 on the 2800 router.

Second, on your 3800 router, you are missing route to the network 192.168.103.0/24. That means that while your packets from the network 192.168.103.0/24 can reach the 3800 router when you ping 192.168.104.1, it does not know where to send replies. According to its routing table, it sends the replies using its default route out via 192.168.192.24 which is obviously incorrect. Therefore, add this command to the configuration on the 3800 router:

ip route 192.168.103.0 255.255.255.0 192.168.104.2

Let me know if it started working.

Best regards,

Peter

Community Member

Re: Connecting to Cisco routers together

Hi Peter, I will try this in about 15 min and let you know.

Community Member

Re: Connecting to Cisco routers together

Hi Peter, Still a no go. Here what it is when I do the ip route. We do have one Sonicwall on we side. Could there be a route in there that messing this up? I also did remove the nat stuff on the 2800. Thanks

Cisco Employee

Re: Connecting to Cisco routers together

Mark,

At least the routing table looks correctly now.

Okay, let's try this one. On the 2800 router, try using these two commands:

ping 192.168.104.1

ping 192.168.104.1 source fa0/0

The first command should succeed. The second command will send pings using the source address from the interface fa0/0, that is, 192.168.103.3. I am very interested in knowing if the second command also worked.

Best regards,

Peter

Community Member

Re: Connecting to Cisco routers together

Hi Pete, Thanks we are making head way. Here are the results. I even was able to give my test pc a 103 ip with the gw as 192.168.10.3 and I'm able to ping 104.1 and 104.2. Okay now that we have that work I now have a 192.168.148.0 and a 192.168.192.0 network that I need to be able to ping the 104 network. Can you please help me with that.

ALPS-VW-CISCO2800#ping 192.168.104.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.104.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms

ALPS-VW-CISCO2800#ping 192.168.104.1 sou

ALPS-VW-CISCO2800#ping 192.168.104.1 source fa0/0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.104.1, timeout is 2 seconds:

Packet sent with a source address of 192.168.103.3

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Cisco Employee

Re: Connecting to Cisco routers together

Mark,

Finally having some success, isn't it? :)

Regarding the 192.168.192.0/24 network, there are some discrepances. It is directly connected on your 3800 router. However, the static routing entry on your 2800 router for this network points towards a completely incorrect next-hop IP address. Therefore, enter these two commands on your 2800 router in the global configuration mode:

no ip route 192.168.192.0 255.255.255.0 192.168.103.10

ip route 192.168.192.0 255.255.255.0 192.168.104.1

I assume that the PCs in the network 192.168.192.0/24 can ping the 192.168.104.1 but can't ping the 192.168.104.2. This problem should be corrected by the two commands shown above.

Regarding the network 192.168.148.0/24, I do not know where it is connected. You have a static routing entry on the 2800 router for this network but I can not confirm if it is correct or not. The 3800 router does not have any information about that network. Without further info, I am not able to guide you further.

Best regards,

Peter

Community Member

Re: Connecting to Cisco routers together

Hi Peter, I have confirmed I have set my test pc up using a 192.168.192.84 and a gw of 192.168.192.57 and yes I can ping the 104.1 but not the 104.2. I will make the ip route change on R2 na d lookm into the 148 network and let you know. Thanks so much for helpping me and sticking with me on this.

Community Member

Re: Connecting to Cisco routers together

Hi pete, I have made the route change and now I can ping 104.2. Thanks

Community Member

Re: Connecting to Cisco routers together

Sorry I meant to say Peter. Thanks

Community Member

Re: Connecting to Cisco routers together

Hi Peter, I have been looking for the 192.168.148.0 network. I see its coming from our SonicWall with a ip of 192.168.148.1 and then going into a switch. Please correct me if I'm wrong but I thing what I need to do is take a network cable and go from the switch to fe1/1 on R1 na then change the route on R2. Thanks

Cisco Employee

Re: Connecting to Cisco routers together

Hello Mark,

I am not completely sure if you are suggesting a topology change - making changes in your network physical cabling. That's not our task here. Right now, we should try to make the network run as is.

I am missing the topology of your network. I have been able to guess some part of it by looking at the configurations of your two routers but for the remaining part, I have too little information. That SonicWall is a completely new information to me and even if I know that it exists, again I do not know where it is located, whether it works as a bridging or routing firewall, where exactly it is connected and so on. Is it perhaps possible to make a detailed graphical depiction of your existing network topology, say, in Visio or XFig/Dia? That would help me further.

Mark, allow me a personal question - how long are you with IP networks and how do you personally assess your skills in IP networking? This will help me understand your situation better.

Best regards,

Peter

Hall of Fame Super Gold

Re: Connecting to Cisco routers together

"ip route 192.168.104.0 255.255.255.0 192.168.104.1"

You should try to put your next hop and not your local interface IP address.

Community Member

Re: Connecting to Cisco routers together

Are you talking about the router that has a ip of 192.168.104.1 or the router that has the ip of 192.168.104.2

1487
Views
5
Helpful
23
Replies
CreatePlease to create content