Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Connection between 2811 and ISP

Hi

The ISP give me a range of public IP space

Network: 46.28.13.240 /28

Gateway: 46.28.13.254

Useable: 46.28.13.241-.253

Mask: 255.255.255.240

The ISP interface is RJ45 Ethernet.

On my side is a Cisco 2811 router with only 2 Ethernet interfaces and advance-security  software.

I try to make a switch port on the router but that is not porssible.

How do you make a connection between the ISP and the router ?

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Connection between 2811 and ISP

Hi,

As the information provided to you by your ISP is this:

Network: 46.28.13.240 /28

Gateway: 46.28.13.254

Useable: 46.28.13.241-.253

Mask: 255.255.255.240

Here you can use any one of the ip addresses from the Useable Range and assign the same to the WAN Interface that is pointing towards the ISP Side.

So, for example if you are using Fastethernet 0/0 as the WAN Interface, then hook it as following:

Router(config)#int FastEthernet0/0

Router(config-if)#ip address 46.28.13.241 255.255.255.240

Router(config-if)#ip nat outside

Router(config-if)#no shut

Make sure, you add in the default route to the next hop that is the Gateway in this case:

Here is the command to do the same:

Router(config)#ip route 0.0.0.0 0.0.0.0 46.28.13.254

Assign, the LAN configurations on the other side of the FastEtherenet port which is your LAN side:

So , assuming that you have FastEthernet0/1 which is the LAN interface, try the following config:

Router(config)#int FastEthernet0/1

Router(config-if)#ip address x.x.x.x y.y.y.y ( Private Ip address )

Router(config-if)#ip nat inside

Then you have to make sure that we are overloading the NAT on the WAN Interface:


Thus, we would have to globally call the NAT statement using this command:

Router(config)#ip nat inside source list 1 interface FastEthernet0/0 overload

Here, access-list 1 would specify the interesting traffic originating from the LAN.

Here is a related document on NAT:

Configuring NAT for IP Address Conservation
http://www.cisco.com/en/US/docs/ios/12_4t/ip_addr/configuration/guide/htaddrs.html

Also, the rest of the usable Ip address can be used for dedicated machines like Servers which can use one to one static mapping.

Hope that helps!

Thanks,

Rishika

3 REPLIES

Re: Connection between 2811 and ISP

Hi,

You can configure your setup one port for LAN and one port for ISP end and configure NATTING in router for internet routing for internal users.

Just configure a normal port by entering into the interface and configure ip address and no shut .

Hope that helps

Regards

Ganesh.H

Cisco Employee

Re: Connection between 2811 and ISP

Hi,

As the information provided to you by your ISP is this:

Network: 46.28.13.240 /28

Gateway: 46.28.13.254

Useable: 46.28.13.241-.253

Mask: 255.255.255.240

Here you can use any one of the ip addresses from the Useable Range and assign the same to the WAN Interface that is pointing towards the ISP Side.

So, for example if you are using Fastethernet 0/0 as the WAN Interface, then hook it as following:

Router(config)#int FastEthernet0/0

Router(config-if)#ip address 46.28.13.241 255.255.255.240

Router(config-if)#ip nat outside

Router(config-if)#no shut

Make sure, you add in the default route to the next hop that is the Gateway in this case:

Here is the command to do the same:

Router(config)#ip route 0.0.0.0 0.0.0.0 46.28.13.254

Assign, the LAN configurations on the other side of the FastEtherenet port which is your LAN side:

So , assuming that you have FastEthernet0/1 which is the LAN interface, try the following config:

Router(config)#int FastEthernet0/1

Router(config-if)#ip address x.x.x.x y.y.y.y ( Private Ip address )

Router(config-if)#ip nat inside

Then you have to make sure that we are overloading the NAT on the WAN Interface:


Thus, we would have to globally call the NAT statement using this command:

Router(config)#ip nat inside source list 1 interface FastEthernet0/0 overload

Here, access-list 1 would specify the interesting traffic originating from the LAN.

Here is a related document on NAT:

Configuring NAT for IP Address Conservation
http://www.cisco.com/en/US/docs/ios/12_4t/ip_addr/configuration/guide/htaddrs.html

Also, the rest of the usable Ip address can be used for dedicated machines like Servers which can use one to one static mapping.

Hope that helps!

Thanks,

Rishika

New Member

Re: Connection between 2811 and ISP

Yes

This soltuin fixed the problem..

Thankx

482
Views
0
Helpful
3
Replies
CreatePlease to create content