Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Connection to Cisco 876 Router problem

Hi all,

I am experiencing a huge problem with my 876 cisco router.

This router was already configured to work in a small company. Now, I am trying to access it at home using either SDM or Internet Explorer but no luck whatsoever.

When I try to install SDM on both pc and router it gives a window requiring ip address, username and password. I am giving the ip (10.10.10.1 or even 10.0.0.1) plus the username/password (cisco/cisco) but the router cannot be reached.

When I try I.E. or Firefox it gives me a blank web page.

I have tried a typical UTP ethernet cable and even a cross-over ethernet cable but nothing comes up ever.

Tried this on Windows 7 and on Windows Server 2003...

What I see is that when I first power up the router, all lights go on and then only the OK light stays on and the CD is blinking. The Lan port light goes off after 30 or so seconds and the indication "cable unplugged" shows up in Windows...

Heeeeeeelp please!!!!!!

Thank you very much for your time! 

P.S. Already tried the reset buton...

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: Connection to Cisco 876 Router problem

hi,

before accessing it via CCP or SDM you can do the following:

Router> enable

Router# config t

Router(config)# hostname xxx   ---> xxx is the router name

Router(config)# ip domain-name xxx  --->  xxx is the domain name

Router(config)# user xxx privilege 15 secret xxxx   ----> your credentials

Router(config)# enable secret xxxx ---> xxx is the privileged mode password

Router(config)# crypto key generate rsa modulus 1024

Router(config)# ip ssh version 2

Router(config)#  ip http server

Router(config)#  ip http secure-server

Router(config)#  ip http authentication local

Router(config)#  line con 0

Router(config-line)#  login local

Router(config-line)# line vty 0 4

Router(config-line)# login local

Router(config-line)# transport input ssh

Router(config-line)# interface vlan 1

Router(config-intf)# ip address 192.168.1.254 255.255.255.0

Router(config-intf)# no shut

Router(config-intf)# ip dhcp excluded-address 192.168.1.254

Router(config)# ip dhcp pool mypool

Router(dhcp-config)# network 192.168.1.0 255.255.255.0

Router(dhcp-config)# default-router 192.168.1.254

Router(dhcp-config)# dns-server x.x.x.x  x.x.x.x  ---> x.x.x.x are the dns servers from your ISP

Router(dhcp-config)# do wr   -----> to save the config

Then connect your PC on a LAN port and configure it for getting its IP address from DHCP and launch the web GUI(

http://192.168.1.254 or https://192.168.1.254)

enter your credentials when asked.

Regards.

Alain

Don't forget to rate helpful posts.
21 REPLIES
Purple

Connection to Cisco 876 Router problem

Hi,

plug in a console cable and post the output of this command: show run

Regards.

Alain

Don't forget to rate helpful posts.
Silver

Connection to Cisco 876 Router problem

Hi George,

are you able to connect to the router via console?

If CD is blinking it means that the line did not train up, so you don't have WAN connection.

LAN port shouldn't go down, once IOS load is completed. If you reset already the router, your PC should get an address via DHCP, in the range 10.10.10.x, with .1 being the router. If that does not work, try to assign manually an IP like 10.10.10.2.

However, you should be able to see what's going on, once connected via console.

Cheers

Marco

New Member

Connection to Cisco 876 Router problem

Thank you all for your prompt answers!

I don't have with me at this moment the necessary console cable to try it out. I will have it though tomorrow and I will do as you told me to do!

I will let you know what happens tomorrow then.

Thank you very much!

New Member

Connection to Cisco 876 Router problem

I connected the console cable to to the router and I have no idea what to do now.......

Windows XP did not react at all once the router was connected via the console.........

What should I do now?

Purple

Connection to Cisco 876 Router problem

Hi,

you need to use a terminal emulator like Putty( http://the.earth.li/~sgtatham/putty/latest/x86/putty.exe ) and connect to Serial Port COM.

do the  following: right-click on My Computer icon and select properties then select hardware tab then  device manager tab  then expand Ports( COM and LPT)  and  you'll see which port COM to use.

You'll be then in exec mode with > prompt and you'll have to type the keyword enable to get into privileged mode then type show run to view the running-config then type space bar multiple times until you have the full config displayed then scroll to beginning and left click to select while scrolling down then  paste here by right clicking.

Regards.

Alain.

Don't forget to rate helpful posts.
New Member

Connection to Cisco 876 Router problem

This is what boot up, using putty, showed me: (i didnt press any key to show this stuff)

C870 series (Board ID: 6-148) platform with 131072 Kbytes of main memory

Booting flash:/c870-adventerprisek9-mz.124-6.T9.bin

Self decompressing the image : #################################################                         ################################################## [OK]

              Restricted Rights Legend

Use, duplication, or disclosure by the Government is

subject to restrictions as set forth in subparagraph

(c) of the Commercial Computer Software - Restricted

Rights clause at FAR sec. 52.227-19 and subparagraph

(c) (1) (ii) of the Rights in Technical Data and Computer

Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.

           170 West Tasman Drive

           San Jose, California 95134-1706

Cisco IOS Software, C870 Software (C870-ADVENTERPRISEK9-M), Version 12.4(6)T9, R                         ELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Tue 09-Oct-07 18:56 by khuie

Image text-base: 0x8002008C, data-base: 0x81AFDAC4

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Installed image archive

Cisco 876 (MPC8272) processor (revision 0x300) with 118784K/12288K bytes of memo                         ry.

Processor board ID FHK122027EP

MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10

4 FastEthernet interfaces

1 ISDN Basic Rate interface

1 ATM interface

128K bytes of non-volatile configuration memory.

28672K bytes of processor board System flash (Intel Strataflash)

         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]:

Press RETURN to get started!

*Mar  1 00:00:05.715: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State changed to: Initializ          ed

*Mar  1 00:00:05.783: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State changed to: Enabled

*Mar  1 00:00:07.647: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to up

*Mar  1 00:00:08.647: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0, changed st          ate to up

*Mar  1 00:00:13.623: %PARSER-4-BADCFG: Unexpected end of configuration file.

*Mar  1 00:00:57.823: %LINK-5-CHANGED: Interface BRI0, changed state to administratively down

*Mar  1 00:00:58.823: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0, changed state to do          wn

*Mar  1 00:36:15.103: %LINK-5-CHANGED: Interface ATM0, changed state to administratively down

*Mar  1 00:36:15.395: %SYS-5-RESTART: System restarted --

Cisco IOS Software, C870 Software (C870-ADVENTERPRISEK9-M), Version 12.4(6)T9, RELEASE SOFTWARE           (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Tue 09-Oct-07 18:56 by khuie

*Mar  1 00:36:15.395: %SNMP-5-COLDSTART: SNMP agent on host Router is undergoing a cold start

*Mar  1 00:36:15.475: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is OFF

*Mar  1 00:36:16.279: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to do          wn

*Mar  1 00:36:16.979: %LINK-3-UPDOWN: Interface FastEthernet3, changed state to up

*Mar  1 00:36:16.987: %LINK-3-UPDOWN: Interface FastEthernet2, changed state to up

*Mar  1 00:36:16.991: %LINK-3-UPDOWN: Interface FastEthernet1, changed state to up

*Mar  1 00:36:16.995: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to up

*Mar  1 00:36:17.979: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet3, changed st          ate to down

*Mar  1 00:36:17.987: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2, changed st          ate to down

*Mar  1 00:36:17.991: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1, changed st          ate to down

*Mar  1 00:36:17.995: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0, changed st          ate to down

Purple

Connection to Cisco 876 Router problem

Hi,

your startup config is empty because you didn't save the running  with the wr command or your config-register is not set to 0x2102 and so the running-config is not saved.

Can you provide output of  following: show version

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Connection to Cisco 876 Router problem

Router>show version

Cisco IOS Software, C870 Software (C870-ADVENTERPRISEK9-M), Version 12.4(6)T9, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Tue 09-Oct-07 18:56 by khuie

ROM: System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE

Router uptime is 18 minutes

System returned to ROM by power-on

System image file is "flash:c870-adventerprisek9-mz.124-6.T9.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Cisco 876 (MPC8272) processor (revision 0x300) with 118784K/12288K bytes of memory.

Processor board ID FHK122027EP

MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10

4 FastEthernet interfaces

1 ISDN Basic Rate interface

1 ATM interface

128K bytes of non-volatile configuration memory.

28672K bytes of processor board System flash (Intel Strataflash)

Configuration register is 0x2102

Purple

Connection to Cisco 876 Router problem

hi,

your config-register is good so you probably didn't save your running-config so you must reconfigure the router and don't forget to save this time.

Regards.

Alain.

Don't forget to rate helpful posts.
New Member

Connection to Cisco 876 Router problem

Alain, thank you for your prompt answers.

How do I configure the router since I cannot access it via lan cable/dsm software?

Any guidelines to do so?

How do I save the configuration when all is done?

Purple

Re: Connection to Cisco 876 Router problem

hi,

before accessing it via CCP or SDM you can do the following:

Router> enable

Router# config t

Router(config)# hostname xxx   ---> xxx is the router name

Router(config)# ip domain-name xxx  --->  xxx is the domain name

Router(config)# user xxx privilege 15 secret xxxx   ----> your credentials

Router(config)# enable secret xxxx ---> xxx is the privileged mode password

Router(config)# crypto key generate rsa modulus 1024

Router(config)# ip ssh version 2

Router(config)#  ip http server

Router(config)#  ip http secure-server

Router(config)#  ip http authentication local

Router(config)#  line con 0

Router(config-line)#  login local

Router(config-line)# line vty 0 4

Router(config-line)# login local

Router(config-line)# transport input ssh

Router(config-line)# interface vlan 1

Router(config-intf)# ip address 192.168.1.254 255.255.255.0

Router(config-intf)# no shut

Router(config-intf)# ip dhcp excluded-address 192.168.1.254

Router(config)# ip dhcp pool mypool

Router(dhcp-config)# network 192.168.1.0 255.255.255.0

Router(dhcp-config)# default-router 192.168.1.254

Router(dhcp-config)# dns-server x.x.x.x  x.x.x.x  ---> x.x.x.x are the dns servers from your ISP

Router(dhcp-config)# do wr   -----> to save the config

Then connect your PC on a LAN port and configure it for getting its IP address from DHCP and launch the web GUI(

http://192.168.1.254 or https://192.168.1.254)

enter your credentials when asked.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Connection to Cisco 876 Router problem

OK. Here comes a stupid question:

Where it says xxx or x.x.x.x  x.x.x.x, what should I put? or leave it as it is with the x's?????????

Purple

Connection to Cisco 876 Router problem

Hi,

x is just a placeholder, replace it by the value you wish, for example:

user xxx privilege 15 secret xxx  choose appropriate username and password

I'm going to edit the previous post to add some notes.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Connection to Cisco 876 Router problem

Thank you so much for your help and I'm terribly sorry for the trouble i'm causing....

Waiting for the edited post

Purple

Connection to Cisco 876 Router problem

Hi,

look at previous post it's been edited.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Connection to Cisco 876 Router problem

This came up:

Router(config)#crypto key generate rsa modulus 1024

                                       ^

% Invalid input detected at '^' marker.

Router(config)#crypto key generate rsa modulus 1024

                                       ^

% Invalid input detected at '^' marker.

Purple

Connection to Cisco 876 Router problem

Hi,

have you entered the hostname and domain-name ?

---> sh run | i hostname|domain

Regards.

Alain.

Don't forget to rate helpful posts.
New Member

Re: Connection to Cisco 876 Router problem

At the very beggining but not in the command you just said

In the list above there is no such command

Purple

Re: Connection to Cisco 876 Router problem

Hi,

ok you got a  k9 version supporting crypto and you configured the hostname and domain name so it should let you enter the command, that's weird.But anyway it is not mandatory to use ssh for accessing the router for CCP or SDM, you can do these settings in SDM or CCP after.

So don't care about it and change this lines in the previous config to :

Router(config)# line vty 0 4

Router(config-line)# transport input all

Don't forget that the keywords to enter are the bolded ones, the italic ones are just router prompts.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Connection to Cisco 876 Router problem

It worked!!!!!!!! (by the way I had to write "exit" a couple of times in the above list of commands to be able to save the configuration)

Finally, I have access via SDM or Internet Explorer using the ip address mentioned above!

Thank you all for your time and effort (especially Cadet Alain)!!!!!

P.S. Now, I have to find a guide somewhere to re-configure the router via SDM (I have no idea again whatsoever...)

Purple

Connection to Cisco 876 Router problem

Hi,

http://www.cisco.com/en/US/products/sw/secursw/ps5318/products_configuration_example09186a008073e067.shtml

start from the above link and you should find other useful infos.

Regards.

Alain

Don't forget to rate helpful posts.
1207
Views
55
Helpful
21
Replies
CreatePlease to create content