Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Connectios between subinterfaces Dot1q on Router 2911

 

Hello,

I would like you to help me with the following issue. I need to connect the following in the router 2911:

 gigaEthernet 0/1.20

 encapsulation dot1q 20

 192.168.120.0 255.255.255.0

to:

 gigaEthernet 0/0.90

 encapsulation dot1q 90

 11.0.12.2 255.255.255.252

Also:

gigaEthernet 0/1.21

 encapsulation dot1q 21

 192.168.180.0 255.255.255.0

to:

 gigaEthernet 0/0.91

 encapsulation dot1q 91

 11.0.12.6 255.255.255.252

 

The next hop for 11.0.12.2 is 11.0.12.1 and the next hop for 11.0.12.6 is 11.0.12.5

 

So, I want to connect the Subnetworks 192.168.120. 0 and 192.168.180.0 to remote host 172.18.70.5, but  the subnetwork 192.168.120.0 through 11.0.12.1,  and the subnetwork 192.168.180.0 through 11.0.12.5.

 

I have tried the following:

 

access-list 101 permit ip 192.168.120.0 0.0.0.255 any

access-list 102 permit ip 192.168.180.0 0.0.0.255 any

!

route-map XXXX permit 10

 match ip address 101

 set ip next-hop 11.0.12.1

!

route-map YYYY permit 20

 match ip address 102

 set ip next-hop 11.0.12.5

!

interface GigabitEthernet0/1.20

 encapsulation dot1Q 20

 ip address 192.168.120.1 255.255.255.0

 ip policy route-map XXXX

!

interface GigabitEthernet0/1.21

 encapsulation dot1Q 21

 ip address 192.168.180.1 255.255.255.0

 ip policy route-map YYYY

!

!

ip route 11.0.12.0 255.255.255.252 GigabitEthernet0/0.80

ip route 11.0.12.4 255.255.255.252 GigabitEthernet0/0.81

ip route 192.168.120.0 255.255.255.0 GigabitEthernet0/1.20

ip route 192.168.180.0 255.255.255.0 GigabitEthernet0/1.21

!

But it is not routing. So I added the ip route to the network 172.18.70.0 with a next hop and it routes, but I want it to be separated by subred:

Please could you give me some advice to solve this?

I have also thought to use "tag" in route-map in this way:

route-map XXXX permit 10

 match ip address 101

 set tag 20

!

route-map YYYY permit 20

 match ip address 102

 set tag 30

!

 ip route 172.18.70.0 255.255.255.0 11.0.15.1 tag 20 ( so that it be used only for subnetwork 192.168.120.0)

 ip route 172.18.70.0 255.255.255.0 11.0.15.5 tag 30 ( so that it be used only for subnetwork 192.168.180.0)

 

What do you think, could this works?

Thanks for your help in advance.

 

Sandro

Everyone's tags (1)
3 REPLIES
Silver

Hello zsmr00001, What do you

Hello zsmr00001,

 

What do you see in a debug ip packet when trying to route?

New Member

Hello davrojas,I have not

Hello davrojas,

I have not used debug yet. But, what do you think? What should I use in route map: set ip next hop or tag.

If  I use "set ip next hop", ip route 172.18.70.0 ..... it is not necessary, isn't it?

If I use "tag" in route map and I add it to "ip route 172.18.70.0 ..", so should it work?

 

Thanks for your answers,

New Member

This discussion has been

This discussion has been reposted from Top Contributors to the WAN, Routing and Switching community.

86
Views
0
Helpful
3
Replies