Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

converting from router to windows DHCP server

We have 2 distinct vlans in our office.

Vlan154 is currently on dhcp via a router

vlan 153 is handled by a windows box.

We are now moving dhcp for vlan 154 to a windows box.

My question...do i need to do anything

besides remove the dhcp group and put in

a helper address?

here is our config

ip dhcp pool blt-pool

network 192.168.154.0 255.255.254.0

default-router 192.168.154.1

netbios-node-type h-node

dns-server 192.168.153.5 192.168.9.5

netbios-name-server 192.168.153.7 192.168.153.5

lease 0 7

interface GigabitEthernet0/0.153

encapsulation dot1Q 153

ip address 192.168.153.252 255.255.255.0

no snmp trap link-status

standby 1 ip 192.168.153.1

standby 1 track Serial1/0

!

interface GigabitEthernet0/0.154

encapsulation dot1Q 154

ip address 192.168.155.252 255.255.254.0

no snmp trap link-status

standby 2 ip 192.168.154.1

standby 2 track Serial1/0

is it simply a matter of adding a helper address under the subinterface and removing the dhcp pool config?

I notice we do not a helper address configured for the 153 dhcp network, even

though a windows box is handling the task

also how will the dhcp server know if it should hand out addresses to the .153 network

or .154 network to a specific host

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: converting from router to windows DHCP server

Richard

When the router forwards the packet on to the DHCP server it uses the interface IP address on which the request was received and includes this in the request to the DHCP server. It's actually the giaddr (gateway address) field that is filled in.

So if a request came in on the 192.168.153.x network the router would forward the request on as a unicast packet to the DHCP server and would put it's 192.168.153.x interface address into the giaddr field.

So the DHCP then reads the giaddr field and can then determine which scope to use when offering an IP address.

Jon

4 REPLIES
Hall of Fame Super Blue

Re: converting from router to windows DHCP server

Richard

"is it simply a matter of adding a helper address and removing the dhcp pool config?"

Yes altho obviously you need to timeout the leases handed from the router.

" notice we do not a helper address configured for the 153 dhcp network, even

though a windows box is handling the task"

This is probably because the DHCP server is on vlan 153 ?. An ip helper-address is only need when the DHCP server is on a different vlan.

"also how will the dhcp know what network/vlan to give out to specific ports"

The router will do all that for you. The packet that gets to the DHCP server will have the information of the router subnet.

Jon

Community Member

Re: converting from router to windows DHCP server

thx jon.

another question..

the new dhcp server is given an address

for ex

192.168.154.10 and this would handle all

dhcp requests from the both vlans and

thus give out 2 diff networks.

is the decision on what ip/subnet to

assign a given host based upon the trunk

information on the router /gateway interface?

Hall of Fame Super Blue

Re: converting from router to windows DHCP server

Richard

When the router forwards the packet on to the DHCP server it uses the interface IP address on which the request was received and includes this in the request to the DHCP server. It's actually the giaddr (gateway address) field that is filled in.

So if a request came in on the 192.168.153.x network the router would forward the request on as a unicast packet to the DHCP server and would put it's 192.168.153.x interface address into the giaddr field.

So the DHCP then reads the giaddr field and can then determine which scope to use when offering an IP address.

Jon

Community Member

Re: converting from router to windows DHCP server

thx!

310
Views
0
Helpful
4
Replies
CreatePlease to create content