Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Copy running-config startup-config doesn't work - Cisco 1811

Hi,

For some reason, I cannot copy the running-config to the startup-config on a Cisco 1811. Every time I boot the router, it asks me if I want to start the initial configuration and loses all the previously saved settings.

I manage to config the router and connect to it with SDM however once I copy the running-config to statup-conig and reboot the server, the router loses all settings.

Does this issue indicate a router fault? Is there a way to debug/fix this problem?

Regards,

Joe

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Copy running-config startup-config doesn't work - Cisco 1811

Hi Joe,

It sounds like the configuration register is not correctly set.

Do a 'show version' and verify that the configuration register is set as 0x2102 (it is probably set as 0x2142 which will ignore NVRAM contents on bootup).

If it is not set to this, enter configuration mode and type 'config-register 0x2102' then do a copy running-config startup-config and reload the router to verify that it is now saving the configuration and using it on bootup.

You can find more information on the configuration register and the different variables at http://www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a008022493f.shtml

Hope this helps,

Nik.

2 REPLIES

Re: Copy running-config startup-config doesn't work - Cisco 1811

Hi Joe,

It sounds like the configuration register is not correctly set.

Do a 'show version' and verify that the configuration register is set as 0x2102 (it is probably set as 0x2142 which will ignore NVRAM contents on bootup).

If it is not set to this, enter configuration mode and type 'config-register 0x2102' then do a copy running-config startup-config and reload the router to verify that it is now saving the configuration and using it on bootup.

You can find more information on the configuration register and the different variables at http://www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a008022493f.shtml

Hope this helps,

Nik.

New Member

Re: Copy running-config startup-config doesn't work - Cisco 1811

Thanks Nik! The problem was with the register...

1899
Views
0
Helpful
2
Replies
CreatePlease to create content