Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Creating three PPPOE Sessions on Cisco 2821

I cant realise more than two simultaneous internet dialin.

I have a cisco 2821 and three dsl lines.

There are three ethernet interfaces and three dialer interfaces configured. Every dialer works fine but I cant connect more than two dialer at a time.

It seems the router have only two possible virtual-access ports.

Has anybody a configuration with more than two active internet dial-in with PPPOE.

9 REPLIES

Re: Creating three PPPOE Sessions on Cisco 2821

Hi there,

The router can support as much virtual-access as its IDBs supports "show idb", which can't be 2, can you please post your configuration as well as "show idb".

best regards,

Mohammed.

Community Member

Re: Creating three PPPOE Sessions on Cisco 2821

Hi Mohammed,

thanks for your reply.

You are right. I try it again today and saw three virtual-access interfaces.

But I dont get a connect on all interfaces at a time.

The config is not ready but i think it is enough to get the connections.

Here is the config:

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

!

card type command needed for slot/vwic-slot 0/0

!

no aaa new-model

!

resource policy

!

clock timezone GMT 0

clock summer-time GMT recurring last Sun Mar 1:00 last Sun Oct 2:00

network-clock-participate wic 2

!

ip cef

no ip dhcp use vrf connected

!

ip dhcp pool VoIP

network 172.21.2.0 255.255.255.0

option 150 ip 10.0.1.80

default-router 172.21.2.1

!

ip dhcp pool User

network 172.21.1.0 255.255.255.0

default-router 172.21.1.1

dns-server 172.21.1.1

!

ip name-server 145.253.2.11

!

voice-card 0

no dspfarm

!

username cisco privilege 15 password 0 cisco

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.1

description *** Management ***

encapsulation dot1Q 1 native

ip address 172.21.0.1 255.255.255.0

!

interface GigabitEthernet0/0.10

description *** User-LAN ***

encapsulation dot1Q 10

ip address 172.21.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface GigabitEthernet0/0.20

description *** VoIP ***

encapsulation dot1Q 20

ip address 172.21.2.1 255.255.255.0

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/3/0

switchport access vlan 201

!

interface FastEthernet0/3/1

switchport access vlan 202

!

interface FastEthernet0/3/2

switchport access vlan 203

!

interface FastEthernet0/3/3

!

interface BRI0/2/0

no ip address

!

interface BRI0/2/1

no ip address

!

interface Vlan1

no ip address

!

interface Vlan201

description internet1-adsl

no ip address

ip nat outside

ip virtual-reassembly

pppoe enable

pppoe-client dial-pool-number 1

!

interface Vlan202

description internet1-adsl

no ip address

ip nat outside

ip virtual-reassembly

pppoe enable

pppoe-client dial-pool-number 2

!

interface Vlan203

description internet1-adsl

no ip address

ip nat outside

ip virtual-reassembly

pppoe enable

pppoe-client dial-pool-number 3

!

interface Dialer1

description Internet-Dialin

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp pap sent-username xxx password xxx

!

interface Dialer2

description Internet-Dialin

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

shutdown

dialer pool 2

dialer-group 1

ppp authentication chap callin

ppp pap sent-username xxx password xxx

!

interface Dialer3

description Internet-Dialin

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 3

dialer-group 1

ppp authentication chap callin

ppp pap sent-username xxx password xxx

!

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2

ip route 0.0.0.0 0.0.0.0 Dialer3

!

!

ip http server

no ip http secure-server

ip dns server

ip nat source route-map 10 interface Dialer3 overload

!

access-list 1 permit 172.21.1.0 0.0.0.255

access-list 101 permit ip 172.21.1.0 0.0.0.255 any

access-list 102 permit ip 172.21.2.0 0.0.0.255 any

dialer-list 1 protocol ip permit

!

!

!

route-map nonat permit 10

match ip address 101

!

route-map nonat permit 20

match ip address 102

!

!

control-plane

!

!

!

voice-port 0/2/0

!

voice-port 0/2/1

!

!

line con 0

login local

line aux 0

line vty 0 4

login local

transport input telnet

line vty 5 15

login local

transport input telnet

!

scheduler allocate 20000 1000

ntp clock-period 17179935

ntp server 192.53.103.103

regards

Sebastian

Community Member

Re: Creating three PPPOE Sessions on Cisco 2821

Hello,

Did you ever get this config running properly? Do you have an HWIC in this router?

Thanks,

Dan.

Community Member

Re: Creating three PPPOE Sessions on Cisco 2821

Hi,

yes I have an HWIC Module.

It was not possible to realice more than two pppoe session on this module.

But I create a third dialin with one of the the fixed gig ports.

So the router runs with three dialins.

Regards,

Sebastian

Community Member

Re: Creating three PPPOE Sessions on Cisco 2821

I think i have found why you cannot have more than two internet dialin's at one time.

conf t

int virtual-access ?

shows:

<1-2> virtual access interface number

If i'm right every dialer interface is attached to a virtual access interface. Thus only allowing you to have two dialer interfaces at one time.

Would this be a limit of the ios? I really need to be able to run four dialin's at one time.

Thanks,

Dan.

Community Member

Re: Creating three PPPOE Sessions on Cisco 2821

Hi Dan,

The problem with the virtual access interfaces is the same problem I find out.

I think you need HWIC-1FE interfaces instead of a HWIC-4ESW. It seems to be a problem with the interface or the internel module slot limitation.

Like I do you can realice two dialer an the HWIC-4ESW and two on the fixed installed ports at the same time so you have four dialin?s at one time.

I think this will work(my config runs with three dialers).

Regards,

Sebastian

Community Member

Re: Creating three PPPOE Sessions on Cisco 2821

Thats a good idea. Would you mind posting your current config. I'm still having some trouble and I wouldn't mind comparing mine with yours.

Thanks,

Dan.

Community Member

Re: Creating three PPPOE Sessions on Cisco 2821

Hi Dan,

here is my config (part of it):

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.1

description *** Management ***

encapsulation dot1Q 1 native

ip address 172.20.0.1 255.255.255.0

no snmp trap link-status

h323-gateway voip bind srcaddr 172.20.0.1

!

interface GigabitEthernet0/0.10

description *** User-LAN ***

encapsulation dot1Q 10

ip address 172.20.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface GigabitEthernet0/0.20

description *** VoIP ***

encapsulation dot1Q 20

ip address 172.20.2.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface GigabitEthernet0/1

description 3-adsl

no ip address

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 3

!

interface FastEthernet0/3/0

switchport access vlan 201

!

interface FastEthernet0/3/1

switchport access vlan 202

!

interface FastEthernet0/3/2

shutdown

!

interface FastEthernet0/3/3

shutdown

!

interface Vlan1

no ip address

!

interface Vlan201

description 1-adsl

no ip address

ip virtual-reassembly

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface Vlan202

description 2-adsl

no ip address

ip virtual-reassembly

pppoe enable group global

pppoe-client dial-pool-number 2

!

interface Dialer1

description 1-adsl

ip address negotiated

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname xxx

ppp chap password yyy

!

interface Dialer2

description 2-adsl

ip address negotiated

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 2

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname xxx

ppp chap password yyy

!

interface Dialer3

description 3-adsl

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 3

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname xxx

ppp chap password yyy

!

ip route 0.0.0.0 0.0.0.0 Dialer3

!

ip dns server

!

ip nat inside source list 1 interface Dialer3 overload

!

access-list 101 permit ip 172.20.0.0 0.0.0.255 10.0.0.0 0.255.255.255

access-list 101 permit ip 172.20.1.0 0.0.0.255 10.0.0.0 0.255.255.255

access-list 101 permit ip 172.20.2.0 0.0.0.255 10.0.0.0 0.255.255.255

dialer-list 1 protocol ip permit

!

gw_uk01#sh ver

Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(4)XC5, RELEASE SOFTWARE (fc1)

Synched to technology version 12.4(5.13)T

In this sample I use 3 dialins but it must be simmilar to use 4 dialins. The gig int 0/0 is for internal and the dialer 3 is for internet access. the other two dialer are for vpn but not configured now.

Regards,

Sebastian

Community Member

Re: Creating three PPPOE Sessions on Cisco 2821

The access-list 101 is not needed in this sample.

It is preparation for VPN (no nat).

296
Views
0
Helpful
9
Replies
CreatePlease to create content