Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cross VLAN traffic issue

I am having trouble getting my dev environment working properly. I am unable to get my ESXi server to communicate with my Windows Server on a separate VLAN. From the diagram below I want DLESXi2 to route via DEVDLSRV1 (on DLESXi1).

I have tried assigning ip addresses to the vlan's, adding helper addresses, adding a static route to the 192.168.17.0/24, and also added vlan tag 17 to DLESXi2. All did not allow communication from the 17 network to DEVDLSRV1. Maybe I'm making this too complicated, but I would like for my server (DEVDLSRV1) to be the DHCP/DNS server and for all communication to the "Internet" (and also the Public_Network which is my business domain) to go through this server (This last part is not part of this forum).

Switch: Cisco 3550Network Diagram

 

My config file is as such:

no aaa new-model
ip subnet-zero
ip routing
ip name-server 192.168.3.237
ip name-server 192.168.3.238
!
vtp mode transparent
!

spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 3
 name Public_Network
!
vlan 17
 name Private_Network_17
!

interface FastEthernet0/1
 switchport access vlan 3
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 3
 switchport mode access
 duplex full
 spanning-tree portfast
!

interface FastEthernet0/2
 switchport access vlan 3
 switchport mode access
 spanning-tree portfast
!

interface FastEthernet0/3
 switchport access vlan 3
 switchport trunk allowed vlan 3,17
 switchport mode access
 spanning-tree portfast
!

interface FastEthernet0/13
 switchport access vlan 17
 switchport mode access
 spanning-tree portfast
!

interface Vlan1
 no ip address
 shutdown
!
interface Vlan3
 no ip address
!
interface Vlan17
 no ip address
!
ip default-gateway 192.168.3.252
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.3.252
ip http server
!

 

Any help would be extremely appreciated.

Everyone's tags (1)
4 REPLIES
Super Bronze

DisclaimerThe Author of this

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

You don't have IPs on any of your VLAN interfaces.(?)

New Member

I tried that before and the

I tried that before and the most I got was pinging to VLAN 17's ip address, nothing more.

I setup VLAN 3 with IP: 192.168.3.223/24

VLAN 17 with IP: 192.168.17.254/24

and still nothing.

Super Bronze

DisclaimerThe Author of this

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

To route, the router will need interface IPs.

Normally, you hosts will have the router's IP at their gateway.  Do they?

New Member

interface FastEthernet0/3

interface FastEthernet0/3
 switchport access vlan 3
 switchport trunk allowed vlan 3,17
 switchport mode access <<<<<<<< I believe this should be Trunk mode 

And in the trunk allow only 3,17 

Hope you try this and reply with the result 

 

153
Views
0
Helpful
4
Replies