Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

DDNS w freedns.afraid.org

i have spent some time trying to get DDNS to work with freedns.afraid.org.

they do not use the name:pw authentication the others use, they use a SHA key at the end of a string.

http://freedns.afraid.org/dynamic/update.php?U2lnOWswTVRTTUl-and-so-on

you can past this string into a browser and it works perfectly, when the router sends it i get a the html source for the splash screen.

10 REPLIES
Hall of Fame Super Gold

Re: DDNS w freedns.afraid.org

In other words ?

Conclusion ?

Community Member

Re: DDNS w freedns.afraid.org

i guess that was a little ambiguous - it doesn't work. I've been through the iad_ddns doc backwards and forwards.

ip ddns update method not4u

HTTP

add http://freedns.afraid.org/dynamic/update.php?U2lnOWswTVRTTUlBQUhTbmVvRTozNjI5NjQ1

interval maximum 0 0 5 0

interval minimum 0 0 5 0

Response:

001132: .Jun 11 16:07:26: DYNDNSUPD: Adding DNS mapping for not4u.ignorelist.com <=> 172.25.243.165

001133: .Jun 11 16:07:26: HTTPDNS: Update add called for not4u.ignorelist.com <=> 172.25.243.165

001134: .Jun 11 16:07:26: HTTPDNSUPD: Session ID = 0x43

001135: .Jun 11 16:07:26: HTTPDNSUPD: URL = 's0t0pe@freedns.afraid.org/dynamic/update.php?U2lnOWswTVRTTUlBQUhTbmVvRTozNjI5NjQ1')">http://eugeneb:s0t0pe@freedns.afraid.org/dynamic/update.php?U2lnOWswTVRTTUlBQUhTbmVvRTozNjI5NjQ1'

001136: .Jun 11 16:07:26: HTTPDNSUPD: Sending request

001137: .Jun 11 16:07:26: HTTPDNSUPD: Response for update not4u.ignorelist.com <=> 172.25.243.165

001138: .Jun 11 16:07:26: HTTPDNSUPD: DATA START

Welcome



is shared privately, therefore you may freely create however the domain owner has reserved their right to approve or deny your request, and should be considered non-permanent until that point.

You may also browse/attach to thousands of other shared domains listed here in the http://freedns.afraid.org/domain/registry/>Free DNS Domain Registry including those domains which are public and do not require any domain owner approval
.

If you have domains of your own, and are not already using http://freedns.afraid.org/>Fr

001139: .Jun 11 16:07:26: HTTPDNSUPD: Response for update not4u.ignorelist.com <=> 172.25.243.165

001140: .Jun 11 16:07:26: HTTPDNSUPD: DATA START

ee DNS to run their DNS, then you should check out what we can do for you.



Hosting your domains here allows you to still keep your current webhost with much greater control at the DNS level. Try using our powerful instantaneous DNS administration panel, and let it speak for it's self!

If you own this domain, you can instantly configure your domain to route to any IP/URL of your choosing from within the members area at anytime by navigating to the http://freedns.afraid.org/subdomain/>Free DNS Subdomains section. This is the default page for a new domain addition.

DNS is our business... 24/7. http://freedns.afraid.org/>Free DNS benefits

http://freedns.afraid.org/>Free DNS is currently processing 990 DNS requests per second.


001141: .Jun 11 16:07:26: HTTPDNSUPD: Response for update not4u.ignorelist.com <=> 172.25.243.165

001142: .Jun 11 16:07:26: HTTPDNSUPD: DATA START

>

001143: .Jun 11 16:07:26: HTTPDNSUPD: DATA END, Status is Response data recieved, successfully

001144: .Jun 11 16:07:26: HTTPDNSUPD: Call returned SUCCESS, update of not4u.ignorelist.com <=> 172.25.243.165 succeeded

001145: .Jun 11 16:07:26: DYNDNSUPD: Another update completed (outstanding=0, total=0)

001146: .Jun 11 16:07:26: HTTPDNSUPD: Clearing all session 67 info

Hall of Fame Super Gold

Re: DDNS w freedns.afraid.org

If you think it should work, but it doesn't, you should contact the TAC, so they can either suggest a working config, or file a bug as necessary.

Community Member

Re: DDNS w freedns.afraid.org

was trying the community first -

thanx

ecd
Community Member

Re: DDNS w freedns.afraid.org

I experience the same problem, I see the HTTP request to freedns.afraid.org is sent with a HTTP Host header set to the IP address of freedns.afraid.org, this is causing the trouble. The response is easily reproduced using wget:

wget -q -O - --headers "Host: freedns.afraid.org" 'http://freedns.afraid.org/dynamic/update.php?XYZ...'

works correctly, while

wget -q -O - --header "Host: 67.19.72.205" 'http://freedns.afraid.org/dynamic/update.php?XYZ...'

does not work and reproduces the response mentioned above.

Excuse my dump question: Who is the TAC?

Community Member

Re: DDNS w freedns.afraid.org

TAC is the Technical support organization for Cisco, if you don't have a contract it costs you to open a support ticket,

you can find TAC under support from the main page.

Community Member

Re: DDNS w freedns.afraid.org

after trying many variables - i gave up and moved to dyndns.com

this is working well.

Community Member

Re: DDNS w freedns.afraid.org

dear freind

i was trying to configure in cisco 877/K9 but it dont work can post your config Dyndns ?, will be appreciable

Thanks

Taher

Community Member

Re: DDNS w freedns.afraid.org

no problem - here you go, enjoy

!

ip ddns update method not4u

HTTP

add s3cr3tk3y@members.dyndns.org/nic/update?system=dyndns&hostname')">http://eugeneb:s3cr3tk3y@members.dyndns.org/nic/update?system=dyndns&hostname=&myip=

interval maximum 1 0 0 0

interval minimum 0 0 5 0

!

interface FastEthernet0/1

description

ip dhcp client client-id ascii not4me

ip dhcp client hostname not4me

ip ddns update not4me host members.dyndns.org

ip address dhcp

ip access-group Wan-Deny in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nbar protocol-discovery

ip nat outside

no ip virtual-reassembly

duplex auto

speed auto

no cdp enable

crypto map Stealth

!

ip access-list extended Wan-Deny

permit udp any eq bootps any eq bootpc

permit icmp any any

permit tcp any any established

permit ahp any any

permit esp any any

permit icmp any any echo-reply

permit icmp any any time-exceeded

permit icmp any any unreachable

permit udp any eq domain any

permit tcp any any eq 22

permit udp any any eq isakmp

permit udp any any eq non500-isakmp

permit tcp any any eq 4500

permit tcp any any eq 10000

permit udp any any eq ntp

permit tcp any any eq 5223

permit udp any any range 3478 3479

permit udp any any eq 28960

permit tcp any any eq 8000

Community Member

Re: DDNS w freedns.afraid.org

use "ip sla"

see: http://www.blindhog.net/cisco-routers-and-dynamic-dns/

btw: cisco ddns suck!

4071
Views
0
Helpful
10
Replies
CreatePlease to create content