Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

debug isdn ..no output shown

I've seen this problem once before but cant remember how to solve it.

I'm running a 2851 as a h323 gateway connected to an E1. when i run 'debug isdn q931' i'm not seeing the output although i know for a fact calls are going in and coming out. i'm connected via console which monitors so term mon is not needed but i'm sure there is a logging command or something that then makes the output be shown.

just cant remember...can anybody help??

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: debug isdn ..no output shown

Andy

It is possible (but in my experience less likely) for the same issues to impact debug output to telnet sessions. Someone could have changed the severity level or could have disabled logging to the monitor (which is what sends output to telnet sessions). For telnet the command is simmilar (but not quite the same):

logging monitor debug

One way to check things is to issue the show log command. In the first group of lines displayed it should show the various logging destinations and how they are set (console logging, buffer logging, and trap logging). It should show what is enabled and what is disabled and what severity level is set for each.

HTH

Rick

4 REPLIES
Hall of Fame Super Silver

Re: debug isdn ..no output shown

Andy

There are several things that may result in debug output now showing up on the console. It is possible that someone has configured the console output for a level that excludes debug output (which is level 7). Or it is possible that someone has configured the console to not display syslog output.

The solution to both of these is to configure:

logging console debug

HTH

Rick

New Member

Re: debug isdn ..no output shown

thanks rick i'll give that a try. would a similar command work for a telnet session or would that be the same problem?

this was an out of the box router so it seems strange but i really appreciate your help

Hall of Fame Super Silver

Re: debug isdn ..no output shown

Andy

It is possible (but in my experience less likely) for the same issues to impact debug output to telnet sessions. Someone could have changed the severity level or could have disabled logging to the monitor (which is what sends output to telnet sessions). For telnet the command is simmilar (but not quite the same):

logging monitor debug

One way to check things is to issue the show log command. In the first group of lines displayed it should show the various logging destinations and how they are set (console logging, buffer logging, and trap logging). It should show what is enabled and what is disabled and what severity level is set for each.

HTH

Rick

Hall of Fame Super Silver

Re: debug isdn ..no output shown

Andy

I am glad that my response was helpful in resolving your question. Thank you for using the rating system to indicate that your question was resolved (and thanks for the rating). It makes the forum more useful when people can read a question and can know that there was a response that did help resolve the question.

The forum is an excellent place to learn about Cisco networking. I encourage you to continue your participation in the forum.

HTH

Rick

2246
Views
5
Helpful
4
Replies