Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

default config file for 878 router

Hi

Can anyone tell me where I can get a factory default file for a cisco 878 router.Also any info on uploading it to the router vie the console port using Hyper terminal would be appriciated.

Thanks

1 REPLY
Bronze

Re: default config file for 878 router

Both the older Security Device Manager (SDM) and the newer Cisco Configuration Professional (CCP) include default config files which are loaded if you do a factory reset. These programs are free downloads  from cisco.com (you may need to register for the site).

In CCP for the 878 this file is called cpconfig-8xx.cfg and I have included its output below. Note that this file will just get you up and running with very basic LAN connectivity and nothing else. It will not set up the WAN side of things. The SDM version of the file is essentially the same.

Rather than transferring the file it might be quicker/simpler just to enter the relevant commands into the CLI via the console.

The contents of cpconfig-8xx.cfg are:

!  The default startup configuration file for Cisco Configuration Professional (Cisco CP)
!  DO NOT modify this file; it is required by Cisco CP as is for factory defaults
!  Version 1.0
!
hostname yourname
!
logging buffered 51200 warnings
!
username cisco privilege 15 secret 0 cisco
username cisco privilege 15 one-time secret 0 cisco
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool ccp-pool
    import all
    network 10.10.10.0 255.255.255.248
    default-router 10.10.10.1
    lease 0 2

no ip domain lookup
ip domain-name yourdomain.com
          
!
interface FastEthernet0
  no ip address
  no shutdown
!
interface FastEthernet1
  no ip address
  no shutdown
!
interface FastEthernet2
  no ip address
  no shutdown
!
interface FastEthernet3
  no ip address
  no shutdown
!
!
interface Vlan1
  description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
  ip address 10.10.10.1 255.255.255.248
  ip tcp adjust-mss 1452
          
!
ip http server
ip http access-class 23
ip http secure-server
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 23 permit 10.10.10.0 0.0.0.7
!
banner exec ^
% Password expiration warning.
-----------------------------------------------------------------------
 
Cisco Configuration Professional (Cisco CP) is installed on this device
and it provides the default username "cisco" for  one-time use. If you have
already used the username "cisco" to login to the router and your IOS image
supports the "one-time" user option, then this username has already expired.
You will not be able to login to the router with this username after you exit
this session.
 
It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.
          
 
username privilege 15 secret 0
 
Replace and with the username and password you
want to use.
 
-----------------------------------------------------------------------
^
banner login ^
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device.
This feature requires the one-time use of the username "cisco" with the
password "cisco". These default credentials have a privilege level of 15.
 
YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE 
PUBLICLY-KNOWN CREDENTIALS

Here are the Cisco IOS commands.

username   privilege 15 secret 0
no username cisco

         
Replace and with the username and password you want
to use.

IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL
NOT BE ABLE TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.
 
For more information about Cisco CP please follow the instructions in the
QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp
-----------------------------------------------------------------------
^
!
no cdp run
!
!
line con 0
  login local
line vty 0 4
  access-class 23 in
  privilege level 15
  login local
  transport input telnet
  transport input telnet ssh
          
line vty 5 15
  access-class 23 in
  privilege level 15
  login local
  transport input telnet
  transport input telnet ssh
!
!  End of Cisco CP default config file
end

3259
Views
0
Helpful
1
Replies
CreatePlease to create content