Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Default routing

Dear all,

I have 5 routers titled router1, router2, router3, router4 , router5 connected as below:

Router1 ---------Router2 --------- Router3------------Router4--------Router5

No static route created in all routers. But just default route set on each router.

If Router1 can ping Router5 and vice versa, can i set default route on each router to the interface of both sides' router?

Any route loop if the neighboring router set default route to each other?

Many thanks

5 REPLIES
Cisco Employee

Re: Default routing

Hi Eric,

It may create a routing loop in your network. Is there any specific reason you only want default route and not static routes or some basic routing protocol?

Regards,

Ankur

New Member

Re: Default routing

Hi ankbhasi,

I just wonder if just using default route can ping from router1 to router5 and vice versa.

How can i set the default route? Both direction of each router need to set?

Cisco Employee

Re: Default routing

Eric,

Two default routes in the same router will not workout for you. You have to use static routes for each destination subnet you want to reach. The reason behind it is that the router will add both the default routes in its routing table and will try to load balance across these two routes. Which will result in some packets taking the one path while some of the packets taking the other path. Which means there will be a packet loop and some of the packets will never make it to the destination.

In this topology setting the default route on router R1 and R5 is OK bot if you set the default routes on the routers in the middle you will see the behaviour as mentioned above. On these routers you have to use specific static routes for every destination that you want to route.

HTH,Please rate if it does.

-amit singh

Hall of Fame Super Bronze

Re: Default routing

You need to implement network routes instead of default routes. Let's say we have the following networks:

R1 <- 192.168.12.0/24 -> R2

R2 <- 192.168.23.0/24 -> R3

R3 <- 192.168.34.0/24 -> R4

R4 <- 192.168.45.0/24 -> R5

For R1 to reach 192.168.45.0/24 segment, you need the following routes:

R1:

ip route 192.168.45.0 255.255.255.0 R2

R2:

ip route 192.168.45.0 255.255.255.0 R3

R3:

ip route 192.168.45.0 255.255.255.0 R4

ip route 192.168.12.0 255.255.255.0 R2

R4:

ip route 192.168.12.0 255.255.255.0 R3

This is why dynamic routing protocol is useful. If you use RIPv2, all you need on each router:

router rip

version 2

network 192.168.x.0

no auto-summary

With EIGRP

router eigrp 1

network 192.168.0.0 255.255.0.0

no auto-summary

With OSPF

router ospf 1

network 192.168.0.0 0.0.255.255 area 0

HTH,

New Member

Re: Default routing

Hi Eric,

You can consider setup Default route in R1 pointing to R2 & default route in R5 pointing to R4. For the rest of routers, you need to use IGP route like static routes or dynamic routes for communication because each of these routers has 2 x links connnected. Please rate my post if helpful.

Leon

101
Views
5
Helpful
5
Replies