Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Destination based NAT?

Hi

Is it possible to NAT an internal private ip according to its' destination differently in PIX and/or router?

Example

10.0.0.1 ==Internal IP

if destination is A

then NAT to 155.55.55.55

if destionation is B

then NAT to 166.66.66.66

etc.

Thanks in advance

Deniz

2 REPLIES
Bronze

Re: Destination based NAT?

In case you want to NAT the inside address 10.0.0.1 to two different addresses, 155.55.55.55 and 166.66.66.66, depending on wheter it communicates with host A or host B. This is what I would try on a router:

interface Loopback55

ip address 155.55.55.55 255.255.255.255

!

interface Loopback66

ip address 166.66.66.66 255.255.255.255

!

interface Ethernet0

ip nat inside

!

interface Ethernet1

ip nat outside

!

ip nat inside source route-map A interface Loopback55

ip nat inside source route-map B interface Loopback66

!

access-list 155 permit ip host 10.0.0.1

access-list 166 permit ip host 10.0.0.1

!

route-map A permit 10

match ip address 155

!

route-map B permit 10

match ip address 166

I'm not 100% sure if it works, but maybe you could test it.

New Member

Re: Destination based NAT?

Good configuration. I will try it thanks.

253
Views
5
Helpful
2
Replies