Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

DHCP Ques

Router @ Remote site (flash:c2800nm-spservicesk9-mz.123-8.T8.bin") and MS-DHCP server at central site

currently helper address at remote points back to central to pull address

But I want remote router to act as dhcp server for voip phones and have

helper-address only on data vlan back to central below is snapshot of current

configs

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.11

description Corporate Systems

encapsulation dot1Q 11

ip address 10.5.11.1 255.255.254.0

ip helper-address 10.1.2.30

service-policy output BRANCH-LAN-EDGE-OUT

!

interface GigabitEthernet0/0.131

description $FW_INSIDE$

encapsulation dot1Q 131

ip address 10.5.131.1 255.255.255.0

ip helper-address 10.1.2.30

service-policy output BRANCH-LAN-EDGE-OUT

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

Only 11 and 131 has helper-address. I want to keep helper on 11 but take out

helper on 131 and make router a dhcp server. Can I do this or will the router

process dhcp differently? How does the router process dhcp process in this

scenario?

Thanks

1 REPLY

Re: DHCP Ques

Hi,

It should just work fine. While VLAN 131 would get an IP from the router, acting as the DHCP server, the router would forward DHCP request to the helper address configured for vlan 11. IP helper-address applied on the interface should take precedence over the configured DHCP scope in the router itself.

HTH

Sundar

97
Views
0
Helpful
1
Replies