Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP - reserving an address

HI,

I have DHCP enabled on a Cisco 800 series router but I want one laptop to get the same address everytime he connects but I can't seem to get manual bindings working. DHCP issues an address rather than my manual one. AM I doing something wrong? Config looks as follows:

ip dhcp excluded-address 11.11.11.1 11.11.11.100

!

ip dhcp pool local

network 11.11.11.0 255.255.255.0

default-router 11.11.11.1

netbios-node-type h-node

dns-server 11.11.111.5 11.11.111.6

netbios-name-server 11.11.111.5

domain-name groupname.com

lease 30

!

ip dhcp pool Joeslaptop

host 10.11.22.107 255.255.255.0

hardware-address 0100.123a.0b1a.c5

client-name JoeMoriartylap

sh ip dhcp bind

Bindings from all pools not associated with VRF:

IP address Hardware address Lease expiration Type

10.11.11.104 0100.123a.0b1a.c5 Oct 27 2005 12:29 AM Automatic

10.11.11.107 0100.123a.0b1a.c5 Infinite Manual

1 ACCEPTED SOLUTION

Accepted Solutions

Re: DHCP - reserving an address

Are you using secondary address of 10.x.x.x subnet and primary as 11.x.x.x subnet ? I dont think this will work, as Cisco IOS DHCP server doesnt work with secondary address. You definitely can have a secondary pool from the secondary address subnet, but the IOS DHCp server will allocate address only if the primary pool is out of addresses. You will have to setup two vlans on your switch and configure a trunk port to the router and configure the router with sub interfaces to make this happen.

int fa0/0

no ip add

int fa0/0.1

encap dot1q 11

ip add 11.11.11.1 255.255.255.0

int fa0/0.2

encap dot1q 10

ip add 10.11.22.1 255.255.255.0

ip dhcp pool local

network 11.11.11.0 255.255.255.0

default-router 11.11.11.1

netbios-node-type h-node

dns-server 11.11.111.5 11.11.111.6

netbios-name-server 11.11.111.5

domain-name groupname.com

lease 30

!

ip dhcp pool Joeslaptop

host 10.11.22.107 255.255.255.0

hardware-address 0100.123a.0b1a.c5

client-name JoeMoriartylap

On the switch configure two vlans.

Switch#vlan database

Switch(vlan)#vlan 2 name Subnet10

Switch(vlan)#exit

int fa0/24

description trunk to router

switchport mode trunk

switchport trunk encap dot1q

This should work.

3 REPLIES

Re: DHCP - reserving an address

Are you using secondary address of 10.x.x.x subnet and primary as 11.x.x.x subnet ? I dont think this will work, as Cisco IOS DHCP server doesnt work with secondary address. You definitely can have a secondary pool from the secondary address subnet, but the IOS DHCp server will allocate address only if the primary pool is out of addresses. You will have to setup two vlans on your switch and configure a trunk port to the router and configure the router with sub interfaces to make this happen.

int fa0/0

no ip add

int fa0/0.1

encap dot1q 11

ip add 11.11.11.1 255.255.255.0

int fa0/0.2

encap dot1q 10

ip add 10.11.22.1 255.255.255.0

ip dhcp pool local

network 11.11.11.0 255.255.255.0

default-router 11.11.11.1

netbios-node-type h-node

dns-server 11.11.111.5 11.11.111.6

netbios-name-server 11.11.111.5

domain-name groupname.com

lease 30

!

ip dhcp pool Joeslaptop

host 10.11.22.107 255.255.255.0

hardware-address 0100.123a.0b1a.c5

client-name JoeMoriartylap

On the switch configure two vlans.

Switch#vlan database

Switch(vlan)#vlan 2 name Subnet10

Switch(vlan)#exit

int fa0/24

description trunk to router

switchport mode trunk

switchport trunk encap dot1q

This should work.

New Member

Re: DHCP - reserving an address

Sorry - a typo when changing the addresses for the forup - both addresses are on the same subnet. They are sitting at the far side of the router which gives them ISDN access to HO.

Thanks,

Tim

New Member

Re: DHCP - reserving an address

Problem solved. I used client-identifier rather than hardware-address.

Many thanks,

Tim

129
Views
0
Helpful
3
Replies
CreatePlease login to create content